Dell Latitude E6520 won't power up (no lights at all)

By davidson ยท 6 replies
Sep 13, 2013
Post New Reply
  1. Hello,

    My laptop wont power on at all.
    No charge light.
    No light when power is pressed.

    Was working fine yesterday.
    Have tried battery and charger from identical working laptop to no avail.

    Any ideas? I can usually fix laptops etc but if it wont power on at all I'm lost.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Did you try removing the battery and AC adapter and holding down the power button for 30 seconds. Then re-installing the battery and try booting again?
  3. Hi. I am also facing the same issue with my user in my office.Latitude E6530.
  4. I removed the power adaptor and holded the statup button for 30 sec. It didnt resolve. Next, I removed the battery and connected the power and tried. its not working. I again reconnected the adaptor and battery. Still its not working. Even its not showing a symbol or light where battery is getting charged. It is totally not blinking.
    Please help.
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    You need to remove the power adapter and the battery before holding the start up button for 30 or more seconds
  6. junky77

    junky77 TS Rookie

    Does it have a bios reset button?
    It might also be that the motherboard or something related to the electricity is faulty
  7. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    The motherboard may be bad...

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...