Tech Stocking Stuffers: 18 awesome gifts under $50

Dell XPS 420 startup problem

By fizwawiz ยท 5 replies
Feb 8, 2011
Post New Reply
  1. I tried to plug a usb into my broken usb port (broke i day i got it, 3 years ago) and my cpu made the sound of a usb being unplugged from cpu, so then i realized and plugged my flash drive into my working drive, and nothing happened. So i figured, ill just restart my cpu and try again, no big deal. Now it wont do anything. When i plug the power cord in, the only way to actually know that it has power is a yellow "Aux LED pwr) light in the back lights up, and a green blinking light where my ethernet cable would go lights up on and off. There are no lights on my power button, and nothing hapens when i hit it. I can hold down the power button for 30 seconds and the LED light in the back goes out, but thats about it.
  2. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Tricky to say much about this, but it sounds as if your mobo or your PSU has failed.

    The only thing you can do here is to use another known good PSU and see if it will boot and check all the internal connections by removing and reseating them.
  3. 03tellis

    03tellis TS Rookie

    wow, ok I have the EXACT same problem.

    Pressing my power button does nothing. I just turned my Desktop off one night and when I tried to turn it on the next morning it didn't work at all. I didn't consider the relelvance until now but both my front USB slots were broken, but one of them I still used to an extent.

    This is relevent because it seems that in the Dell XPS 420 the power button is connected to the card connected to the front USBs, sound Input/Output ect. This is not a usual way of laying out a Desktop.

    Did you find a solution?
  4. fizwawiz

    fizwawiz TS Rookie Topic Starter

    No i did not... currently my desktop is sitting in my room collecting dust, however my brother said the same thing about either my mobo or PSU failed, so id say thats the best bet. Dell wants like 400$ to fix it, rofl...
  5. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    How much !!!!!! you know what Dell can do, lol.
  6. redx

    redx TS Rookie

    I had the same problem, left for work and when I tried to turn on the comp it did nothing. I initially thought the problem was the power supply, even though I could see that the ethernet light and the amber mobo light were on. I ordered a new power supply and changed it out only to find that things were exactly the same.

    Next step I decided to open things up and have a look. I completely disassembled the front of the computer and disconnected the usb hub from the front. I will also note here that I had just recently yanked one of the usb connections real hard breaking it. Ok so once i had the power button that plugs into the usb hub disconnected I untied the wires. Two or three mini zip ties and then a piece of tape and unwound the six wires. There are six wires and 7 slots in the plug so one of them is not used. The end that has one wire then a space is the one you want. Take that wire and the one on the other side of the space, cut them and splice them together. Now just plug it back in, reassemble and when you plug it in it should start up.

    I had some more problems after this. It just randomly shut off and when I powered down the power supply and turned it back on it would shut off two seconds later. So I took out the mobo battery and put it back in. Restart and it works now. Pain in the *** but I wasn't taking no for an answer.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...