Direct3D Interfaces Something is very wrong here...

By textus ยท 5 replies
Dec 16, 2005
  1. I gotten an old graphic card from my friend and replaced it with my 4mb graphic card that I talked about before. I am currently running nVidia Geforce2 MX400 on P3 computer 550mhz and 128MBRAM. My Sound card is just a Soundblaster Audigy and its plugged to a 5.1 surround sound system.

    I believe Geforce2 MX400 definitely has 3D acceleration as the Test Direct3D function from "dxdiag" is available to me. The test ran fine for the one with 7 interfaces, but the problem began when it ran the 8th and 9th interfaces. I did see the spinning cube, but the faces were distorted, jagged and garbled up with occasional black blinking patches. The same thing happens when I run "MapleStory" a low end online game that requires a graphic card with 3D acceleration.

    My Driver is gotten from the Nvidia official website and the version number as written on "dxdiag" is 6.14.0010.8195. I just downloaded the driver yesterday off the site, so it should be the newest on available. DirectDraw works fine though.

    Hope someone can help me fix this problem, since the garbled up images renders the game nearly impossible to play. I already tried changing monitor frequencies but I don't think that is the problem here. By the way, the problem dosen't occur to the desktop or the usual office programs. But I am sure any games that I run that requires 3D acceleration will have the same problem.

    Thanks alot for any input! Any help is greatly appreciated. :D
  2. tchiseen

    tchiseen TS Rookie Posts: 45

    update your direct X from

    but the real problems is you need a new computer. that's about the only thing i can suggest. if i were you, i would throw my old computer out the window and start from scratch. call dell and see what's the cheapest machine you can get, and it'll be 100 times better than what you've got now.

    good luck
  3. Federelli

    Federelli TS Rookie Posts: 361

    Unfortunatedly, tchiseen is right. Although you should try every single driver version from Nvidia, starting from the latest, to the oldest, that works best for you.
  4. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,088

    The graphics card itself is the problem,as it only supports DirectX 7,where the game you mention requires a card that supports DirectX 8.1.Your only option is to get a card that supports DirectX 8.1 or higher.Here's a list of cards and the the DirectX version they support.
  5. textus

    textus TS Rookie Topic Starter

    Okay here is an update and an overview of the problem. I try to be as detailed as possible so please don't mind the lengthy post.

    Here goes, previously I had this lousy 4MB Cirrus Logic Laguna GD5465 Graphic Card which worked fine for any office applications. However it doesn't support 3d acceleration hence the "test direct3d" button in "dxdiag" is not available to me. I can't run games like Maplestory, a low end online computer game. After hearing suggestions from a previous thread here, I decided to get myself a better graphic card.

    I got a friend who just bought a new computer and decided to just sell me his old graphic card at S$20. I thought it was quite a good deal since its a 32MB Geforce2 MX400, way better than my 4MB graphic card. I brought it home and replaced the old graphic card. Windows installed its own driver for the graphic card and all was well. The "test direct3d" button in "dxdiag" was still not available to me and I still can't run MapleStory. So I figured it had to be the windows driver.

    I decided to download the latest driver off the official nVidia website since my friend didn't know where the stock cd went. I installed it in and viola!, the "test direct3d" button in "dxdiag" becomes available to me. I ran the test and the 7 interface direct3d test looked fine. The problem came when i ran the 8 and 9 interface tests. The DirectX cube faces were distorted and its images were garbled up. It jaggy black patches that blink on the cube. I ran MapleStory and the game images were all distorted and jaggy and some patches of it were stretched.

    I went on to the forums and made a search on my geforce2 mx400 to find out the problems. It seem that they were many comments that the latest graphic card dosen't work best with geforce2 mx400 since its quite an old card. Some threads even talk about how the card is a directx 7 card and dosen't work well with 9.0c (the version i am using).

    Nonetheless I went on to download an older version of the driver from I uninstalled the latest driver and installed the older version driver. When windows startup it shows that a new hardware is found despite already installing the old driver. I went through all the hassle of uninstalling the driver and finding another old driver to use.

    On the 3rd old driver I found and installed. Upon restarting the computer and after the windows xp loading screen, the monitor went into a no signal mode. I figured that was a bad driver and reset the computer and entered Safe Mode. I uninstalled the driver and restarted the computer. Windows booted normally and it detected the new hardware. It attempts to install its own driver for the graphic card. But after installation, the screen turns pitch black and it goes into a no signal mode again.

    I started to panic and reached for the reset button. After pressing the reset button, I waited for like 3 seconds and I heard a beeping tune from the cpu something that went like "Tu... Tu Tu Tu". It seems it couldn't be reset. So I went ahead and switched it off.

    I went on to the forums on my other computer and found a thread that had the same garbled up image as me and the person also uses the same card. Someone replied to him saying in Bios the video aperture is limiting the graphic card's ability or something like that. However I ignored that thread and went back to the computer as I knew it is probably too late... T_T

    5 minutes later, I turned the computer back on and the same tune came from the cpu again. "Tu... Tu Tu Tu". Immediately I knew my graphic card might have died, it might have been burnt T_T. I opened the cpu up and retrieve the "corpse". (The card dosen't look burnt) I placed back the 4MB graphic card and went for the power button again.

    "Tu... Tu Tu Tu" ZOMG... the same sound again. I am currently at a loss at what could be the problem. Afterwhich i power down the computer and switched off the main switch. I went to the refuge of my AMD64 computer to post this. I hope anyone here can tell me what the problem is, how I can save my computer, or is it true the graphic card is burnt? Looking on the brighter side and if the card is actually not burnt and if I am able to solve the problem of my computer, is there a way to allow the game images to quit being so distorted? How true is the Bios video aperture limiting the capabilities of the graphic card?

    Should I return the graphic card to my friend immediately and get back my money, or do I do some method that you all might suggest? I am completely at a lost now. This is probably the first time something died on me. T_T Please help, any input is appreciated. Thanks.

    P.S. Don't really know why but all my threads seems so empty with hardly anyone replying...T_T Are my problems really that hopeless? :(
  6. Federelli

    Federelli TS Rookie Posts: 361

    If the beeps are as you describe, then your AGP slot is fried.

    Try resetting the bios, by using the jumper on your mobo, if that works, you are safe.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...