1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Do routers get viruses or malware?

By vegasgmc
Dec 1, 2012
Post New Reply
  1. I'm having a weird problem with my router. Its an SMC SMCWGBR14 300mbs Gigabit switch model. Works perfectly except several times a week when I'm on ebay , the pages will start showing up in Chinese, I get directed to ebay.cn or I get Forbidden 403. It lasts for about 30 minutes and then goes back to normal. This only happens with ebay. I called them about it and they knew nothing but a web search shows this is a very common problem on the east coast with people using Verizon. I'm on the west coast using Centurylink. It also happened when I had Cox. I tried returning the router to factory defaults and upgrading firmware but that didn't help. I've taken my desktop off the SMC and connected it to a Netgear and the problem went away on the desktop but still happened on my laptop so I'm sure its just the router. I've run virus , malware and rootkit scanners on all PC's and they come up clean. I hate to get rid of this router, it runs every internet enabled device in the house like a champ but I run a business on ebay and its caused some major problems lately. Would flashing it with Tomato or something like that help? Thanks for the help.
  2. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 9,162   +3,260

    Then its not an issue with you specifically.

    Take this as I'm thinking out loud as I don't know for sure. The virus would need to overwrite the router's firmware and be specific to each model they infect. A BIOS or Firmware virus would be a non-productive effort in creating them.
  3. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    the short answer is YES

    but that means
    1. remote management was allowed
    2. the passsword was not changed at the time of install
    3. the firmware was updated maliciously
    If you're really convinced this has occurred, then the solution is trivial
    1. download a fresh copy of the firmware for that device
    2. reset the hardware (there's a paperclip hole for this)
    3. login after the reset
    4. IMMEDIATELY set a new admin password
    5. now load the new firmware from (1)
    6. IMMEDIATELY reset the admin password again
    7. disable remote management
    8. configure your Router, DHCP range and any applicable WiFi settings

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...