Downloading run/save files and or software via IE 7

By Feisty49 · 5 replies
Jan 17, 2007
  1. Every time I attempt to run a file from the Internet using IE 7, I get the following error message: “Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item.” Sometimes I can save the file, instead of running it, but sometimes IE won’t even allow that. The most recent example occurred today at the website I wanted to look at the IT-150 Short Form (listed on the left side of the page), which uses Adobe to read, and I got the above noted message.

    This problem started a few weeks, maybe even a couple of months, ago when I upgraded to IE 7.

    Please note that the computer which is denying me permission is my personal machine in my home. I am the only person who uses it.
  2. halo71

    halo71 TS Rookie Posts: 1,090

    Why dont you try and download the Firefox browser and see if you still get the same error. You can download it from the link below.

    EDIT: I would recommend you use Firefox over IE. Its a little more secure!!!
  3. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    I couldn't make your link work halo71, no place to actually download, even clicking that tab. Why did you link to that rather than anyway?

    Plus Opera is better :p

    I think the problem is likely due to the default security settings in IE7, but I don't use that browser so I'm not sure what to look for - should be fairly obvious though. If that fails, re-download Acrobat Reader.
  4. halo71

    halo71 TS Rookie Posts: 1,090

    Sorry about it not working for you. It worked fine for me. Thats why I linked it.
  5. Feisty49

    Feisty49 TS Rookie Topic Starter Posts: 17

    Thanks for the replies. I did run the file using Firefox, which I've used as a browser now and then for a couple of years. Thing is, I do prefer IE -- go figure. :) My preference is what it is and I doubt I'll change now so I do wish I could figure out why it gives me problems. By the way, I mentioned that it was an Adobe run that was giving me problems, but it's all files, not just an Adobe read one.
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Go into Programs, Accessories, System Tools, Internet Explorer (No Add-ins) and run it. See if the problems disappear
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...