driver_irql_not_less_or_equal plz help

By Seldszar · 198 replies
Aug 22, 2005
  1. x_Aces_x

    x_Aces_x TS Rookie

    Similar probs

    Hi all

    I have started having trouble over the last few days regarding windows. I've noticed when I get the BSoD and it reboots, the CPU make and model isn't displayed at the BIOS bootup(tried 2 different CPU's by the way). From a cold boot the CPU is displayed as normal.

    I get a BSoD when I launch a DVD or DVD software (movies) and random BSoD when launching games. Heres the dumps and thanks in advance ;)
  2. FraglessOne

    FraglessOne TS Rookie

    I think I found my problem. One of my gpu's was overheating. GPu 1 was reading at 64 c after the crash while gpu 2 was reading a nice and cool 40 c, my cases ambient temperature is around 39 and 40, just on of my gpu's is overheating resulting in the bsods, hence more crashes during hl2 and counterstrike source. I am using aftermarket coolers on both gpu's. NV silencer 6 rev2 on both. I have re-added my side panel fans that are over the gpu's to see if that helps. also I am going to recheck my gpu cooling and make sure that it is correctly applied, make sure the arctic silver is correctly applid. But the overheating of the one gpu seems to be the casue of my crashing.
  3. FraglessOne

    FraglessOne TS Rookie

    note: I am fanatic about dust, dust is most certainly not an issue in my computer. I go through a can of air every 2 weeks :p
  4. tigermuppetcut

    tigermuppetcut TS Rookie

    Same problem

    Hi I have a pretty nice PC but it constantly bombs to the BSOD. It does it most often when running a bit torrent client and downloading / uploading files, it has also done it during an adaware scan.

    Other poblems include a windows start up time of around 5 - 10 minutes, and longer for a shut down. Some larger .exe files take a long time to open.

    The RAM is seated nicely, the cables have been plugged and unplugged to check connection. The Maxtor drive is set to 4th primary IDE.

    I checked Hi-jack this and after analysis it looked fine.

    I've attached my dxdiag info.

    I really hope you can help I've exhausted all the other options I can thing of, I've scanned with AVG and Norton for boot sector viruses, I've run Registry Fixer etc. etc. Thank you so much for doing this for everyone.

    Below are my minidumps:

    Event Type: Error
    Event Source: atapi
    Event Category: None
    Event ID: 9
    Date: 08/10/2005
    Time: 20:14:32
    User: N/A
    Computer: NEW_PC
    The device, \Device\Ide\IdePort2, did not respond within the timeout period.

    For more information, see Help and Support Center at
    0000: 0f 00 50 00 01 00 a4 00 ..P...¤.
    0008: 00 00 00 00 09 00 04 c0 .......À
    0010: 00 01 00 00 00 00 00 00 ........
    0018: 00 00 00 00 00 00 00 00 ........
    0020: 00 00 00 00 00 00 00 00 ........
    0028: 00 00 00 00 00 00 00 00 ........
    0030: 00 00 00 00 07 00 00 00 ........
    0038: 40 00 00 0e 00 00 00 00 @.......
    0040: 00 20 0a 12 40 03 20 40 . ..@. @
    0048: 00 00 00 00 0a 00 00 00 ........
    0050: 00 f0 a4 f7 30 c5 77 86 .ð¤÷0Åw?
    0058: 00 00 00 00 60 37 d7 86 ....`7×?
    0060: 00 00 00 00 e7 70 8c 10 ....çp?.
    0068: 28 00 10 8c 70 e7 00 00 (..?pç..
    0070: 31 00 00 00 00 00 00 00 1.......

    Event Type: Warning
    Event Source: Disk
    Event Category: None
    Event ID: 51
    Date: 08/10/2005
    Time: 20:17:08
    User: N/A
    Computer: NEW_PC
    An error was detected on device \Device\Harddisk0\D during a paging operation.

    For more information, see Help and Support Center at
    0000: 03 00 68 00 01 00 b6 00 ..h...¶.
    0008: 00 00 00 00 33 00 04 80 ....3..?
    0010: 2d 01 00 00 00 00 00 00 -.......
    0018: 00 00 00 00 00 00 00 00 ........
    0020: 00 00 00 00 00 00 00 00 ........
    0028: 35 8c 00 00 00 00 00 00 5?......
    0030: ff ff ff ff 03 00 00 00 ÿÿÿÿ....
    0038: 40 00 00 0e 00 00 00 00 @.......
    0040: 00 20 0a 12 40 03 20 40 . ..@. @
    0048: 00 00 00 00 0a 00 00 00 ........
    0050: 00 00 00 00 e8 cc 77 85 ....èÌw?
    0058: 00 00 00 00 68 0c 5d 85 ....h.]?
    0060: 00 00 00 00 3f 24 9c 10 ....?$?.
    0068: 28 00 10 9c 24 3f 00 00 (..?$?..
    0070: 28 00 00 00 00 00 00 00 (.......
    0078: 00 00 00 00 00 00 00 00 ........
    0080: 00 00 00 00 00 00 00 00 ........
    0088: 00 00 00 00 00 00 00 00 ........

    Event Type: Error
    Event Source: System Error
    Event Category: (102)
    Event ID: 1003
    Date: 08/10/2005
    Time: 20:14:53
    User: N/A
    Computer: NEW_PC
    Error code 100000d1, parameter1 00000008, parameter2 00000002, parameter3 00000000, parameter4 f7593848.

    For more information, see Help and Support Center at
    0000: 53 79 73 74 65 6d 20 45 System E
    0008: 72 72 6f 72 20 20 45 72 rror Er
    0010: 72 6f 72 20 63 6f 64 65 ror code
    0018: 20 31 30 30 30 30 30 64 100000d
    0020: 31 20 20 50 61 72 61 6d 1 Param
    0028: 65 74 65 72 73 20 30 30 eters 00
    0030: 30 30 30 30 30 38 2c 20 000008,
    0038: 30 30 30 30 30 30 30 32 00000002
    0040: 2c 20 30 30 30 30 30 30 , 000000
    0048: 30 30 2c 20 66 37 35 39 00, f759
    0050: 33 38 34 38 3848

    Event Type: Error
    Event Source: ipnathlp
    Event Category: None
    Event ID: 32003
    Date: 08/10/2005
    Time: 21:27:53
    User: N/A
    Computer: NEW_PC
    The Network Address Translator (NAT) was unable to request an operation of the kernel-mode translation module. This may indicate misconfiguration, insufficient resources, or an internal error. The data is the error code.

    For more information, see Help and Support Center at
    0000: 1f 00 00 00 ....

    Event Type: Warning
    Event Source: Rasman
    Event Category: None
    Event ID: 20027
    Date: 08/10/2005
    Time: 21:27:55
    User: N/A
    Computer: NEW_PC
    Remote Access Connection Manager failed to start because NDISWAN could not be opened.

    For more information, see Help and Support Center at
    0000: 02 00 00 00 ....

    Also arecent error which seems consistent is:
    (0x00000008, 0x00000002, 0x00000000, 0xF7593848)

    NDIS.sys Address F7593848 Base F757L5000 Date 41107ec3
  5. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    The culprit is nVidia Firewall. Unstall or upgrade nVidia Firewall.
  6. kamiryu

    kamiryu TS Rookie


    I have the driver_irql_not_less_or_equal when I start up my computer... The files in minidump do not correspond with the date that this error occurred, they're approximately 1 month too early, and each of the other files are earlier than that. I had this error before and fixed it with system restore, but now for some reason system restore is disabled by my computer. it says to restart it in normal mode (non-safe mode) and enable it, could someone tell me how to enable system restore from safe mode or how to fix this error :S I'm extremely confused.

    Thanks in advance.
    -Mike :angel: :bounce:
  7. kamiryu

    kamiryu TS Rookie

    ps the error contains the following i think... i can't see it to clearly


    (0x00000000, 0x00000002, 0x00000000, 0x00000000)
  8. Nataly

    Nataly TS Rookie

    Hello to everyone!
    I have similar problems with my pc - it restarts repetitively and I am not able to find the reason. It looks like the problem is not related to any activity and it happens in different time. Iam running windows xp proffesional sp2 all updates.

    Event Type: Information
    Event Source: Save Dump
    Event Category: None
    Event ID: 1001
    Date: 10.10.2005 г.
    Time: 07:00:11
    User: N/A
    Computer: SOLTEKINC
    The computer has rebooted from a bugcheck. The bugcheck was: 0x1000008e (0xc0000005, 0xbf83e9d2, 0xb933cc68, 0x00000000). A dump was saved in: C:\WINDOWS\Minidump\Mini101005-01.dmp.

    Thanks in advance
  9. kamiryu

    kamiryu TS Rookie

    with mine I figured out how to fix it, I had to disable a driver and uninstlal a few programs, the blue screen of death has always for me been assosciated with bad wireless drivers... I'm not very good with comps but I guess U should check out your wireless networking drivers if u can and I'd recommend using system restore or a program like ghost :p they're pretty handy.
  10. tigermuppetcut

    tigermuppetcut TS Rookie

    Kamiryu... interesting I have a wireless network. a Linksys (Wireless - G WRT54G) router and an X-Micro WLAN 11g USB Adapter.

    How could I get new drivers / upgrades / whatever it is I need to fix this, any ideas?

    I really hope something like this is my problem and not the Ram / HDD :(
  11. kamiryu

    kamiryu TS Rookie

    well you could try the microsoft updates, u could do a search for it, go onto the company's site and try to find an update for ur driver, or you could go into device manager and rollback or uninstall the driver.

    what does ur problem say? mine was a
    (0x00000000, 0x00000002, 0x00000000, 0x00000000)

    and if urs is different it could be your hardware :S
    also sometimes u can turn cachéing off of your motherboard, I've heard it helps for people sometimes, but I reall ydon't recommend it lol, everything runs REALLY slow :giddy:
  12. tigermuppetcut

    tigermuppetcut TS Rookie

    kamiryu - close started with 0x000000D1, but the rest was:
    (0x00000008, 0x00000002, 0x00000000, 0xF7593848)

    I have all the latest windows updates and there is no driver update for my USB wi-fi adapter. :(
  13. ElMacovich

    ElMacovich TS Rookie

    Also got the driver_irql_not_less_or_equal.

    Should be really happy if someone could take a look at my minidump as I attached.

  14. gotgame3

    gotgame3 TS Rookie


    Can someone that knows how to read minidumps and can help me out, please email me at, or add me to msn, i would really appreciate it.
  15. Mike2H

    Mike2H TS Rookie

    Also got the driver_irql_not_less_or_equal.

    I have also got the driver_irql_not_less_or_equal.
    And also had this error some times: Mulitple_IRP_Complete_Requests.

    System Specs:
    Coolermaster RealPower 450W
    AMD Athlon 64 X2 4400+ BOXED (Socket 939) *Toledo-core*
    Corsair 2x512MB PC3200@233 TwinX DDR SDRAM
    Asus Nvidia EN7800GT/2DHTV 256MB DDR3 SDRAM (PCI-E)
    Western Digital 200GB (WD2000JS, 7200RPM, 8MB, SATAII)
    Asus A8N-SLI

    I run windows XP with integrated SP2.

    (BTW when i booted up this morning i first got the driver_irql_not_less_or_equal screen..and a restart gave me alot of artifacts when starting up...uh oh.... :( )

    I did install the latest nForce4 AMD driver...after installing all parts it was about to finish the installation...but it gave this strange error:

    3 of my last minidumps are here:

    The most common time it occurs:
    When i bootup and when msn is auto-logging in.
    When i close msn quickly at startup and later start msn i do not get any problem..but the problem then occurs after a while...a little later..

    I understand people on here got alot work to do with checking these minidumps, but you do help people like me out very much.
    I hope there is someone who can help me fix the problem.

    You can contact me at:

    Thanks alot for your time.
  16. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Hi Mike2H,

    The culprit is nVidia FireWall. Upgrade or de-install nVidia Firewall.
  17. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Hi ELmacovich,

    I've studied your minidumps and it is hardware problem. It maybe faulty CPU or RAM.
  18. MJoannides

    MJoannides TS Rookie

    I have read thru this forum and am also having the IRQL_not_less_or_equal BSOD. Prior I was receiving the worker_thread_returned_at_bad_IRQL error. I reinstalled the OS and was good for a few days, but the error is back. I also updated by BIOS version.
    Could someone please read through my minidumps? I'm also attaching my pstat. Thanks so much!

    Also, here's my bugcheck codes:The bugcheck was: 0x000000d1 (0xbfdb3b90, 0x00000002, 0xbfdb3b90, 0x82004bd8).
    and 0x000000d1 (0xbfdb3b90, 0x00000002, 0xbfdb3b90, 0x820076b8).
  19. ElMacovich

    ElMacovich TS Rookie

    Thanks a lot for that quick answer! Now I'm gonna take a look at the hardware...

    Respect to you for helping me and all of us!!!
  20. ElMacovich

    ElMacovich TS Rookie

    One more question...

    Why is this driver_irql_not_less_or_equal happen for so many people now? My friend and I got this for the first time almost at the same day. That's weird I think... What do you think?
  21. Aesrith

    Aesrith TS Rookie


    I know you're getting a lot of requests but would you be able to help me out?

    I'm getting the same error when I'm patching one of my games:


    So I went into the minidump folder and found the most recent dump.

    Here it is, thanks in advance.
  22. IT Girl

    IT Girl TS Rookie

    I would start first with getting rid of the Mcafee crap and the free anti stuff and invest in something that has it all for 50 bucks. PC Chillin Rated highest in PC magazine for virus protection and spyware removal. i have it on my network and home PC and it is better than anything i have delt with. Plus it will be less space on your harddrive since its all in one. Just a suggestion.

    Go to and do their free online scan. that is the best way to tell your antivirus isn't working like it should.

    I always believe if its free there's got to be something wrong with it or its a virus its self. :p
  23. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    We need to see some more minidumps, as it`s very difficult to give you advice from just one minidump.

    your minidump crashes at tcpip.sys.

    This may, or may not have something to do with your internet connection.

    Take a look HERE for a possible solution.

    Regards Howard :grinthumb
  24. Aesrith

    Aesrith TS Rookie

    I followed the steps stated there, unfortunetly it didn't solve the problem.

    I've grabbed all the minidumps of today this time, I hope it helps make this problem that much more clearer.

    Thanks for your help so far!
  25. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Two possible causes spring to mind.

    Either your nic(network interface card) has bad drivers, in which case try updating the drivers, or try another nic.

    Or, you have a ram problem.

    Remove your ram stick/s and clean the contacts with an eraser. Blow away the remnants and replace, one stick at a time, and test your system.

    You can also download the Memtest86+ from

    Test each stick of ram individually, and let the programme run for at least seven passes. If you don`t have a floppy drive, there is a pre-built iso version available, that you can burn to cd, and then boot from that.

    Note. Some faulty ram can pass Memtest. If Memtest shows errors with your ram, then your ram is bad.

    Also please be aware, that I`m only learning to analyze minidumps, and it is possible that the info I have given you maybe wrong.

    If you want to wait for cpc2004 to confirm, or otherwise what I`ve said, then that is a sensible way to proceed.

    I have been informed that faulty ram is the more likely culprit.

    It could also be an overheating problem. Check you system temperatures.

    Regards Howard :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...