dvdrom no longer works

By Casia01 ยท 11 replies
Dec 11, 2006
  1. okie folks, after cleaning this computer till it had a clean HJT log, I have suddenly found that drive d:, you know the nice little drive that reads all your cd and dvd needs, no longer shows up...

    upon inspection of the device manager, it says driver not found/corrupted or file missing.

    Of course i couldn't rollback the driver (i tried) cause i did all my work with sys restore off and so on and so on.

    So I do all the troubleshooting and windows searching thing to try to restore missing folder so I can run a disk.

    No go there.

    Here is what I am doing, please let me know if it is the right thing...
    From another computer..
    I am taking a windows disk and saving it to a 1gig jump drive and going to use it on the damaged comp for the driver search to locate its missing files for download.

    God I hope I am making sense to you all. Please let me know and dear God how I hate an emachine
  2. Rik

    Rik Banned Posts: 3,814

    Have you tried uninstalling it in device manager then rebooting to see if windows sorts it out??
  3. Casia01

    Casia01 TS Rookie Topic Starter Posts: 23

    Well, I tried uninstalling it then looking for hardware changes then rebooting the computer. But I will try uninstalling and then rebooting alone to see if that helps.

    If that doesn't work, would win files on my jump drive help?
  4. JimShady23

    JimShady23 TS Maniac Posts: 373


    You can get a DVD burner of $25.....If you spend another hour trying to figure out that it is dead.....you just waisted $25 worth of you time lol
  5. Rik

    Rik Banned Posts: 3,814

    If it worked before spyware but not after then spending $25 on a new one wont make any difference at all!!!!
  6. Casia01

    Casia01 TS Rookie Topic Starter Posts: 23

    Jimmy Dear, I promise you it isn't the dvd burner ;) just a missing file/driver

    Rik, the parental units are already asleep, so I will have to drive over to their house in the morning. I will let you know how it works out..
    thanks in advance
  7. JimShady23

    JimShady23 TS Maniac Posts: 373

    Update Driver

    All cd/dvd drives use a windows unified driver.....

    In device manager instead of rolling back the driver did you try the "Update Driver" option ? Then allow the update to check the internet for the driver.

    But yeah take that step after you uninstall the device and reboot. As rik said windows may just sort it out by itself
  8. Casia01

    Casia01 TS Rookie Topic Starter Posts: 23

    I tried the update driver also before I posted the thread. I'll let you all know if Rik's idea works before I have to go about trying to manually replace missing files/folders

    Lord I hope it works I am so friggin' tired of emachines
  9. Casia01

    Casia01 TS Rookie Topic Starter Posts: 23

    Sorry guys, none of the ideas work.
    I am thinking that I need to check to see if it is even detecting it in the BIOS?
    any ideas, comments, or tuts on the bios idea, could really use all of ya'lls brain power here

  10. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,088

    Try uninstalling whichever IDE channel it's on via the device manager. If you don't know which one then just uninstall the controller. When you reboot, Windows should find a new device and install the drivers.

    Look under IDE/ATAPI controllers in the device manager.
  11. Casia01

    Casia01 TS Rookie Topic Starter Posts: 23

    ok, before I do that, are you absolutely 100% positively sure that is will reinstall driver and controller? and do you mean uninstalling IDE/ATAPI itself and not any of the items in the dropdown?
    Brain if totally fried at this point, I will be your humble pupil if you can walk me through this
    Many thanks,
  12. Casia01

    Casia01 TS Rookie Topic Starter Posts: 23

    Okay peeps, I am going to first try the emachine website where they link to the computer to find and resolve the issue, as well as their online chat (don't try to call them) and if that doesn't work, I will then try her emachine restore disk, and if that doesn't work, I will save her personal stuff and reformat and redownload everything...
    Brain trully hates emachines...
    Probably be next week before I get to do this, she is going out of town to visit my sister and her kids.

    Again if anyone has any other ideas, I would love to here them I don't like the idea of reformatting the hd.
    Also still going to FIRST try the bios thing and see if that doesn't work

    keeeping my fingers crossed


    May I please request an admin to move this thread to the device driver forum, as the more I search the more I realise that this isn't an os issue and I put this post in the wrong forum.
    I am sorry
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...