Emachine T2460 & the dreaded video card upgrade.

By lindseyjena ยท 13 replies
Nov 11, 2005
  1. I have read a lot of posts about problems installing a new video card in Emachines and tried about everything to make mine work to no avail. Well here goes anyway. I have an Emachines T2460 with onboard video Prosavage. I am trying to install a Radeon ATI 9600XT AGP card. There is nothing in the BIOS that me,Emachines or ATI can find to disable the onboard card so i get a code 12 in device manager under the primary video. Not enough resources. Vgasave is using the resources that the card should be assigned to. I can't disable VGA because i get a black screen if i do.
    I found a thread on techspot with the same exact issue which had a link for a fix but when i follow the link it says i don't have permission to view this website. Sigh. Anyone know of a fix? Or can reccommend a video card that WILL work?
    Confucious say: Never buy a PC with an onboard video card. ( Well he would have.)
  2. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    Hi lindseyjena,

    You have a bit of work to do in order to get that aftermarket videocard to work. It can be done, but you have several steps to perform.

    First, get the 5.9 Catalyst drivers from ATI at www.ati.com. If you've been trying to load/install ATI drivers, you should also download Driver Cleaner Pro and run it's Live Update (but not the program itself.. yet). You can get Driver Cleaner Pro at www.drivercleaner.net

    Now, last but not least, you need to get CPU-Z at:

    Unzip CPU-Z and run the executable inside (cpuz.exe) We need to verify what Mainboard your EMachines has. It will be the Mainboard tab at the top. In that section it should say you have an AM37 motherboard. If you listed the proper EMachines in your post, this indeed should be the motherboard.

    If you do have the AM37 mainboard you need to hit this link:

    Download the top, VLB44 BIOS, unzip. Insert a blank floppy and format it in XP as an MSDos Bootable disk (right click the A: drive in My Computer, Select Format, click the "Create an MS-DOS Startup disk" checkbox) then copy the unzipped contents from the above zip to the floppy.

    Now, restart your computer but start smacking the DELETE key to interrupt the power-up sequence. This will put you in the BIOS. You'll need to hunt around in here to disable the BIOS Guardian. You will also need to change the Boot Order to A:/Floppy is at the top of the list. Once this is done, save settings and exit. You should now boot off the floppy you made previously.

    Once booted on the floppy, run the bios flash utility:
    A:> awdflash.exe VLB44.BIN /nbl

    When the flash utility comes up, it will ask you if you wish to save the current BIOS. Say YES. Save it as VLB41. It will then flash and verify the new BIOS. When this is completed, hit F1, remove the floppy and it will reboot into Windows.

    Windows MAY ask you for your Windows KEY upon first boot. Your case should have a sticker somewhere on the side or back with this KEY. If asked, type this key in from the sticker on the case to get into windows.

    After this, perform a RESTART in Windows and once again, smack DELETE to interrupt the power-up tests and get in the BIOS. You will have new options to change. You should hit/change the following:
    a- turn the BIOS Guardian back on.
    b- Change your boot order once more so it will boot the HD first.
    c- You can turn PnP OS to "Yes"
    d- Enable On-Chip USB as this may be set to Disable and any USB devices you may have will not work until you do.
    e- Go into Standard CMOS Setup page and you'll now have a place in there where you can disable the on-board video. If you still have your new ATI card in, you can flip this to Disable, and next boot will come-up on the new AGP card!

    You should then run Driver Cleaner Pro in Safe Mode as Administrator and install the 5.9 (or later) Catalyst drivers from ATI.

    Good luck! Hope this helps.
  3. lindseyjena

    lindseyjena TS Rookie Topic Starter


    Wow your AWSOME! The fact that you took the time to type all that in for me ( a complete stranger ) says volumes about you. I really appreciate this! I have'nt tried it yet but i have no doubt it will work. Sounds fun too.
    Well I'm on it. Wish me luck.
    Thanks again!
  4. lindseyjena

    lindseyjena TS Rookie Topic Starter

    Bios flash

    Well i flashed my bios but i got no additional controls in BIOS to disable the onboard video card. When i boot up to the floppy i get a llong ist of options before it flashs. I chose /PY ( flash memory ) It then goes to a screen that asks for (Source file) then (name backup). It seemed to work yet no BIOS line for disabling onboard video. I messed with it so much it wouldnt boot so i did a full restore. It does ask if i want to save but only after it gives me like 20 choices of what to do on floppy bootup. Any suggestions? Should i just get an Nvidia card and send this back?
  5. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    Hi Jimmie-
    It sounds like you need to re-download and re-make the BIOS floppy. I'm betting you typed the wrong filename at the wrong time, your floppy has a bad block/checksum, or simply copied your existing BIOS onto the new BIOS file on the floppy (i.e. just simply flashing the same old bios you had back on).

    That VLB44 BIOS does have an integrated video prompt on the Standard CMOS Setup page, so the flash isn't going through. Did you make sure to go into the BIOS setup prior and disable the BIOS Guardian? And be sure to call the old BIOS VLB41 and then burn/flash the VLB44 one. If you inspect the BIOS boot-up and post test screens, what does it say? Does it show you have BIOS 44 or 41?
  6. lindseyjena

    lindseyjena TS Rookie Topic Starter


    Hi Shark
    Well i downloaded the VLB44 file again and tried it. Heres what it says:

    File name to program : VLB44.bin
    Checksum: C1D9H
    Save current BIOS as : VLB41
    BIOS-Lockstring does not match with your system

    I checked and do have the AM37 motherboard and i downloaded the VLB44 file from FIC, I'm sure i have the correct one. I'm disabling the BIOS guardian each time too. ( shrug )
    Thanks again
  7. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    HI again Jimmie,
    >>" BIOS-Lockstring does not match with your system"<<

    This is the problem- it wont flash the new BIOS as it doesn't identify your existing BIOS as being a match for the upgrade. The BIOS Guardian can yield a similar error, but I don't think this is it.

    If you are positive you are using the: awdflash vlb44.bin /nbl command line at the floppy prompt, you have four options from which to proceed:
    1) You can contact FIC's support email at the link for the BIOS to see if there is a different revision AM37 that you may have along with an updated BIOS.
    2) You can try the VLB43 BIOS at the same link from above in hopes of better success flashing (the 43 version also has the on-board video disable option)
    3) You can try to disable only in Windows XP the on-board video in the Device Manager (expand the Display Drivers and find your on-board.. click and right-click on Properties). Setting "Device Usage:" at the bottom to "Disabled in this Profile" and rebooting may restore just enough resources to configure the ATI card (but a long-shot).
    4) As you considered, some older NVidia cards require much less I/O config space, such as GF4 Ti-series or MX series. While these videocards are old and obsolete, they are still massively better than your onboard video. It's also a luck-of-the-draw for how much I/O space they will require.

    Of course, getting an updated BIOS is the preferred route as this will enable PnP (Windows can remap all hardware as it needs to) as well as the option to fully disable the on-board video. It's unusual that your AM37 isn't able to flash to the V44 BIOS for the AM37, so I can only theorize there is something wrong with the procedure or you have some odd, rare, unseen revision of this mainboard. Perhaps also trying a screenshot of the Mainboard tab in CPU-Z would be helpful here also as it might yield insight on any clues towards getting it handled.

    I've upgraded a few EMachines T2460's to AGP cards and after flashing the new BIOS, enabling PnP (and dealing with Windows Device Manager remapping EVERYTHING in like 3 boots lol), WIndows Key re-entry, etc.etc.. on-board gets fully disabled fine and any aftermarket AGP 2x/4x/8x card works great. I'm hoping we can get this working for you!
  8. lindseyjena

    lindseyjena TS Rookie Topic Starter


    Heres a snapshot. I tried the VLB43 bios and it did the same thing. I must be doing something wrong somewhere. Been trying to get this done all weekend. I will not give up. I need a good video card and a 2460 processor is plenty fast enough for me,so i Don't want to buy another tower.
    Thanks for the help.

    Attached Files:

    • bios.txt
      File size:
      569 bytes
  9. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    >>BIOS ID: 12/09/2002-KM266-8235-6A6LVF0DC
    >>OEM Sign-On: Version VLB411H

    Everything looks perfect. It's the VLB411H version (the older revision) that the VLB44 is supposed to overwrite.

    I did some hunting/research on the Lockstring error message and could only find that this error happens when windows is running? Did you format the floppy as a bootable system disk? Are you booting off the floppy to a black & white, text only DOS style boot? Or are you trying to run the awdflash program from a dos box in windows? It's important that BIOS Guardian is disabled.. and the boot-order in the BIOS is also set to A: first and the system boots off the floppy. If the floppy isn't booting or if it comes into windows, the boot order is incorrect, the floppy is no good/not formatted properly or similar.

    There are other ways to "force" the BIOS flash, but they require some more tools (uniflash is one of them). I don't believe an Emachine needs this though as it should flash without issue- unless Windows has booted or it's in windows.. or if the Guardian is somehow still enabled.
  10. lindseyjena

    lindseyjena TS Rookie Topic Starter


    I'm using old floppy's. I bet your right. I'll buy new ones tommorow and try again. Thanks Shark
  11. lindseyjena

    lindseyjena TS Rookie Topic Starter


    Well I tried a new floppy but it had the same results. Heres the screen i get when i first boot into the floppy.

    Usage: AWFLASH [filename1] [filename2]
    Filename1:new BIOS name for flash programming
    filename2: BIOS file for backing-up the original BIOS
    <switches> ?: show help messages

    PY:program flash memory
    SY;backup original bios to disk file
    SB:skip bootblock programming
    CD:clear DMI after programming
    LD:destroy CMOS checksum & no system halt for first reboot
    Q1:qualify flash part number with source file
    E:return to DOS after programming
    F:use flash routine in original BIOS for flash programming
    CKS:show update binfile checksum
    PN:no flash programming
    SN:no original BIOS backup
    WB:always programming bootblock
    CC:clear CMOS DATA after programming
    CKSxxxx:compare binfile checksum with xxxx

    I think the first time i flashed it and it took i did something wrong and now it doesnt recognize the program?
    I don't know but maybe i will try downloading the original BIOS and start over.
    Thanks Shark
    PS: I'm a Factory Certified Master mechanic so email me if you need help on a car. I will PM you with my email later.
  12. gary_hendricks

    gary_hendricks TS Rookie Posts: 107

  13. lindseyjena

    lindseyjena TS Rookie Topic Starter


    YAY!!! I finally got it to take! You were right. I missed a space in the initial command and it flashed but not properly. It runs SWEET now. Thanks a ton again! Thanks to Gary for the post also.
    I'll be lurking around on this board now,I see that i can learn alot here.
  14. lindseyjena

    lindseyjena TS Rookie Topic Starter

    Windows product activation

    Well after i changed my BIOS to install my new video card i kept getting a windows product activation screen. It gave me 30 days to activate windows. I clicked activate and it says already activated. Well i called Microsoft and they said itwas activated and itwas Emachines problem. My time ran out and i restarted my PC and it won't let me into my computer. Say's i have to activate windows first. Then i click ok and it says already activated and throws me into a death loop of activate before you can use windows screens over and over. I can only log on in safe mode. Any suggestions? I get no help from Microsoft.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...