Every program generates an error and closes

By Beanbag ยท 15 replies
Aug 4, 2007
  1. This problem started when my friend tweaked around with my laptop to try and fix a problem with my USB external HDD.

    For the past week, I have been getting this error which applies to pretty much every program on my laptop. When I open a program...

    (name of program) has encountered a problem and needs to close. We are sorry for the inconvenience.
    If you were in the middle of something, the information you were working on might be lost.

    This error comes out around 70% I open a program. I am either forced to close the program by pressing on the 'Close' option or drag the window to a space on the screen and use the program.

    I also get this error called dwwin.exe. I understand it's some Dr Watson error reporter but I have no idea to fix it. It comes out along with the first error mentioned. In the dwwin.exe error it says "The instructions at (example) 0x7c883f9c referenced memory at 0x7c883f9c. The memory could not be "written".

    I have noticed that my computer has slowed down considerably and often hangs.

    I can't start any downloads; an attempt to do so will result in my laptop hanging. I found this out by trying to download HJT...

    Any, any help will be greatly appreciated. Thank you very much for taking the time to read this; I've been hopeless struggling with this.

    P.S. If you think it is a must to get HJT, I can download it onto a USB drive (not the spoilt one) on another computer and transfer it onto my current one. Please tell me if you think this is appropriate.
  2. tomrca

    tomrca TS Rookie Posts: 1,000

    if you have clocked it try resetting first. i have seen recently that tweeking programmes can be debtremental to OS. if resetting doesn't work please go to https://www.techspot.com/community/...lware-removal-preliminary-instructions.58138/ and follow all the instructions exactly. after which, poste all required logs such as avg,combo,vundo and hjt. be sure to chang the name of hijack this and place it within its own folder in programme files or docs. eg, C:/prog files/hijackthis/analysethis v_2.exe.

    please post your logs as attachments and not a copy and paste. to do this go to additional options ,attach files and select manage attachments. these are located below the reply box

    this thread is for the use of BEANBAG only, if you have similar problems, please start a new thread in security and the web forum
    if this doesn't work start anew thead in the hardware and tweeking forums
  3. Beanbag

    Beanbag TS Rookie Topic Starter Posts: 41

    Hey, I've run CCleaner and installed some other software you told me to download, and after installing AVG Rootkit I had to reboot. After I rebooted, I've not had a single error whatsoever.

    I have no idea what caused this, but thank you so much for directing me to the page by Howard Hopkinso (thanks to him too!). I can now download files and not receive any error.

    Do you want me to post any logs still so you can find out what went wrong? If you, please do reply. Either way, thank you very much.
  4. tomrca

    tomrca TS Rookie Posts: 1,000

    thank you for your reply, but would you please post an 'hijackthis log' as there may be more. click the word 'hijackthis' in my signature below for the newest version of hjt
  5. Beanbag

    Beanbag TS Rookie Topic Starter Posts: 41

    Hello tomrca, yes, the error somehow came back, but I ran CCleaner again and restarted and so far nothing but I haven't opened any other program than Firefox to access the forums.

    I have just run HJT. Here is the log in an attachment. Once again, thanks a lot for your help.
  6. tomrca

    tomrca TS Rookie Posts: 1,000

  7. Beanbag

    Beanbag TS Rookie Topic Starter Posts: 41

    Hi tomrca, I have run NoLop (Search and Destroy) and it has turned out there are no errors detected by it.

    I have fixed the O4 realtek thingy you listed above.

    What's next? And, thanks for all the help so far.
  8. tomrca

    tomrca TS Rookie Posts: 1,000

  9. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    Is the clue here something to do with the external drive? If the "tweak" messed around with allocated drive letters maybe this is what is causing all (?) programs to stop with the same error message.
  10. Beanbag

    Beanbag TS Rookie Topic Starter Posts: 41

    Hi, I have fixed all you suggested, anyway I have already stopped using Lycos Mail.

    Albert, what you posted seems to likely be the answer, but how did CCleaner/anything stop the errors from coming?

    Once again, thanks for both of your help.
  11. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    CCleaner is one of those utilities that mucks about with the registry and I treat these with suspicion. I have no idea what it did - perhaps just be grateful?!
    No disrespect to your friend who tried to help, but a fix that reduces a PC to a knot of electric string is no fix in my book.
    Glad to have helped
  12. Beanbag

    Beanbag TS Rookie Topic Starter Posts: 41

    Well, since CCleaner seems to be used by most people, it seems to be okay... However, my IE browser doesn't work but my Mozilla does. Weird but not affecting much...

    Yes Albert, I agree, a registry cleaner usually failed me but this one hasn't yet. Hope it doesn't at all. Maybe that old cleaner actually messed up my com since my friend used it to try and fix my laptop when I had the USB problem.

    Anyway, you may want to know my external HDD works fine without being screwed into the casing. I have no idea why. And as always, your posts are really appreciated by me :).
  13. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    Thanks Beanbag!
    External HDD won't work in the casing - interesting. The only time I have ever come across this before was with a SCSI drive that shorted out to earth and stopped working when it touched the chassis. Perhaps you could try fitting it into the case with rubber grommets if there is space?
  14. Beanbag

    Beanbag TS Rookie Topic Starter Posts: 41

    I don't have the HDD now, left it at school for the time being. What are rubber grommets? Are they some kind of stuff the fill the space up in the casing? Thanks.
  15. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    Like little rubber tubes that fit round the mounting screws to stop the shank of the screws touching the drive chassis. The computer or external drive chassis must have the right size holes to take the grommets, however.
  16. Beanbag

    Beanbag TS Rookie Topic Starter Posts: 41

    Okay, thanks, maybe I'll get some of those, but for now I'll stick to my literally "naked" external HDD; not sure if the risk is worth it though. 40 GB is something to think about as it's 40% of my main HD.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...