Excel Mystery

By macx ยท 7 replies
Nov 22, 2008
  1. Have used Excel for probly15+ years (?)

    Just recently had a problem with my Zone Alarm security suite, so got rid
    of it and installed Comodo per the recommendation of Mr Flynn.

    Seemed to work fine.

    When I tried to open Excel, I started getting Comodo windows saying somethng about Excel was tryng to contact the parent application or something like that and, if I use Excel regularly, it was OK to do that. So I OK'd it.

    But now when I open Excel, all I get is the application, not a new file.
    And when I saved an Excel file, it seems to go someplace else.
    When I reopen it from the icon, all I get, again, is the application,
    and not my saved file.

    What happened?

    How do I get "back to normal"?
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    I've seen this
    When I did see it, I ran:
    Memtest; and
    Antivirus\Malware scans
    Repaired Office (in Add\Remove programs)
    And ran sfc /scannow

    One of them fixed it ;)

    Start with Office repair
  3. macx

    macx TS Evangelist Topic Starter Posts: 718

    My Excel file isn't corrupted, it is just "disconnected" from the application and stored elsewhere when I save it - I was able to find it with a search.

    It seems it started when I started using Comodo - I had never seen those security windows telling me about the "parent" application (.exe) running the app on my computer - so it isn't a case of corrupted data, it's something in Excel, like the Excel I'm now using is some Excel "mother ship" some place that opens a new worksheet on my computer when I try ot open Excel. Even after I saved a file, all that opens when I open that saved file is the app itself, my saved file is elsewhere on my computer and, of course, is hard to find.

    From what I see on Office Repair that to repair corrupt data?

    I'll take a look at those others, but I think it's some kind of command somewhere in Excel, or in Comodo, that I need to turn off or something like that.

    I'll keep digging.

    I've very recently spent 2 days running all kinds of Spyware and Malware and anti virus stuff on my laptop while I was fighting that Zone Alarm problem. One thing about the ZA, I've never had number 1 virus or spyware get thru it.

    But I'll try again - I recently switch from ZA to SUPERantispyware and MalwareBytes plus the Comodo av, so I'll try them again.
  4. mflynn

    mflynn TS Rookie Posts: 2,655

    Mac Mac mac

    Turn off Comodo long enough to test if problem exists with Comodo off.
    If not then this is apparently Comodo.

    If it still exists then likely not a Comodo issue, so do the Office repair and test if corrected with Comodo still off.

    The Office repair in Add/Remove Programs only repairs Office executable's and settings and does not touch the data in any way.

    When you search for your spreadsheet where is it, and are you finding the actual file or a shortcut to it, should be both.

    If corrected then restart Comodo and if back then it is Comodo.


    PS I told you once before Mr. Flynn was my dad! me I'm just Mike!;)
  5. macx

    macx TS Evangelist Topic Starter Posts: 718

    Here's where my general lack of detailed knowledge on these things shows in glaring fashion - and why I come here for help.

    I have been on Add/Remove Programs several times and can't find a single thing that remotely resembles Office Repair, or Repair Office, or anything with either word contained in it.

    Where is it?

    In the meantime, I'm continuing scanning but coming up totally clean so far.

  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Start->Run-> appwiz.cpl

    Maximize the Window
    Scroll down to Microsoft Office
    Single Click on it
    Click on Change
    Click on Repair

    Follow any other prompts
    Test again
  7. mflynn

    mflynn TS Rookie Posts: 2,655

    You may or may not need the Office CD.

  8. jobeard

    jobeard TS Ambassador Posts: 11,170   +987

    I've lived with this too, but let me recap;

    (1) dbl-click an excel.xls and you get a new, empty document.
    (2) dbl-click again on the same document (or even any other) and the file loads.

    it's NOT the file type association to Excel as (2) works fine.

    I've given up and resorted to this procedure;
    PIN Excel (and Word) to the Start Menu
    Launch the application by itself
    then dbl-click the document of choice (or use the Recent File list)​

    It is not Comodo per se, as I'm running Sunbelt (but was a previous Comodo user)
    and Comodo was uninstalled.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...