External Hard Drive Not Detected

By meilinuk ยท 6 replies
Dec 26, 2008
  1. I have a Maxtor Diamondmax Plus 9 160GB hard drive. It came in an external casing which became tatty and so I bought a new one. Well the new enclosure didnt work and so I have only just got a new one after about 11 months.
    The problem I now have is that my computer will not recognise it. I'm running on Windows XP Home, and the hard drive did work on there before I put it in the new enclosure. I have tried the jumpper settings suggested by Maxtor and it doesn't work. The only way I can get the computer to show it is by putting the jumppers on Cap Limit, then it shows a 31.50GB hard drive. I can not format the drive, I have too many things on there that can not be replaced.

    If anyone can help me at all, then please I would be very very greatful.

  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    What types of interface are you using to connect computer / external drive?

    What interface options drive and its enclosure?

    "Computer doesn' recognize it" also leaves a gap of unanswered questions including at which point is it not recognized?

    Is it recognized by Devmgr? Are attachining via USB or other? Cause couldn't even ask what "not recognized means" until i know what should be expected.

    In generalization:
    - Recognized in devmgr (if that simply mean "i can see it listed under Disks, so yes." There can be still further criteria required before you could say "yes" for DevMgr so that answer is still an am not sure)

    Do you see it at all in Explorer? Or do you see it but with no drive letter assigned?

    Same for Disk Managment, it';s drive letter shown there? does it appear as a disk there?

    So please translate "not recognized"
  3. meilinuk

    meilinuk TS Rookie Topic Starter

    Right I'm connecting by USB, and I hear the connection noise the computer makes when you plug in a USB device. I can not see the hard drive anywhere on the computer. It does not show up in Device Manager or under My Computer. I have tried several different USB ports on more then 1 computer. I have also tried different USB leads as well as different hard drive enclosures.
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    OK. so now you can start doing meaningful things (i.e. perform test steps whille knowing its purporse, how to do-it, what look for in results and know what results mean)

    1. So if you hear the "ding-dong" when connectingi assume you mean then Windows as at least seeing the physical connection. That step's done.

    2. Being seeen by Dev Mgr means there are TWO drivers installed for the device. You verify each
    => There's a driver for your drive listed under disks
    => There's a driver for your drive listed under USB and with name USB Mass Storage
    =====> Look at driver's properties to check if tthat driver is REALLY for your
    ======> Even more true for USB as any connected USB drive gives the same name: "USB MASS STORAGE"
    == And make sure each driver indicates DeviceStatus= working

    If you aren't able to see the confirming info or do encounter some other issue, don't even think of diagnosing any further (like Disk Management) till the DevMgr case is all in control
    Things to do:
    1. Try changing the USB cable you're ussing.
    2. If you can, try a USB port on someone elses computer
    3. All testing should have the drive plug directly into usb port on computer (no external hub connections along the way)
    4. When drive physically connected use devmgr to look at each hub listed
    ====> Under USB, find each Generic Hub and Root Hub (these can be "internal / logical" hubs)
    ====> For each hub, rt click Propertie. Click Power tab.
    ====> View and check power usage drawn by the devices on that hub. If it's excessive windows just down the hub
    =====> If recall correctly there's a 500mA total power max. if sum total of devices want a larger amount, Windows will shut down the hub
  5. meilinuk

    meilinuk TS Rookie Topic Starter

    Ok it has all of a sudden came up in Device Manager, it is there under Disk Drives. It is now also in the Disk Management, it is saying that it is online but the it says that the disk is unallocated, it is show as the whole drive now as well. So I don't know what has happened, all I did was turn it all back on. Where do I go from here? I really can't format the drive as there are things on there that can not be replaced.

    Is there anyone out there who can help me at all?
  6. to6479

    to6479 TS Rookie

    meilinuk - Were you able to find the solution???

    I m in the same situation as you were - can you please share the your findings?

    either here in the forum or by mail to

    to6479 at yahoo mail id

    Thanx buddy

  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    to6479 AND meilinuk

    First, meilinuk, i'm so sorry i missed your reply (i now see is couple months back). Are you still having problems? fyi... if one finds no answer sometimes to their thread after several days, is perfectly OK to post a "bump" as people (like me) will sometimes miss the initial reply and then notice the bump message

    And to6479
    I posted a guide a few weeks back you should refer to. Start with Initial Troubleshooting steps in Part 1. Troubleshoot: Windows Won't Recognize Your USB Hard Drive

    Post again if you need further info / have any questions

    Meilinuk, again i'm sooooooo sorry i missed your earlier post when needing further help!!!!! :(
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...