1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

External hard drive not showing up in Disk Management

By giyad ยท 13 replies
Aug 4, 2005
  1. Hey everyone,
    I just purchased a new external hard drive for my laptop. I have a Sony vaio, and the hard drive I bought is a Micronet Platinum XL 500gb. I turned it on and it didn't show up in My computer so I went into the disk management and noticed it was not activated. I activated it and then still nothing.

    That was obvious because the drive had not been formatted. So I clicked create new partition and started formatting it. All was fine, it was late so I went to bed, got up in the morning to see how it completed and it said that the format was NOT successful. Now it won't show up in My Computer, nor will it show up in Disk Management. Should I just create a WIN98 bootdisk and format it from DOS, or is there something else I can do?

  2. synthetik

    synthetik TS Rookie

    If it won't show up, I don't see how you can format it in DOS.

    Anyway, check out Device Manager and tell us more.

    Other suggestions:

    1. Test your drive on another pc
    2. Check your bios settings

    good luck
  3. jshields13

    jshields13 TS Rookie Posts: 107

    I recently installed an external hard drive and some similiar problems. Turn your computer off, then unplug the USB cable and then the power to the drive. Restart you computer, plug the power into the hard drive, wait 10 seconds and then plug the USB into the computer. This clears the hard drive buffer. See if the drive shows up in disk management. Before formating, turn off your antivirus. I had no problems once I did that.

    Good Luck.
  4. giyad

    giyad TS Enthusiast Topic Starter Posts: 59

    The wierdest thing

    Its the weirdest thing... I unplugged my hard drive, its a firewire not usb, but it worked. It showed up and I tried to format it again. I think the problem is that I am formatting it through a cardbus and not through my internal firewire port. Now it won't show up again, I think it might be a cooling problem which is a load of crap because I bought this 3 days ago because the advertisement said how good its cooling is. Its burning hot! I hate marketing, they are such liars.

    I still can't figure it out, can anyone help?
  5. zephead

    zephead TechSpot Paladin Posts: 1,554

    take it back, the drive's controller is probably shot.
  6. giyad

    giyad TS Enthusiast Topic Starter Posts: 59


    I am at work now but before I left I tested the drive again and it worked! I started formatting it from my internal firewire port, we will see if it works or not when I get back, I will post what happens. I just can't believe that if I unplugged for a few hours it starts to work again!
  7. Unbuffered2%

    Unbuffered2% TS Rookie

    I am having a similar problem

    I don't mean to jack your post but, I am having a similar problem and hoping that someone can help.

    I picked up a WD caviar 500GB SATA drive and an external SATA enclosure. I hooked it up to my comp via USB and formatted the drive in disc management. I was able to save a few things to the drive then shut down for the evening. The next day when i restarted the comp, it would only recognize the drive as a USB device in the device manager (originally, it recognized it as a WD drive). it will not show up in the disc management section (neither the top or bottom part) or as a drive in explorer.

    I have tried uninstalling the drive and all usb devices then letting the comp reinstall everything, but the drive always comes up as a usb device.

    Also, i have another hdd that is ide in an external enclosure that works fine.

    I have tried on my laptop and a different workstation and it still only shows up as a usb device.

    Does anyone know if it could be the enclosure causing this?

    The drive was purchased online from Fry's which is a pretty reputable source so i am hoping that it is not dead. I picked up the enclosure from microcenter, it is a silver river duo (if that helps anyone).

    Any ideas or suggestions would be appreciated.
  8. jobeard

    jobeard TS Ambassador Posts: 12,486   +1,428

    500gb :wave: your BIOS must have the LBA option set.

    if you get access via the Disk Manager, I would partition it into at least two equal partitions of NTFS.
  9. Rick

    Rick TechSpot Staff Posts: 4,512   +65

    I'm not 100% sure, but I am very confident this does not apply to USB drives (If you can though, certainly prove me wrong). I have some vague memories of using large USB drives on SP1 and pre-SP1 computers. The problem with out-of-date Windows boxes is a direct result of how it accesses IDE controller directly (ATAPI v6). A USB controller, however, acts a middle man which I believe avoids this. SATA is also unaffected.

    I couldn't find anything to prove or disprove this, but maybe someone else will have better luck finding some facts.
  10. Rick

    Rick TechSpot Staff Posts: 4,512   +65

    Just so you know - and I understand where you are coming from - but I've purchased MANY dead things from Fry's. :)
  11. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,545   +429

    I'd guess that your enclosure or your drive is dead. You pretty much ruled out any software issues by duplicating the problem on another computer and by not being able to duplicate it with another external drive.

    I'd remove the drive from the enclosure and hook it up internally to determine whether its the drive or the enclosure that is bad. Have you tried a different USB cable?
  12. Unbuffered2%

    Unbuffered2% TS Rookie

    I have not tried a different USB cable on the drive, I will definitely do so after work. It would be awesome if that was the problem, but I have a feeling it will be more complicated, like most things.

    I need to check and see if my MO is set up to run SATA internally, the comp I have is a shuttle my friend built and gave me so there isn't any room for an additional hd. My next option will be to buy a new enclosure to see if that fixes the problem.

    Also, does any know if the program TestDisk would work to fix this problem. I saw it mentioned on techsupportforum under the title "Have you "lost" a hard drive or partition in your computer?"

    Once again, thanks for all the help.
  13. jobeard

    jobeard TS Ambassador Posts: 12,486   +1,428

    ME TOO! If you need hardware frm Fry's, be sure it's in an unopened, sealed box;
    Fry's is known to put returns back on the shelf for resale :( YUCK!
  14. grat3fuluser

    grat3fuluser TS Rookie

    Jshields, I joined this site JUST to say an ENORMOUS thank you to you! I hope you're still around to see my gratitude. : )

    I have this external hard drive:
    w ww.hitachigst.com/portal/site/en/menuitem.7e8588a6f6f2c950483bad24eac4f0a0/

    It's a little over a year old and now contains tons of data. But this morning it suddenly did not show up in my computer!
    After following your tips (exluding the formatting, of course), all is well!

    The incident, however, has reminded me that I absolutely need to buy another external HD to back up my current one. All my files are additionally saved to DVDs; but it takes an eternity to copy all the content from those!

    Many thanks for your post, and thank you to TechSpot for this site! Glad I found this place! :approve:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...