External HD not recognized

By HawaiianHoney ยท 11 replies
Feb 9, 2011
Post New Reply
  1. Hello All! I've been searching for an answer to my problem for almost 2 days to no avail, I really hope you can help me...

    A few days ago, my WD 1TB stopped working. Ironically, I was trying to back up my back up onto another external when it stopped and gave me an error message, which I can't remember. Now, when I plug it in to my laptop, it doesn't work.

    Here is what I mean:
    -No sounds are made on my laptop, indicating that something has been connected to the laptop.
    -It doesn't show up in Disk Management
    -It doesn't show up in Device Manager either

    This is what I have tried, but has not worked:
    -Using a different USB power cable
    -Connecting it to another laptop/PC (it won't read on them either)
    -Cleaning out my "hidden devices" in Device Manager
    *I cleaned out everything I could under volumes and USB controllers. Rebooted twice and reinstalled everything. It still didn't work.
    -Connected it to different USB ports on my laptop

    Other information:
    -When I connect the HD, the light will come on and will sound like it is working, but there are some definite "clicks" that I don't remember happening before this problem.
    -I'm pretty sure that it used to show up in Device Manager under WD Drive Mgmt. devices, but it definitely does not anymore. There isn't even a "shadow" or hidden version of it.
    -Win 7 - clean
    -Hd is about 2 months old
    -Laptop is about 8 months old

    Normally, I would take this in to get it fixed, but I am stationed overseas so taking it to a Best Buy or something isn't really an option. Anything anyone can offer (especially if it includes retrieving my info on it) would be greatly appreciated! Thanks!
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Sounds like the drive may have died but will take a closer look.....

    > Download the zip file HERE. Save it on your Desktop
    > Unzip and move devcon.exe to C:\Windows\System32
    > Now double click to run USB_DevDump.bat file

    It will create file USB_DEVCON.TXT on your Desktop. Please attach it to your next post.

    Also, have you tried connecting other USB Drives and/or devices? Do others fail or just this one?
  3. HawaiianHoney

    HawaiianHoney TS Rookie Topic Starter

    Thanks... file attached

    Hello! Thanks for your reply, I did as you asked. Hope it came out alright. It never dawned on me until now, but I didn't have the external attached when I ran through the process. Did I need to?

    I did attach other items (other externals, camera, iPod) to the different USB ports and they all worked.

    Attached Files:

  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    yes, please repeat and run the tool with the external drive connected, plugged in (if it has its own AC adapter) and turned on
  5. HawaiianHoney

    HawaiianHoney TS Rookie Topic Starter

    File attached

    Sorry about that! Here it is!

    Attached Files:

  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Couple things

    You said you don't ever hear the device connect ding-dong when you connect the HD drive??

    And Ooops. I don't think you copied the devcon.exe file to C:\Windows\System32 (refer back to instructions in my earlier post). There should be lots of cryptic strings in your output. Should start something as follows. You can either just move the file and/or if you redownload the zip file, the update script now does the error check (or just look at your output should be similar to below)

    2011-02-09 1101 AM   
    START: USB_DevconDump script  
    ECHO is off.
    ************************** devcon hwids USB   
        Name: USB Root Hub
        Hardware ID's:
        Name: USB Root Hub
        Hardware ID's:
        Name: USB Root Hub
        Hardware ID's:
        Name: USB Root Hub
        Hardware ID's:
        Name: USB Root Hub
        Hardware ID's:
  7. HawaiianHoney

    HawaiianHoney TS Rookie Topic Starter

    Need a little help...

    So, I feel like an *****. I have tried to delete everything and do it again, delete again and then re-download and then do it again, and the file keeps reading "echo is off" which what I assume you are talking about. I am pretty sure that I moved the file to the correct location. I did it three separate times, and I get the same result. Just in case I am doing it wrong, I have attached a screen shot. Thanks again!

    Attached Files:

  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    No worries. It's a new script and i'll go test it out some more before future use...

    For now.. do this
    > unplug the usb cable for the external drive
    > Open Device Manager then reconnect the USB cable. Normally 3 events should occur
    1. You hear the device connect ding-dong
    2. Device Manager refreshes and a new USB Mass Storage Device appears under the USB category
    3. A new disk appears listed under Disks in Device Manager

    You should be able to unplug/replug and see/hear these 3 events. Are you hearing/seeing any of them??
  9. HawaiianHoney

    HawaiianHoney TS Rookie Topic Starter

    Definitely not. Nothing happens anywhere. There are no sounds indicating that anything is being connected, except for the sounds (clicking) that the external makes. It doesn't show up in device manager or disk management.
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Then it would seem to be hardware problem on the external HD. Either the ext HD enclosure failed or it's the disk itself inside the enclosure. Are you comfortable with opening an enclosure to remove the disk and try connect the disk to a USB adapter cable?

    If the disk itself is still ok (and was the enclosure that failed) that should work. Hopefully, not your disk itself that failed

    btw.. i found my own dumb mistake with that script. but thanks for trying it. Wish i had better news :(
  11. HawaiianHoney

    HawaiianHoney TS Rookie Topic Starter

    Opening the case

    I thought about opening it up, and attaching it directly to where my CD ROM drive is, but... I am a little worried that it will void my warranty on the external. I guess if it doesn't void the warranty, I would need some instruction on how to do it properly.
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Then sounds like there's a few different issues first of which is your warranty. Suggest you contact WD and ask about your situation and their policy about warranty vs. ability for you to get your data before you return a disk under warranty (and get it in writing)

    Then there's how to open the enclosure and determining what type and size disk is inside (e.g. IDE/SATA) so you can determne how to connect it.

    Lot's of online guides on those topics

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...