F:\ is not accessible. Help please.

By yaypenguins ยท 4 replies
May 14, 2007
  1. Well, heres my story and I hope someone can help.

    A few weeks back, my computer got a BSOD and when I got it fixed, I tried to access my F: Drive. Unfortunately, my driver wouldn't open and this error message would pop up "F:\ is not accessible. The request could not performed because of an I/O device error." That is the exact error message that would show up and nothing more.

    I tried to google the error, but I didn't get any help. So I thought someone here might be able to help :D.

    I also tried to reformat my F: drive, but everytime I right click the drive, my computer freezes up.

    Extra Information:
    +My computer is a desktop.
    +My F: drive is just an extra drive that stores stuff. My C: drive contains 50 gigs of my memory and my F: drive contains 70 gigs of my memory. So you can tell that I need my F: drive D:.

    If anyone could help, I would greatly appriciate it.
  2. fr0stasdell

    fr0stasdell TS Rookie

    did you have any data on the drive at That time? Or was a USB ?? be specfic so i know what your talking about..
  3. yaypenguins

    yaypenguins TS Rookie Topic Starter

    I had about 20 gigs of data on the drive.

    Sorry for not explaining things clear enough.
    Just ask if you need clerification on anything else.
  4. CCT

    CCT TS Evangelist Posts: 2,653   +6

    When you say 'memory' do you mean 'data'!

    Sata or Ide drives?

    What else do you have installed? cd,dvd,floppy and what drive letters do they have?
  5. yaypenguins

    yaypenguins TS Rookie Topic Starter

    Nevermind, I got it :))).
    Thanks everyone for trying.

    I just formatted it in the command prompt :).

    Thanks guys.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...