Flashing a Bios without Windows, or through the previous Bios

By Swarms
Jun 24, 2008
  1. Hey guys, first post here.

    I have a computer here that has a "BIOS Rom Checksum Error" upon boot up. The computer doesn't post, and I can't get in the bios. It does nothing but give me a black screen with that error, and then the following line occasionally says Detecting IDE Atapi Device.

    I have read around, and think I need a new bios, since the old one got cleared or corrupted in a CMOS Clr. My question is, how do I flash a new bios without windows, or through the old bios.

    I have tried using drdflash to make a boot disk with AWDFlash and my new bios version on it. I have an external floppy plugged in through USB that didn't seem to do anything. I also tried an old floppy I had lying around that I plugged into the IDE that didn't seem to do anything.

    Did I do the boot disk wrong? Is that not my problem? Am I going about it completely wrong?

    It's an Asus Striker motherboard, Q6600 Chip, running Windows...if any of that helps. Thanks guys, I look forward to your replies.
  2. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

  3. Swarms

    Swarms TS Rookie Topic Starter

    I appreciate the help, Tedster, but I didn't see anything there that addressed my problem. Unless the "if it doesn't work you have a giant paperweight" part was supposed to be your answer? But please tell me that wasn't your point.

    I have tried making a bootable CD, USB, and Floppy now...but the screen never gets past the "BISO Rom Checksup Error - Detecting IDE Atapi Device..." screen. Is it a paperweight?
  4. Swarms

    Swarms TS Rookie Topic Starter

    This problem all started when I removed bad ram (Asus LCD was saying DET DRAM or something).

    I changed the ram out and got the Bios error, but I just put 1 stick of the old ram back in and it came on. So that leads me to believe that the ram is just bad, but the Bios itself isn't corrupted so...

    This thread can be closed/ignored. Thanks anyway guys.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...