1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

For Geniuses โ€“ Strange Problem

By reflect ยท 46 replies
Jan 22, 2007
  1. jobeard

    jobeard TS Ambassador Posts: 10,295   +787

    point the finger at the failing component --> MAXSTOR

    too late now, but ALWAYS low-level-format a new device with at least two full passes
    before you commit to storing data on it.

    btw: are you Overclocked at all?
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Low-level formatting comes in handy, but it's not really necessary in most cases. These 3 bad Maxtors could probably use it though
  3. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Are the Three Maxtors similar as far as models and product ID]s go? How old are they...
    Doubt that the computer could cause the failures, but the power supply could possible do so... Rather think it is a cooincidence... as so many Maxtor drives used in Gateway and Dell went bad before they sold out to Seagate.
    Get a Seagate with the five year warranty, and forget about worrying.
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    I asked this same question a few posts back... I have 3 Seagate drives that were replaced under the 5-year warranty in my system right now
  5. reflect

    reflect TS Rookie Topic Starter

    mikescorpio- The drives are C:/ and F:/....and I have a folder on my SATA that's called "olddrive" let me make sure I have this right?

    I have the Ultimate Windows Boot disk(is that a cmd shell), which has the "unstoppable copy" program on it, but it wouldn't read the drive. Or do you mean the command prompt?

    So I should put

    xcopy F:\*.* C:\olddrive>C:\Copyresults.txt

    I'm bad with coding...lol, but let me know if that's what you mean. Also, I don't know what the individual files are called, I have tons of files on the disk.

    raybay - I can't access the drive as a slave, it freezes my system. Also, I put it back in the USB and did a file recovery on it by diskdoctor. It froze the system. I also tried Disk Image, and a few other cloning programs. They either won't read the drive or I get a no volume error.

    joebeard - How do you low-level format? I just used disk management to format the drives when I first installed them. Also, no, I'm underclocked actually.

    raybay - Nope, different model numbers and bought almost 1 year apart.....I'm ONLY buying SEAGATE drives now....lol
  6. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    Command prompt - command shell ... same thing :)

    Go to START - RUN - Type: cmd (hit ENTER)
    A black box (cmd prompt) should appear, and in this screen type the following:

    xcopy F:\olddrive C:\Files-From-F-Drive /h /i /s /c /e /r /k /y >C:\Copyresults.txt
    If you have more files outside the "olddrives folder, replace olddrives with *.* (it will get everything on there ... hidden or not).

    Before you run this make sure you create a folder in the root of C: called "Files-From-F-Drive".

    If the xcopy does not work, and gives you an error such as "invalid parameters" try it again with the line in inverted commas. I wrote the line in a way though so if you copied it and pasted it in the cmd shell it will run due to no spaces. You need the switches that I have written after it (/h /i /s, etc).

    Copy the entire line and paste it in a cmd prompt. It will work, although it will only copy what it can ... anything else suggests either disk errors or corrupt data table. For that you would need to schedule a chkdsk -f -r in a cmd prompt on F:, but this may or may not delete files.

    Do this by going ot START - RUN - Type: cmd (hit ENTER) type the following:
    chkdsk /f /r

    I have attached a text file. Simply save the text file as xcopy-script.bat and double-click it if you are unsure how to run it (edit the batch file once renamed and check to see I'm not doing anything incriminating!).

    Good luck and plz let us know how you go :grinthumb

    BTW: Western Digital is a HDD brand I swear by (if you got the $$$, buy a Raptor!)
  7. foozy

    foozy TS Rookie Posts: 139

    Thats a pretty neat sript - so you can copy all non-corrupted files from a crashed hard drive as long as the destination drive works?
  8. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    Yer it's good when your disk has bad sectors and/or corrupt data table. The drive still needs to show up in Windows and be assigned a drive letter (online).
    I always pipe a text file to the root of C: so you can see what it did/didn't copy.

    Got me out of trouble many times!

    IF you want a more robust copier than xcopy, download the Windows Resources Tool Kit and play with robocopy.
  9. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    my two pence
    the enclosures are over heating the drives
    don't set them on top of machine
    enclosures supply power to the drives if erratic (cheap) this can cook motor :chef:
    I'm bored need data recovery PM me
  10. reflect

    reflect TS Rookie Topic Starter

    I got an invalid parameters error when I tried it. I also tried check disk and it didn't work either. The drive seems to be stuck and not spinning I think.

    Samstoned - The externals have fans and are high-quality. I sure hope they're not overheating the drives if that is the case...
  11. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,729   +409

    If they have fans they certainly wouldn't overheat unless you are just having them constantly thrash all day. I've got a 500 gig in an enclosure with no fan, and its not getting too hot. Well I'm sure someone on these forums would say its too hot, but those are the same people that think anything above 90F is too hot for anything.
  12. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    If the drive is not showing in Windows then you cant run the copy. You get an invalid parameters if you didn't create the folder in C: or if the path is different.

    Copy this: "xcopy F:\*.* C:\Files-From-F-Drive /h /i /s /c /e /r /k /y >C:\Copyresults.txt" and make sure you create a folder in C: called: Files-From-F-Drive BEFOREHAND
  13. reflect

    reflect TS Rookie Topic Starter

    The drive shows up in windows, but I can't get to it on my 160GB

    The 300GB shows up in windows and I can access it, but can't copy or open anything on the drive.

    I did create a folder on the C drive before hand. I tested out xcopy by using my CD rom drive...worked perfectly.

    I tried it on the 160GB got an invalid parameters error

    I tried it on the 300GB - started to copy files, then the drive hung and the activity light stayed lit, but the drive wasn't doing anything. The cmd prompt just kept blinking, but nothing was being copied (I waited 10 minutes, as it was stuck on a 35 meg file through USB 2.0)

    Is all very strange, the 300GB drive is spinning, the 160GB drive spins, then clicks, then spins, then clicks(the click sounds like it's thinking) and this continues on and on forever...
  14. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    How do you know it wasn't copying anything? Did you check inside the filder or read the text file? You can open the text file during the copy but do not save the changes when you close it.
    The cmd prompt will just sit there until it is finished, looking like its doing nothing. If you add /f to the xcopy line, you will see the file names and paths as it copies.

    The clicking noise is worrying ...
  15. reflect

    reflect TS Rookie Topic Starter

    I opened the folder and looked at the files and the folder size. The folder wasn't getting any bigger, and no files were being added, and the file it was on was 35 megs. Shouldn't take 10 mins....or will it take longer if it's a bad sector?
  16. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    It will take a while for it to finish ...
    Add /f to the xcopy command. But also, when the xcopy is running, keep the text file highlighted in C: and keep hitting F5. Or open the folder and keep hitting F5.

    Bad sectors means it will try hard to copy, but if it can't, it can't. It will take ages to run so kick it off and leave it to run. Check every now & then.
  17. chamillitarysk8

    chamillitarysk8 TS Booster Posts: 128

  18. YosefM

    YosefM TS Rookie Posts: 41

    Read whole thread & surprised no one has mentioned this.

    Most external enclosures never spin the drives down. Consumer drives are not meant to handle continuous use & this will kill them much quicker than you would expect - any brand. Make certain you get an enclosure that does spin the drives down, or buy server class drives (usually SCSI).

    Power supply makes a difference also, so put it on your UPS.
  19. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    I think this is more of a home set-up and unless you're made of money, most aren't going to buy SCSI disks and UPS PSU's!

    What do you mean by "spinning down"? A SCSI disk has about as much chance of dying as a standard IDE or SATA HDD. The difference is the RPM. SCSI's are upwards of 10K RPM whereas IDE and SATA are around the 7200 RPM mark.

    REFLECT: How are you going with this problem?
  20. YosefM

    YosefM TS Rookie Posts: 41

    Home setup understood. Don't expect home users to go for commercial class drives - it's simply an option.
    Commercial drives are made to be in constant use, consumer drives are not, regardless of their warrantees. Most external enclosures do not support powering down the drives when not in use for a time (see the Control Panel Power Options applet), and so contribute to the early death of many a drive.

    The simple answer is, if your enclosure doesn't support hibernation (and most do not), simply remove & turn off when it's not in use. A bit more trouble, to be sure, but better than the expense & trouble of replacing a drive every year or so.

    If you're trying for an autonomous backup solution, you'll need to replace the enclosure with one that supports this option.

    EDIT: after further research, power savings mode for external drives is controlled by the firmware in the drive, and you should contact the manufacturer for a utility to modify the settings if your enclosure doesn't allow you to control it (example, Maxtor One-Touch, but only for Maxtor drives).
  21. jobeard

    jobeard TS Ambassador Posts: 10,295   +787

    Glad you caught this, but NO enclosure has firmware -- it's all in the HD itself.
    The issue is HOW to access the control. It should be in the SCSI control panel,
    along with Park Heads on Power Off control.
  22. YosefM

    YosefM TS Rookie Posts: 41

    The best information I found was in an ask Leo column & suggested that the manufacturer may have a downloadable utility to set power savings mode timing on an individual drive. Naturally, this would depend on the individual manufacturer & it seemed that Seagate might not have one.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...