Freecom 500Gb Hard Drive - No Longer Working with PC, Still recognised by PS3.

By PreacherE9 ยท 13 replies
Feb 27, 2008
  1. Hi all,

    I've been searching for a way to repair my external usb hdd, which recently stopped working. I'm not having much luck, and I stumbled accross your forum so thought I'd give it a try. This is my first post. Here goes:

    I bought a couple of 500Gb external usb hdd's from amazon about four months ago. They are both usb 2.0 connection and have been working fine up until a few days ago when the main one I use for backup stopped being recognized by windows. I am using Windows vista 32bit, on a HP1QQ70 'All-in-one' Pc.

    Everything has worked fine since buying both hard disks, and I have been able to back-up all my data without any problems up until now. Now, when I plug the hdd in to my computer, I hear the windows chime telling me that a new device has been iconnected but it does not run autoplay as usual. When I open my computer to try and open it manually, it freezes my computer and I am forced to end task. On occasion, the drive will show up, but the details such as storage capacity and % in use do not show up. When I double click to open the drive it freezes explorer again. The hard disk makes a 'ticking' noise, as if it is searching for something. No matter how long I leave it doing this, it does not recognise the drive.

    I figured the drive had just been corrupted and was ready to format and call the 450Gb of data I had stored lost, but as a last resort I plugged it into my PS3, where I found It was able to read it and I was able to access all the files stored on it with no problem whatsoever. Strange huh? I've tried using various other usb 2.0 cables but still get the same problem. So I know it's not anything to do with the hardware side of it.

    So, I know the data is still on there, and not corrupt, but for whatever reason I can't get to it in windows. The only other computer I have access to is a laptop which is also running Windows vista 32bit - Same problem there.

    I've googled around and tried to find a solution myself but had no joy. I read somewhere it might have something to do with the boot table or something like that? In all honesty I haven't had to deal with anything like this before so I don't know what to do. I've also tried running various data recovery tools such as 'GetDataBack NTFS', none of which will recognize the hdd.

    I've reached the point where I've run out of ideas. Any suggestions please?
  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Did those drives come with an external power supply or a special double ended dongle for power?

    Have you tried other USB connections?
  3. raybay

    raybay TS Evangelist Posts: 7,241   +10

    We find these problems are nearly always caused within the poor quality external enclosures rather than with the hard drives themselves.
    You can but another brand of enclosure for $20. I suspect that will be the short cut to gettting access.
  4. PreacherE9

    PreacherE9 TS Rookie Topic Starter

    Yes, it does have an external power supply but I have also tried using the power supply cable from the second hdd, but still get the same problem. Both power cables work fine with the other drive.

    I'm curious as to how the external casing would suddenly cause vista to not recognise the drive? Also, would it not also cause the same problem when plugged into the ps3?
  5. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Have you swapped USB connection cables also - they often fail.
  6. PreacherE9

    PreacherE9 TS Rookie Topic Starter

    Yep, have tried swapping both cables and even tried using a cable I bought ages ago but never had use for. Today was the first time it had been taken out of its packaging - still no luck.

    I really think it might have something to do with the information that is stored on the drive. Is there a file or section of the drive dedicated to telling windows what is on it? sort of like an index or anything? I'm almost certain that it's not faulty hardware that is the cause, as it works perfectly fine with the playstation.. Anyone got any ideas about boot tables?
  7. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Just a quick recap:

    You have the external power hooked up and turned on (if a switch is included), the mode switch is set for external power (if equipped - my Firelites have that), you then plug the USB cable into your comp and nothing happens and the drive doesn't show in My Computer, Disk Manager or Device Manager.
  8. PreacherE9

    PreacherE9 TS Rookie Topic Starter


    The drive is connected to the pc via a usb cable, the external power supply is plugged in and the power switch is set to on. There is no power-mode switch. When the usb is plugged in windows makes an audio alert informing me that a device has been plugged in. If 'my computer' is open it stops responding. The drive makes a 'tick noise' (Thats the only way I can describe it) It sounds like when a hdd is accessing data, but makes the noise once every few seconds. If left for a long time, the 'my computer' window will start responding again, the drive shows up (In this case, 'Local Drive H:'), however, it does not show the name of the drive, size of drive or % of drive that is in use (as it did previously). When I attempt to open the H: dive, windows explorer stops responding for a long time before informing me that I need to format this drive before I can use it. It does not show up in device manager.

    Using the exact same setup, with the second drive, everything works fine. The only thing I have done is unplug the cables from one drive and plugged them into the other.

    When I plug the drive into the ps3, it is recognised instantly. I am able to browse the contents of the drive and play music/watch video without any problems.

    This leads me to believe that there is a problem with the way windows reads the inormation on the drive, as there is no indication of any kind of hardware failure.
  9. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Have you tried reformatting the drive in Windows?
  10. PreacherE9

    PreacherE9 TS Rookie Topic Starter

    I want to avoid formatting it straight away as It contains everything I have collected over the past 8 years, including irrecplacable photos, mp3s, divx etc. When I bought the drive I transferred all my files which I had previously backed up on dvd/cdr and then destroyed the originals. What I want to be able to do right now is transfer the data from one drive to another then format, as I'm sure this will make the drive usable again.
  11. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Put all the 8 years of data on DVD's and safely store them away. It's extremely foolish to keep such data on hard drives. You may be able to use hard drive diagnostics software to "repair" the external drive so that you can recover the data
  12. CCT

    CCT TS Evangelist Posts: 2,653   +6

  13. PreacherE9

    PreacherE9 TS Rookie Topic Starter

    Ok, I'm having a look at TestDisk now, and so far it looks good. I am able to view the files in the dos window, and there is an option to copy files. I had a quick read of the documentation that came with it and from the sounds of things the bootsector of my drive has become corrupt. It has an option to rebuild it and even to change the type from fat32 to ntfs. which I am just about to try now.

    Does anyone know if a ps3 is able to read drives in an ntfs file structure? I'll post a follow up when done. Thanks.
  14. Ph30nIX

    Ph30nIX TS Rookie Posts: 243

    If I were you I'd copy the files off first. The last thing you want is for that program to stuff up while changing the format and inadvertently loose everything, which is what you are trying to avoid anyway. And do what CCT said and try copy them using the ps3
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...