front USB ports take dive

By hewybo
Oct 31, 2005
  1. I have an Ultra Wizard case, which is about 2 months old. Installed a new mobo last week, and front USB ports worked fine. 2 days ago, they quit. Tried an open header on the mobo, no luck. Have not changed any BIOS settings. How to tell if it's case sockets, cable, mobo? It just started out of the blue, and I don't know how to troubleshoot further. Thanks? :suspiciou
  2. jobeard

    jobeard TS Ambassador Posts: 11,155   +985

    plug in your device and reboot. then go to the device manager and look for yellow or red icons and go from there
  3. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Wouldn't be the first or last time I've seen USB headers "go bad".

    There's only a handful of things it could be other than an electronics problem. This includes the USB headers being turned off by a switch, jumper or BIOS setting. You can also check for physical issues (loose connection, physically broken jacks) and lastly, software issues with Windows (if none of your USB ports work, usually).
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...