Gamecube No Disc Error

Hey everyone, so I have a gamecube that won't read any of my discs. I pop a disc in and it just goes straight to the menu (it doesn't even play the gamecube intro). When I check the "gameplay" setting it just says: Please insert a NINTENDO GAMECUBE DISC.

So far, I've tried adjusting the power of the laser, trying to keep it between 150 - 250 Ohms, but that didn't help. I've also tried replacing the laser assembly with a new one and that doesn't help either. I tried leaving the gamecube on for at least a few hours as well to see if it would eventually read the disc but that also didn't work.

I'm really at a loss here, so I'd really appreciate any help. I know it might be easier to just buy a new gamecube, but I'm kinda stubborn and just really want to find out what the issue is.


Posts: 904   +215
TechSpot Elite
When I read the title of your post I thought I would have some ideas just based on PC fixes. Typically I run into hair that is wound around the spindle and that interferes with the laser. I also run into disc issues where people wipe the disc in circles when the should be wiping the disc from the inside to the outside. I am sure none of these things are your problem since you have gone to much greater lengths to get it to work.