Geforce AGP4X fix!

By zellar ยท 11 replies
Jun 20, 2002
  1. Geforce FIX!

    Hey guys!, This is my first post. I was having a problem with 2 video games -AvP2 and Duke Nukem MP. They were flashing badly and locking up with disruptive graphics thrown in for good measure. After searching every forum from here to Geforce heaven I came across this fix. I went into my BIOS under advanced chipset features and disabled AGP4x Mode. And BINGO! it worked. All my games run at high performance settings and run very smoothly. I posted this on another forum and it caused quite a stir. Some guys said I was nuts for disabling that in my BIOS. What I would like to no is why it worked? I haven't really gotten a straight answer. Zellar:grinthumb
  2. Arris

    Arris TS Evangelist Posts: 4,730   +379

    Welcome to TechSpot forums

    Check out the Geforce FAQ link in my signature.
    Lots of information about why how when and where is available there.

    Edit : Eek the GeforceFAQ link is dead :(

    You can find it here instead
  3. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Re: Welcome to TechSpot forums

    The author of the FAQ forgot to renew the domain & a domain squatter bought it up quickly hoping to squeeze some money out of the author.:dead:
  4. TS | Thomas

    TS | Thomas TS Rookie Posts: 1,319

    Geez, that's pretty cheap alright. I thought I read somewhere before that they had sold it (Tweak3d).
  5. PreservedSwine

    PreservedSwine TS Rookie Posts: 325

    I think it worked becuase you have an unstable system. It shouldn't make a diference unless you are having some conflicts within your rig.
    But if it works, great!
  6. JAV

    JAV TS Rookie Posts: 210


    AGP 4x has a data tranfer rate of 1066 MB/s. PC-133 RAM has a DTR of 1066 MB/s.

    Some games can use 4x & some can't. Depends on how the developer configured the game.

    If you have PC-133 & run a game that uses AGP 4x then the transfer rate of the RAM is maxxed out & anything else using memory at the same time will cause your problem. Turning on 2x & restricting the card from recieving at the 4x rate means 533MB/s goes to the card & 533 MB/s is free for other uses.

    Those games (AvP2 & DNMP) are evidently 'optimized' for 4x but will run on 2x.

    If your particular RAM is faster then the 133mhz of PC-133 & this is happening in 4x: I'd say you have a program running (at the same time as the games) that is limiting the thru-put of 1066 MB/s to the card.

    FWIW: PCI @ 66mhz x 64bit transfers data @ 533 MB/s, the same as AGP2x. Just thought I'd throw that in. :cool:

    This is *bandwidth* of the RAM, AGP port & PCI bus I'm talking here, BTW.

  7. Setaseeker

    Setaseeker TS Rookie

    This is a known issue with Geforce cards. Mine did the same thing. If you have a Via chipset it has to do with incorrect driving controls.
  8. JAV

    JAV TS Rookie Posts: 210


    ALL GeForce cards? Or ALL GF cards on ALL VIA chipsets? Or SOME GF cards on ALL VIA or SOME GF on SOME VIA? :confused:

    I am interseted in which is which. Hate to buy something that is known to have 'issues' if I can find out first, ya know? ;)

  9. zellar

    zellar TS Rookie Topic Starter

    So What!!1

    Well so far everything has been great!! I bought Sof2 and Spiderman the Movie and they both are running super and look great!!! I haven't had one problem with anything locking up or failing since I shut this AGP4x thing off in my BIOS. Does anyone see it being a problem down the road?
  10. JAV

    JAV TS Rookie Posts: 210


    If it doesn't pose a problem for you ... :cool:

    Down the road when more games use 4x & now there is 8x > you may experience less detail in those games at 2x. Time & your own preferences will tell. ;)

    Little 'tweek' I found for better frame rates on my MX400: in 'Display' > 'DX' > I set the 'Texture' (amount of system RAM to use) to 16mb. If I set it higher: the faster card is using the slower sys RAM too much & if I set it lower: the card tends to 'idle' waiting on the slower sys RAM. :cool:

  11. zellar

    zellar TS Rookie Topic Starter


    Hey JAV thanks for the idea with the settings. I'm always looking for tweaks!!! Have you updated your GF4 drivers to the 29.80 BETAS? So far so good for me!!! Zellar1
  12. Setaseeker

    Setaseeker TS Rookie

    I'm not sure if it's all Geforce cards, but I believe it is... from what i've read this problem has been around for a while and that is why 4x AGP is normally disabled on Via chipset boards... you have to patch them to get them to work most of the time... and then you run into the driving control problems... as long as you run it in 2x you'll be ok but 4x might require some bios tweaking...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...