Get disconnected from wireless router every 5 minutes

By bmvik ยท 5 replies
Feb 12, 2010
  1. Hi! I searched and couldnt find a fix for it online. Something is strange going on. We have switched our routers from linksys to ambit brand. Cable company came out and gave us that Ambit... No comments since I like linksys. Anyways we've all had intermitten problems in the house with old linksys router. It was first revision of wrt54g. So i went ahead and flashed it to dd-wrt. that seemed to fix issue for a month. then we started having disconnects again. So we figured the router finally just started going bad.. then it quit. So we got this new one. I have wireless adapter from linksys wusb54gsc first revision. net security is wpa-psk. Every 5 min i have to run ipconfig/release and then renew thru DOS. otherwise i cant browse the web. When i ping google or yahoo - it cant ping. when i ping their IP addresses - i get response. the only way to fix is to release renew. Windows Vista gives me error that it cannot communicate with DNS server NOONE else has the same problem. we have laptops, desktops and an apple pc. I tried another usb card(same exact kind) with same result. If i go to pull up card status to see if i can change DNS servers to say OPENDNS ones, it doesnt even give me that menu. all i can see is that window with Connection and Security tabs (in Control Panel\Manage Wireless Networks). Really wierd... what could be wrong??

    i've removed and reinstalled drivers thru Device Manager also.
    Wanted to try to fix it without changing WPA PSK mode to WEP... owner doesnt want any changes. Their laptops are older anyways... one even still only supports b and not even g. And it works fine for them.
    It drops something to do with DNS (seems like). if i plug in googles ip in address bar it goes to it

    i have also tried disabling firewall on my PC and putting my PC's IP in DMZ in the router settings.

    I cant change DNS settings in router. Also cant in my pc's wireless card,- i cant get to those settings in my pc. Option simply isnt there to click on. my NIC for the wired connection, for example has those options to change.
  2. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    my my.

    Have you updated the firmware of the router? They ALL need it! Start there first.

    Leave the PC(s) alone; the get there settings from the router.
    Also do NOT use the DMZ feature!

    First, ONLY use a wired connection to attempt changing router settings.
    Turn off all WiFi adaptors; they will reconnect later[*2]
    The router should have a choice for the IP settings and the DNS settings and usually we
    recommend the Automatic (DHCP) choice for both. While wired to the router, you should
    see the Gateway address, subnet mask, and the routers address; write them down.

    Now use the MANUAL settings instead of the Auto(DHCP) and insert the OpenDNS addresses for the DNS setting.

    save the settings. Your SSID and encryption keys will still be the same.

    disconnect from the router and enable the WiFi adaptor(s)[*2]

    for each system, use IPCONFIG /ALL to view the DNS settings; they should be the OpenDNS addresses. If you see the DNS server as, it's not an error, but it means the firmware is forcing a port forward from the router's address to the Gateway address of the ISP.
  3. bmvik

    bmvik TS Rookie Topic Starter

    thank you for your reply.
    no virus on my pc. btw, in the router, the dns servers are 65.35.something. where and how the windows get the that i mentioned ??
    There's no way for me to update Ambit router's firmware. Its unlike linksys for instance and theres no option to. Even using admin/cableroot password combo.
  4. bmvik

    bmvik TS Rookie Topic Starter
  5. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

  6. bmvik

    bmvik TS Rookie Topic Starter

    dont see anything on how to update DDW2600 firmware or even download it at ubee link
    i've come across that dslreports page already today
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...