1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Getting Atheros AR5212 Wireless Cards to Work with Windows XP

By luvr · 23 replies
Dec 18, 2005
  1. I recently assembled a computer (running on an AMD Sempron 3200+ CPU) that will have only wireless networking installed (serial and parallel ports, as well as on-board ethernet, are disabled in BIOS).

    For networking, I'm using a Peabird Wireless G PCI Adapter 802.11 G that (according to the Linux "lspci" command) apparently uses an "Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)" chipset.

    I'm currently using Windows XP SP2 as the Operating System on the computer, and I initially installed the wireless networking drivers from the CD that came with the adapter card. It was a nothing less than a disaster: Windows would start allright, and it would connect to the wireless network, but if I was very lucky, I would be able to view just two or three web pages, after which the system would completely lock up: No more mousing around, no more keyboarding, no more nothing - the only option would be to hit the RESET button. :mad:

    On the internet, I found a few notes about these problems (sorry, but I don't seem to currently find the references to the web pages involved :monkey: ), and the idea seemed to be that the Atheros AR5212 chipset just didn't work right with Windows XP. Under Linux, however, it should be a great choice (though I haven't tested that yet).

    By now, I have tried numerous drivers that all claimed to support the AR5212 chipset under Windows XP, but they all had the same problems; with some of them, the lockups would stay away a little longer, and I could even do a small download, but eventually, they would all cause the system to lock up.

    Anyway - Yesterday, when taking a fresh look at the issue, I somehow found myself directed to an AirLink 101 Technical Support Page for a possible solution. I downloaded the two driver versions I found there:
    I decided that these would be my last hope at getting the adapter working under Windows.

    I tried the older version first - Same troubles: The system locked up after just a few short minutes. :(

    Then I tried the newer version, "AWLC4030 Driver v4.0.0.1733" - and guess what: This really, actually works! I can surf the net, I can download, I can use the local network - Everything goes! I'm even confident enough that I'm typing this very message on this system now! And, at the same time, I'm even listening to an online radio station ("The Pulse 1330 AM, Enumclaw Washington USA" ) through Winamp! :cool:

    To install the driver, I simply unzipped the downloaded archive, awlc4030_v4_0_0_1733.zip, I fired up the Windows Device Manager (Control Panel -> System -> Hardware tab -> Click Device Manager), and looked up the wireless network adapter in the device list.
    I opened its Properties window from its context menu, went into the Driver tab, and clicked Update Driver...
    I opted to Install from a list or specific location (Advanced), then Don't search, I will choose the driver to install.
    I clicked Have disk..., browsed to the directory in which I had unzipped the archive, and selected the ".inf" file that I found there.
    Windows gave me an Update Driver Warning, telling me that Installing this device driver is not recommended because Windows cannot verify that it is compatible with your hardware. If the driver is not compatible, your hardware will not work correctly and your computer might become unstable or stop working completely. Do you want to continue installing this driver?
    Since the system would be unstable with drivers that Windows did consider "compatible" with my hardware, I thought, "What the heck!" and clicked "Yes."

    Ever since, this system has been working like a charm! Many, many, many thanks to AirLink 101 for this great driver! :approve:
  2. rebelyell

    rebelyell TS Rookie

    Thanks for this posting so much. My wife got a Toshiba Satellite last year and we haven't been able to get the Atheros Wx chipset to work with our router at all. I posted for help in a number of forums and all folks could tell me was that Atheros was garbage. I tend to agree with them for the most part. After applying the V4 driver you referenced in your post, the wireless adapter came to life and connected with Excellent signal strength. Thanks again for your post and offering a link to the driver. I hope other folks that are saddled with the functionless Atheros and the drivers that come with them will read your post and get them working. Well, I'm off to see the wizard...
  3. luvr

    luvr TS Enthusiast Topic Starter Posts: 53

    You're welcome!
    Glad that my post helped you - That's why I posted it in the first place.

    I don't believe that the Atheros hardware is to blame; once you install the right driver, it works great, doesn't it? Furthermore, Linux folks generally love it.

    I just cannot understand why manufacturers ship it with such lousy drivers. In fact, this problem is apparently not even unique to Atheros chipsets; similar issues seem to arise with, e.g., Marvell wireless networking hardware.
  4. san_

    san_ TS Rookie


    I'm using a netgear wg311 v1 pci wlan adapter based on atheros AR5212 chip. My OS is an Win XP Professional. Since i've installed SP2 wg311 stopped connecting to my wi-fi router. I've tried various drivers and updates, even uninstalled an windows update, as they say on the netgear support site. Nothing could make my card work.
    Thanks to Iuvr and it's post, my wg311 works again.
    Thanks a lot, great post ;)
  5. deadlycow21

    deadlycow21 TS Rookie

    I get this error (WG311v3.1 XP SP2): The specified location does not contain any information about your driver?
  6. luvr

    luvr TS Enthusiast Topic Starter Posts: 53

    That's correct - The driver is for Atheros-based wireless adapters only.
    The Netgear WG311v3 adapter has a Marvell chip on-board, and requires different drivers. Unfortunately, the only drivers that I have been able to find for such adapters, are the same as those that come with the WG311v3 in the first place...
  7. krishy_123

    krishy_123 TS Rookie

    Thanks to you i finally overcame the freezing problem on my system!... thanks heaps!..

    but one thing i have noticed is that although my wg311t connects at 108 and says very good to excellent connection at 95% to 100%... it doesnt seem to be running at anything near 108mbps... i did some measurements myself.. and found it would on avg run at 2MB/s ...which is only 16mbps.. so.. im not sure if its the driver you provided or if its something to do with my system setup? ...

    also.. i have recieved the bluescreen of death once.. which related to the N3AB.sys which is the exact driver that you pointed to above.. (IRQ not less or equal to).. any ideas?

    plz email me @ curry_boi@msn.com
  8. luvr

    luvr TS Enthusiast Topic Starter Posts: 53

    You're welcome!

    I'm afraid I cannot help you on this. The driver works great for me, with no data transfer issues that I can notice; copying files on my LAN must be somewhat slower than between wired ethernet hosts, I guess, but it works well enough that I often don't even realise that I'm on my wireless computer. (I haven't done any measurements myself, but I have never felt like I needed to.)

    Sorry to disappoint you again, but I haven't seen the Blue Screen of Death here. In fact, these days, I have two computers using the same driver for wireless networking, and both of them work equally great (they both have a Peabird adapter that I mentioned in my original post).

    I wonder if, perhaps, there's something about the WG311T adapter that makes your experience less satisfying? You do need a bit of luck with wireless networking, in my experience; some hardware combinations don't seem to work right. For example, my first wireless adapter was a Netgear WG311v2, which worked flawlessly in one PC, but was much harder to get to work in the other one; and, even after I got it to work, it would occasionally fail to connect upon power-up (some 20% of the time, I estimate), and a reboot was required to get it going. Once I had it working, it would continue to work, no matter how often I rebooted, at least until the next power-down cycle.
  9. krishy_123

    krishy_123 TS Rookie


    ok.. thanks for the reply...

    after fidling around with the driver... and finding the main site where i was able to d/l the Utility for that driver... i actually found out that it connects at 54mbps and only gets 70% reception, where as windows was telling me it connects at 108mbps and had 95 to 100% reception..

    so im not sure whats going on. Thing is that PC is only 10 feet away from the Router...so having 95 to 100% connection was viable. I might have to do some more experimenting and find out how i can get it to run at full speed...but for now your driver is at least stopping it from freezing 95% of the time.. :)
  10. luvr

    luvr TS Enthusiast Topic Starter Posts: 53

    One more suggestion, even though it may sound competely ridiculous: You may want to try and move your wireless adapter to a different PCI slot if you cannot get it to work properly (e.g., in case the Blue Screen Of Death turns out to be a recurring problem).

    While it sounds stupid, this was what I had to do with my WG311v2, to get it do do anything at all in the computer that didn't seem to like it.

    About the 54 vs. 108 Mbps: I have never looked too deeply into this issue, but the way I have come to understand it, the standard 802.11g specifications support connections of 54 Mbps, and if a vendor claims 108 Mbps, then either they add sending and receiving transmission rates together (yes, it's what some vendors apparently do!), or they implemented proprietary extensions on top of the standard. Since the working driver implements the standard, and does not support any non-standard, proprietary extensions, it will not go beyond 54 Mbps. Even so, a working, 54-Mbps connection is infinitely better than a consistently crashing 108-Mbps one!
  11. krishy_123

    krishy_123 TS Rookie

    infact when i saw the bluescreen of death, I changed the PCI slot.. as IRQ issues relate to the assignment of slots.. but yeh i havnt recieved the error again so far.. so that may be solved.

    with the speed thing... my netgear router wgu624 is a tri-band a/g/b and supports 2x 108mbps streams simultaneoulsy on both a and g bands. So i am guessing that for the Wg311t to support 108 would be a driver thing with an additional feature called frame burst? or something similar i think? ...

    so well at least the driver is stoping it from crashing atm... and i noe in the future when i update the motherboard and cpu of that system, (making sure its not a VIA chipset lol) i should be able to catch a 108mbps stream without issues.

    thanks for your help. :)
  12. luvr

    luvr TS Enthusiast Topic Starter Posts: 53

    Well, since both your router and your wireless card are from the same vendor, and they both support 108 Mbps, yes, it will be a matter of finding the right driver (one that works) if you want to run at the maximum connection speed.

    In my case, there's no point in trying to go beyond the standard 54-Mbps connection speed, since I'm running a mixed-vendor configuration: my router is a Linksys, and my wireless network cards are Netgear and Peabird.
  13. MCitroen

    MCitroen TS Rookie

    Thank you

    After 3 evenings of problems with installing WiFi (lock of keyboard and mouse, no BSOD) I found this post.
    I was end life kicking my very old ASUS A7VC Duron 1200 Windows Prof (yes it runs on this thing with 512Mb) with a Sweex LW052 wireless PCI card.
    LW052 Atheros chipset and drivers from Sweex are absolutely not the ones as in this post, but I had to do something (desperation...). And look, the thing is running with the Airlink 5212 drivers as suggested (the card has an AR2413A or something like that).

    I joined techspot just to save others a lot of work. (I hate spam..)
  14. npahlavan

    npahlavan TS Rookie Posts: 25

    I have a D-link 624 router and D-link WDA-2320 wireless NIC and Windows XP SP2. The older v3.3.0.150 driver has worked flawlessly for me. It eliminated the BSOD errors and my random connection drops. My NIC also consistently has an "excellent" connection status. I dunno why but all the other Atheros drivers simply didn't work right for me. Here's a list of their drivers if you would like to refer to them:

  15. shrimant

    shrimant TS Rookie

    Get 108 Mbps on the AR5215 use driver for AWLH4030-II Super G™ Wireless PCI Adapter

    In order to be able to use 108 mbps on the AR5212 chipset use the driver for AWLH4030-II Super G™ Wireless PCI Adapter
    The name of the file is awlh4030-II_v4_0_0_167.zip and is downloadable at:

    I am quite satisfied now .... and I am sure this works for you too:


  16. npahlavan

    npahlavan TS Rookie Posts: 25

    thank you so much. I will definitely try it out
  17. puzzlegeorge

    puzzlegeorge TS Rookie

    I purchased a HP 5188-3296 Wireless 802.11g PCI Card that has a Atheros AR5006X chipset. I installed it in my Compaq SR1200nx Desktop that has an AMD Sempron 2800+ CPU and a VIA chipset.

    I experienced the same exact freezing problem that Luvr documented so well in his original post. I had tried several drivers already all with the same result and I was about to give up. Eventhough the "AWLC4030 Driver v4.0.0.1733" is for the AR5212 chipset and I have the AR5006x chipset I figured what do I have to loose?

    I updated the driver exactly as Luvr described and it WORKED!!! Instead of freezing after a few minutes. my WiFi connection works perfectly.

    Thank you, Luvr for taking the time to write up your findings.

  18. DeBaas

    DeBaas TS Rookie

    SMCWPCIT-G EU working now.

    Thanks to your info my new WiFi is working now.
    On my dual boot system this card is working perfect with PCLinuxOS.
    Installing for WindowsXP SP3 a ......(@#*!)
    The driver you provided a charm.

  19. pezz

    pezz TS Rookie

    Same as Puzzlegeorge, this AWLC4030 Driver v4.0.0.1733 worked perfectly with my AR5006X pci card, whereas the 'correct' driver froze the machine randomly. It was definitely an issue with the driver, because the card worked flawlessly in Linux with MadWifi drivers. The driver mentioned here being an Atheros driver should probably work with a wide variety of other Atheros cards too, Atheros implement a more or less 'one size fits all' driver policy. Anyway, thanks millions for posting this here ages ago. Problem solved :)

    It's worth mentioning that the Atheros cards work beautifully when a good driver's found. I find performance outstanding, weak signal throughput in particular is far superior to any other card I've ever tried. It now runs rock solid.

    The buggy drivers really need to be fixed, because these fine cards are getting the flak. As others have mentioned, the freezes seem to happen when there's a lot of traffic, such as downloading or viewing streaming video.
  20. mchoppin

    mchoppin TS Rookie

    TP-Link TL-WN651G working under WinXP

    Thank you so much. My TP-Link TL-WN651G PCI WLan card with Atheros ar5212 chipset is now finally working under WinXP SP2 with this AWLC4030 Driver v4.0.0.1733.

    The system used to freeze after a few moments of surfing the web. Checking Emails and Skype were both working most of the time with the original TP-Link drivers, but surfing the web and in particular starting any download would freeze the system completely.

    Now, everything works fine!
    Thanks again
  21. luvbebito2

    luvbebito2 TS Rookie

    Hello Luvr,
    I am ready to pull my hair out. I downloaded the files you said but when i go into device manager to look for the wireless card, i dont see it, i havent been able to even get it to work once cuz it always freezes upon insertion. Any suggestions. Im running XP Serv Pk 3. I have two cards, a dlink and a lucent technologies. The laptop always freezes. I dont know how to run the sys file since xp doesnt allow me to do it. Another thing, How do I get XP to not revert to the old file once I change the file. Any help greatly appreciated.

  22. pezz

    pezz TS Rookie

    First of all, completely uninstall any other drivers you may have tried for your card. Then reboot.

    You don't run a sys file. You've unpacked the driver to a folder, so go into control panel/system/hardware/device manager. Select your Atheros card, right-click, and select 'update driver'. 'Install from specific location', 'don't search, I will choose the driver to install', and 'have disk'. Browse to the folder you unpacked the driver to, and select the .inf file.

    You say your laptop freezes as soon as you plug the card in, so it's probably loading the wrong driver immediately. Get rid of that, and you might make some progress. Faulty hardware is unlikely, but if all else fails, it can't be ruled out.
  23. luvbebito2

    luvbebito2 TS Rookie


    Thanks for the reply. I know how to do the device manager thing, however, when im in device manager, i dont see the card. its not under network adapters. the only thing there is my lans connection. and under the pci card, comes out 1510 cardbus. If this is it, Ive tried to uninstall but i reboot windows install it automically even though there isnt anything in the slot. Could this be it, the 1510? If so, how do I get Windows to not reinstall it after boot up?

    Any idea? I'm stumpped. Im not to savvy with computer terms but I manage pretty well. I was able to get it to do one time, but upon boot up, it reverts back. Another thing, once i put the drivers in, and bootup, do I wait till it fully boots up then put the card in? maybe I did a mistake somewhere there.

    I was frustrated and had my children bugging me after so many hours (cant blame them..lol) I may have overlooked something.

    Thanks again.:)
  24. pezz

    pezz TS Rookie

    Don't you see any devices with the yellow exclamation mark next to them? Have you installed a driver for your Atheros card before? Anyway, the link below gives instructions on how to remove 'hidden' devices in device manager. Try that, and remove any wireless lan cards you might find. Then reboot, and pop the card in, remembering to go through the process above for installing a specific driver when the new hardware is found.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...