GForce2 MX400 AGP display card conflict with USB device?

By sayhwee ยท 8 replies
Feb 3, 2005
  1. Hi! I'm new here, this is my first topic post here. I had view through all those similer topic, but I think my problem may be different, hope that someone can spend a bit treasure time to look into my explaination here and help me to resolve problem... THANKS!

    I'm not too sure is my display card conflict with my USB or with my DSL-200I USB Modem. Well my problem is that my PC will auto restart on everytime I run a application or game that require the Direct Draw or Direct 3D. The only solution to avoid the PC restart is to PLUG OUT TELEPHONE CABLE from my DSL-200I USB Modem, this mean that the Modem will be in IDLE mode due to no signal detected. My modem was installed as POPPE and the driver was downloaded from DLink International Support web site.

    I had reinstalled (Format and install) my OS (Windows 2000 Pro SP4) several time, tested the Direct Draw and Direct 3D within DirectX 7, 8, 9b and 9c. I'm also tested with several version of Nvidia Quadro display drivers (the lastest (67.22) and the older...) which were downloaded from Nvidia driver web site. I also updated the drivers for the motherboard, ATA controller, INF, chipset, bios... (from Intel Support web site)

    I did sent my PC to the local computer shop, they had checked for be by changed a new power supply but result same as I mentioned above...

    Well I still can using my PC but just feel troublesome to plug out the TELEPHONE CABLE...

    I'm not sure what actually cause this problem...(Maybe the DSL-200I modem, USB or Display Card...) Wish someone can share wtih me the solution, THANKS!

    Here is my PC spec:

    Pentium 4 CPU 1.7 GHz (never overclock)
    Intel 850GB MotherBoard Chipset (RAMBUS Supported)
    256 RAMBUS RAM PC800
    Nvidia GForce2 MX200/400 64MB 4x AGP Display Card
    300W Power Supply
    Creative PCI Virbra 128 Sound Card
    1 ULTRA ATA 100 20GB 7200rpm Hard Drive (Master plug in primary controller)
    1 ATA 2GB Hard Drive (Master plug in secondary controller)
    1 52X CD ROM (Slave plug in secondary controller)
    DLink DSL-200I USB Modem

    Windows 2000 Pro with SP 4 and all the latest update from Windows Update
    Sygate Personal Firewall version 5.5
    AVG AntiVirus 7.0
    Microsoft AntiSpyware Beta1
    DiscInDisk virtual CD ROM
    Intel Active Monitor 1.2.1

    CPU: 47~50C on non working. 50~60C for working
    Zone1: 37C
    Zone2: 40C
  2. Spanky76

    Spanky76 TS Rookie

    USB and Video Conflict

    I'm also new to this forum, in fact I joined specifically to help with your question. I also have a motherboard with the Intel i850 chipset and an MX400 video card and I also had problems with games running Direct3D. Even though I had no problems with the DirectX diagnostics, I couldn't get any games to run. They would lock-up or flip rapidly between two video modes. I tried a bunch of different nVidia drivers in both Windows98 and WindowsXP and even bought a new video card, still no joy. Finally, I noticed that the video card and USB are on the same IRQ in the BIOS. I updated to the latest Dell 8250 bios (A04), but was unable to separate the two. No matter which IRQ I set the video to, the USB followed. However, I did find a setting called "USB Emulation" in the BIOS that was enabled. I disabled that setting, leaving the other USB controller settings enabled. Eureka, success! Games now work. What's more, my USB mouse still works as well.

    I'm not entirely sure what the problem is with the i850 chipset, but it doesn't seem to play well with USB. Maybe it's just old or maybe there's a newer USB driver somewhere that works better. If so, I haven't been able to find it. Anyway, see if you can separate the video IRQ from the USB in the BIOS. Preferably, the video would be on its own IRQ. If this isn't possible, as in my case, try disabling the USB settings one at a time (starting with USB Emulation if you have it) and see if things improve. Good luck.
  3. sayhwee

    sayhwee TS Rookie Topic Starter

    Thank you, Spanky76. Finally got people reply me...
    I realized that my sound card, display card, usb and some more... using same IRQ 9. According to the intel support website, the IRQ sharing is under control by the Microsoft ACPI-Compliant System, this is not possible to change the IRQ manually. I also realized that others intel chipset motherboard (845) which having IRQ greated than 15, but for 850 chipset has only up to 15, the IRQ sharing may be require...
    On my CMOS, the only setting related to USB is the "USB Regency" enable or disable and both I had tried... I also had reserved the IRQ for the PCI device in order to reduce the sharing in IRQ 9 but didn't work, the sharing still remained on IRQ 9...
    What else I can do? Or may be I should avoid on using the USB devices for this motherboard...?
    I plan to use the router with NIC instead of USB modem, but I afraid that same thing will happen on the NIC... Please sharing the advices... Thanks.
  4. Spanky76

    Spanky76 TS Rookie

    Well, your options are limited. Do you have another USB device such as a mouse? You might try disconnecting the modem and connecting a mouse and see if the same problem persists. If not, it could be a problem with the modem driver. I noticed the latest D-Link driver for the DSL-200 is dated July 5, 2004. Are you using this?

    Next, go into the BIOS and disable the "Legacy USB Support". This is only required if you have a USB keyboard or mouse installed during the boot process. It allows the BIOS to talk to these devices. If you don't have a USB keyboard or mouse, you don't need this. Next, look in "Advanced"-> "PCI Configuration" and try to set any PCI slot that you have a device installed in to any IRQ except 9 (default is Auto). For example, if your sound card is in slot 4 (slot 1 is nearest to the AGP), then set the "PCI Slot 4 IRQ Priority" to "5". Make sure you give a unique IRQ to each slot you change and only change slots that are being used. Note that slot five cannot be changed from "Auto". If you have a device in the last slot, consider moving it. Finally, look in the BIOS under "Advanced" -> "Boot Configuration" and set "Plug&Play O/S" to "No" (this will permit the BIOS to configure the IRQ's) and set "Reset Config Data" to "Yes" to reconfigure the P&P PCI data on the next boot. Reboot the machine and re-check the BIOS to see all is what you expected (set "Reset Config Data" back to "No" if it wasn't done automatically). Continue the boot and see how Windows behaves. Hopefully now most of the extraneous hardware will be on some other IRQ's besides the one the video is using.

    As always, be sure to record any BIOS changes you make. You never know when you might need it! Good luck, and let us know how it goes.

    BTW, this isn't related, but your temps look a little high. You might want to check the fan speed and clean the heatsink. If these look okay you might want to re-seat the heatsink (the thermal grease can dry out over time) or get a larger one.
  5. sayhwee

    sayhwee TS Rookie Topic Starter

    I had try all of these, but still the same. The IRQ still using 9... There are no way to change the IRQ. I changed the sound card IRQ (PCI Slot 3) and set the Plug&Play OS to NO, reset the "Configure Data". All done but in windows system info, all the devices still squeeze in IRQ 9... The setting in CMOS doesn't work at all...
    I updated all the drivers, Display Card, Sound Card, Chipset, DSL-200I... I had worte to D-Link Singapore support center but no reply. What else I can do...?
  6. Spanky76

    Spanky76 TS Rookie

    Did you try a USB mouse in place of the USB modem? Did 3D apps still crash? The Creative PCI Virbra 128 sound card is old and I doubt the drivers support DX9. You might try disabling Direct Sound and trying the apps again. If all else fails, at least un-plugging the modem works!
  7. shadow_29

    shadow_29 TS Rookie Posts: 211

    well saywhee...first of all i noticed that you said that you downloaded the quadro drive from nvidia website.what????? quadro is a totally different line up of video card from nvidia made for 2d workstations.if you have that first you need to remove that.second dont get the latest detonator driver from nvidia they work on a unified architecture meaning all 3d drivers work with all of there cards meaning the geforce 1 to geforce 6800 all can run on the same driver.but you need an older driver version like 30.82 or 45.32 they work nicely.second since i also have an xfx geforce mx 400 card i can tell you it bugs a lot at first.i had win98 earlier and faced a hell of a lot of problems but ever since i got xp the problems have been far and few.check your bios see what speed agp bus is running at 1X,2x or 4x there should alos be some other agp specific options.check them and tell me what they are set at.
  8. sayhwee

    sayhwee TS Rookie Topic Starter

    Thanks for reply.
    To Spanky76,
    I did had try the USB mouse, the result was that my PC can't diplay anything... The OS can boot but when come to the login prompt, the OS seen like freeze and display nothing... This wont happen with PS2 mouse.
    Well, I had mentioned on my first message, the problem occur only when my DSL Modem is connected to the ISP... (The LINK signal is light up, or the telephone is plugged). So if I unplug the telephone cable, the problem wont occur, I can run Direct 3D application correctly without any problem. This mean that I no need to unplug the DSL modem from the USB port. (Sorry, my English is not so good... I hope you can understand)

    To shadow_29,
    I'm using the latest quodro driver which is version 66.72. I dont kown whether this is suitable MX 400 GForce2 display card... If not then I will have to download the old one as what you mentioned... Last time before I used the DSL Modem, I did used the USB 56K modem (Well...I forgot what version of display driver I installed that time) and it just work fine, no error as I mentioned.
    For the AGP setting in CMOS, all I can see related to the AGP setting is the AGP Texture Size and the value is 64MB default. Refer to the the Intel Support website, the AGP Slot of Intel 850GB chipset motherboard had supported 4X...
  9. shadow_29

    shadow_29 TS Rookie Posts: 211

    I think the very first thing you should try are new drivers from nvidia website,like i said quadro drivers are a totally different lineup, designed for 2d workstation.I also have had the same card you do so i can tell you to get that quadro is not for your card,you can try different versions of the drivers but nothng that says quadro to see what meets your need.also if you have xp than it installs the drivers by default try removing your current driver and see what xp installs.otherwise the best possible versions would be 30.82 or dont have a newer version of these but a completely different driver all together they are WRONG.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...