Hard-Drive light always on

Not open for further replies.
I recently installed a Western Digital SATA 250gig HD on my E-Machine W3107 as a secondary drive. I needed an adapter since this machine has an IDE cable and the original (main) drive is IDE. After installing and formatting, everything is working properly (to my knowledge), but the HD light is always on. I've adjusted my pagefile (since I also upgraded my RAM from 512meg to 2gig) so that on the main drive, it's set to 3-4gig and 4-5gig on the secondary (WD) drive. I have also gone into "msconfig" and stopped all non-windows processes to no avail. Is there something else that might fix this, or should I even worry about it? Thanks in advance!!


you're going to need a massive amount of free space to support that size
swap file. After setting the new size, the system is going to mung the HD
to make it active ... it may take a long time.

suggest you reset it to something more reasonable,
shutdown most services,
disconnect from the Net,
and defrag the volume.

then resize as you please and reboot.


Posts: 1,634   +0
You sure you're talking about swap file? I don't see why you'd need a swap file located on BOTH drives.
You should put a 1024mb size swap on the drive which is NOT your Windows drive. And that's IT.

Also, is the HDD light blinking rapidly, or just simply ON? If it is just plain on and never blinks or fades, then it could just be the controller is wacky. But if it is blinking or fading a lot, then it may be accurate usage. Can you HEAR the hard drive activity? Can you hear it "doing" stuff? If so, which drive is doing all the activity?

Lastly, sometimes HDD usage goes hand in hand with CPU usage. Press CTRL-SHIFT-ESC to get in Task Manager and go to the Processes tab. Sort the CPU column and see if any particular process is using a lot of CPU time as well, it may be the one using the hard drive too.

Good luck
More info

All the XP Tweaking places I've visited said that the page file size should be 1.5-3 times your RAM. Since I have 2gigs of RAM, I set for 1.5-2 and 2-2.5 times. I also read that putting some of the page file on a drive that windows isn't on would help with speed and stability. The light is constantly on, and I do hear constant "whirring", but can't open my case without totally unplugging everything and rerouting the wires to where I can access it while plugged in so that I can tell which drive it is. I'm guessing its the new one since the constant light wasn't a problem untill after the install. The light (and "whir") was present befor I reset the page file (it was at 800meg). In Task Manager, 94-99% is system idle prossess. Could it be that the new drive is 250gig and needs partitioned into 2 @ 125gig? I've seen that some people have problems with drives over 150gig. Thanks again!!


Posts: 1,634   +0
The "1.5" rule is somewhat misleading at times. After all, a person with 128mb of RAM and a swap file of 192mb will have FAR to little assignable memory space. And at the same time, a person such as yourself with 2gb of RAM, doesn't need a 3gb swap file, which gives you 5gb of total memory space, which is rediculous for a home PC because XP only allocates up to 2gb for any program. And it would be very rare for a home user to have enough gigantic programs open to fill all that space! The very general rule that I follow is to give XP at LEAST 1.5gb to 3gb of total space between RAM and swap. So if you have 256 of RAM, I would create a swap of probably 1 - 2gb. A system with 1gb or RAM I might make a swap of 1gb.

Regardless, it's probably not the swap file causing the issue at hand.
Have you put any data on the drive yet? Or is it pretty much blank? Because there are two things I'm thinking:
1) Indexing service. Takes a lot to index a lot of files on a drive that size. You could turn the indexing service off and see if it helps.

2) System Restore. XP normaly sets a percentage for restore space, somewhere like 8% or 10%. Which would be about 20gb+ on that drive. And XP could spend a lot of time collecting restore data with 20gb to play with! Right-click My Computer and choose Properties. Then System Restore tab. Check the settings for each hard drive and either turn it off, as a test, or set the percentage down to something reasonable like 3gb or so. Better yet, turn OFF restore for the extra drive. As needing to use System Restore on a non-system drive is near null. Most people ever need S.R. on their primary XP partition.

If worse comes to worse, you could run a program which monitors HDD activity and that may lead to some conclusions. Check out the software at www.sysinternals.com. They have a couple HDD monitoring apps.
Tried the suggestions

I turned off Restore on that drive and Indexing services just had drive C listed. I tried one of the monitoring apps from that site and all it had for the drive was an infrequent write to it. I have 41.5G of info on the drive and have defragged it 2 or 3 times since I put the info on there. I have actually tried 2 different monitoring apps, FileMonNT and DiskMon. FileMon shows itself as the only activity on L drive, and DiskMon (I ran both again right befor this sentence) showed no activity for it. Needless to say, the "whirring" and light are still constant. I've also contacted the manufacturer and am still waiting on a reply (should get later today). Thanks for the help you've given. I'm now wondering if it has anything to do with the adapter.


Posts: 1,634   +0
Very possibly the adapter. Or more specificaly, the driver.

I would check at the adapter manufacturer's website and get the latest driver for that adapter.

But also, there is some theory behind the HDD light. If this is the same light that is on your case that has always been there, then chances are good it is only blinking for your old IDE drive, not the new one.
The new adapter may have its own pins to connect an activity LED. But to my knowledge, I don't believe your existing case LED is going to show activity for a separate hard drive on its own adapter.
Or in other words, I don't think that light will show activity for BOTH drives, but only the IDE one that it was meant for.
I may be wrong. But that being said, the activity may be on the original drive, if you haven't changed anything with the LED lights. Does the adapter have pins anywhere to connect an activity light? Or does it have a light built-on?

If worse comes to worse, you can always shut down and unplug the adapter and drive to see how it behaves afterwards.

Lastly, besides the indexing service, check for any other indexing programs such as google desktop, yahoo and msn desktop search etc... And your virus scanner may be scanning it in the background.
I don't know! Very odd.

That's the adapter I am using. It came with a "splitter" for the power cable so that the 4 pin power cable is split to power the drive and the adapter.

Befor posting here, I had already tried disabling all services that were non-Micorsoft, and had disconnected the new drive (which restored "normal" activity light activity).

The adapter doesn't show on the device manager panel, just the drive itself, and the "update driver" option for the drive says it could not find a better match for the hardware.

Thanks for the time and effort on my behalf. Western Digital still hasn't responded to my question there, even though they say they will respond in one business day. The Addonics site stated that this adapter doesn't need a driver, but otherwise has not responded to the query I sent them. At least I'm not the only one that this has perplexed.


Posts: 1,634   +0
Haha, lol! I didn't know when you talked about an "adapter" that it really was an adapter, or converter, from SATA to IDE. I thought you had an actual PCI SATA controller card "adapter".
Ok, well that makes more sense. That adapter would not need a driver, but it WOULD affect the light activity because it's on the IDE chain for hard drives.

That being said, I still can't guess why there is so much activity, unless it is just the funky way the adapter works trying to convert data.

If your hard drive monitoring tools are not showing intense usage for either drive, it may just be a funky setup. Or the adapter is quirky and causing useless read and/or write operations on the SATA drive.
To be honest, I have not been able to successfully use a SATA drive on IDE using an adapter like that. So I don't try any more.
Thanks again. Since niether you, Western Digital, nor Addonics can figure out what the deal is, I'm going to go with it just being erronious. PC Pitstop's full tests gave me all finish-line flags (meaning no problems) also.

Thanks again for the help and time.
Not open for further replies.