hard drive not being detected, please help

By zinga
Apr 12, 2006
  1. Sorry about the length of this...

    Anyway, I've got a really weird problem with my hard drive not being detected.
    It started when I turned on my comp, when the "Loading Windows XP" screen came up, it froze after a while. So I rebooted my comp, but when the loading screen came up, my comp crashed and rebooted automatically. I've had this problem before - I find it's a hard drive problem and I usually fix it by going into the XP Recovery Console. However, when I tried to do it this time, Windows Setup came up with a "no hard drives detected" error.
    I have 2xSegate 200GB SATA NCQ harddrives in RAID 0 attatched to the Silicon Image SATA RAID controller on my MSI K8N Diamond motherboard. I know that Windows needs driver disk when entering setup, which I have supplied it with, but it still doesn't detect my hard drive.
    This is especially puzzling because I can access/view/detect the hard drive through DOS utilities such as fdisk and NTFSDOS. I've also tried various Linux distros, but they don't detect the hard drive either.
    Oh, by the way, I'm talking about the entire hard drive - I have multiple partitions on it so it's not just a partition being hidden.
    I've installed Windows XP on an old 80GB PATA harddrive - XP doesn't detect the my SATA HDD (no sign of the harddrive at all in the Device Manager) - but it does detect the RAID controller (yes, I have the drivers for this), if I enable RAID.
    There's nothing wrong with BIOS settings nor the RAID config utility settings. I've also checked the MBR by wiping it (of course, I backed it up first) and even tried replacing it with the MBR of my old hard drive (which is detected by Windows), but it still doesn't work.
    I doubt there's anything wrong with the boot sectors nor the actual hard drive, since I can access it under DOS, I've scanned the HDD with a DOS version of NTFSCHK (which found no problems), and the harddrive is only 3 months old.
    Interestingly though, if I disable RAID, the harddrive still isn't detected, even if I disconnect one of them. But if I put one into the nVIDIA SATA port, the one in the NV SATA port gets detected (obviously this breaks up the SilImage's RAID0 array, and I can't simply plug my HDDs into the NV SATA ports and use NV RAID because it's different from SilImage's RAID). I doubt there's a problem with the Silicon Image controller since the motherboard is only 3 months old (and again, I can actually access the HDD from DOS and even boot from it - except Windows crashes). I also believe there's nothing wrong with the driver because it's worked before, when installing Windows, plus I created a second driver disk (from the supplied CD) but to no effect.
    This is really annoying me. If someone could please help me, I would be VERY grateful. I don't really need to be able to boot into Windows, but I really need to get the data off the HDD - I know I can use NTFSDOS and copy the stuff onto my old HDD (DOS's 8.3 filename limitation is annoying, but I _can_ rename the files, so it's not too big a problme) but since FAT32 can't handle files bigger than 4GB, I can't recover some of my videos...

    Anyone have any ideas? Thanks.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...