HELP! Can't get MSI K7N2 Delta-L to work with AMD XP 2600+ - Nothing happens!

By RideC2 · 11 replies
Aug 31, 2003
  1. These are the components which make up the system that I can’t get to work:

    MSI K7N2 Delta-L motherboard
    AMD XP 2600+ processor with heatsink
    512mb DDR PC 2700 Ram - Generic I believe
    Chaintech gForce MX440 64mb Videocard
    Western Digital 80gb Hard Drive
    Lite-On 52x CD-RW
    52x CD-Rom
    Sony 1.44 Floppy
    2 case fans
    Turbo Case 350watt ATX
    Windows XP

    Ok here is my problem - It’s going to be long and detailed so everyone knows what I have gone through:

    I first built the system and powered it on. The screen read what it was supposed to such as XP 2600+. It took a very long time to detect all of the devices. Then it would throw a floppy drive fail (40) error. I went through the BIOS and selected boot from CD-ROM first so I could boot up WinXP and let it do it’s thing. It took a very long time to do this. Then it told me that the drive wasn’t partitioned and that it couldn’t install the OS. Then I went through the BIOS and selectd boot from floppy but that was failiing so that didn’t work. Keep in mind that on each start-up the processor would change what it was - for example it did not say XP 2600+ anymore but rather 1057gzh or something like that.

    So then I take it to a computer shop in my college town to ask him what’s wrong. He screwed around with the BIOS and couldn’t figure out why it wasn’t reading the processor right. I think he overclocked it and really messed it up. When I took it home that day I could only get it to turn on and not read any video. I tried clearing the CMOS but it didn’t work how it should. Still I had no video. Then all of a sudden my computer would only boot up for like 5 seconds and then shut right back down. It would not stay on for more than 30 seconds probably.

    I then take my computer to my neighbor back home. He has never seen anythign like it. We try every possibility. We tried booting it without anything hooked up. We tried switing the RAM. We tried a new video card. Nothing. Then we figure that it is a bad motherboard. So I go to the local computer shop adn buy the exact motherboard.

    I get home and install all of the components but only have 1 CD-Rom hooked up. When I booted it up it went very fast and read it as a XP 2600+ but it threw the floppy error again. I then went through the BIOS to have it boot from CD. I throw the XP cd in and it gets pretty far. It detected the hardware and installed some drivers. The blue screen for XP install was on for about 3-4 mins. Then all of a sudden it completely shut down.

    Then when I booted the machine back up it read the processor as some 2.?ghz. I then went through the BIOS with my neighbor and we shut down all of the onboard devices such as the LAN, USB, adn all that junk. We also had 3 devices on one IRQ number so we changed that (I heard you can only have 2 - is this right?). Then we re-booted adn it again said that the processor was some different number - like 1.453 ghz or something. It would throw an error. Then we re-booted the machine again and it read another number for the processor I believe.

    We then checked the floppy cable and flipped it around b/c it was backwards (I didn’t think it could be backwards b/c the notches matched up). We stuck a bootable floppy in but no go. I put 3 new floppys in to see if that was the problem - NO! Then out of nowhere on the next boot-up we got no video? We tried a new video card but no dice. Then I reseated the video card along with taking the CPU out and reseating that. I started it back up but just a blank screen. It won’t read video now. I can’t do anything with the computer. I tried clearing the CMOS with the jumper and battery and everything but still nothing.

    Could this possibly be something with incompatibility with my hardware? Could it be a bad power supply? Could the processor be bad? Memory? ANY IDEAS?? I am so frustrated and lost that I don’t know what to do. My other computer is an AMD XP and I never ran into any problems such as this. None of the people I have asked have seen this either. HELP ME PLEASE!!!

  2. Roderick

    Roderick TS Rookie Posts: 26

    Sounds very similar to my boot problems after I done my 1st build. My ASUS has an option in the BIOS for Plug and Play OS. The default is NO. After a couple of failed boot attempts, I noticed this option and set it to YES. No boot problems since. On a different note, I'm not sure what you meant by "generic" for your memory and what else did you used to swap it out, but I work in the memory chip manufacturing business and I can tell you that there are "tiers" for customers of our products. Tier 1 customers are Kingston et al., they'll return an entire shipment just for cosmetic defects, let alone testing. Tier 2 customers are those whose testing criterias are not as stringent as Tier 1. Chips that "failed" Tier 1 standards are offered to Tier 2 buyers at a discount. Tier 3 module builders exists and you can guess about their standards.
  3. arien101

    arien101 TS Rookie


    I have a similar problem. Specs:

    MSI K7N2 Delta Board
    Athlon XP 2600
    512 MB DDR RAM
    Asus V8420 Deluxe

    At first I had the 1025 MHz problem too, but it is solved by switching the CPU FSB Clock setting in BIOS: Advanced Chipset Features to 166. That is were the real problem started though, as the computer is now booting up and powering down in irrgular intervals. I've tried different settings in BIOS and right now it hasn't powered down for the last 20 minutes, but I guess that's because I have it set at 133 right now. If you find any clues as to how this can be solved while having it set at the full 166, let me know.
  4. stilup

    stilup TS Rookie Posts: 21

    major problems

    the biggest problems with the K7N2 boards is either non conforming memory or inadequate power supply.
    Check to make sure your memory is a proven brand to work with the motherboard.
    My favorites are Corsair 3200 and Mushkin Black.
    Don't skimp on the memory or power supply.
  5. bogan393

    bogan393 TS Rookie

    i had the same problem with the cpu registering differnt speeds on this motherboard. To fix it go into the bios and change the FSB to 266 then check the manual to find the fsb jumper on the motherboard move the jumper accross. as for the rest of your problems i got no idea whats happening. hope this helps you some.
  6. sas wasp

    sas wasp TS Rookie

    re: bios floppy problems no boot up

    i had the same problems as you mate , and i found it to be after a lot of trial and error , the bios was curupted from the 512DDR kingmax pc3200 with small bga memory chips , so we went back too pc 2100 ddr @266mhz and hot flashed the bios with another k7n2-delta L's bios chip, fired the system back up then while still running reinserted the old one and exit and saved the bios .. the system reboots and away ya go!!! hope this HELPS all my fellow gamers with this shockin chipset of a motherboard hope this helps your problem mate
  7. DivXKittiE

    DivXKittiE TS Rookie

    :) It works!!

    I had many problems with this board when I first installed it into my system upgrading from an Athlon 2200xp on an ASUS A7V333 mobo.

    This is the system that I had attempted install with the new board but was very unsuccessful:

    System Specs:
    AMD Athlon 3200Xp
    MSI K7N2 Delta Series Mobo
    300watt Power Supply (AMD Approved--allegedly)
    2x DDR400 (256mb) Memory from Fry's Electronics (Generic)
    80gb Western Digital 7200rpm 8mb cache (system drive)
    2x 120gb Western Digital 7200rpm 8mb cache Internal drives
    120gb Cobra Firewire Western Digital 7200rpm 2mb cache External drive
    30gb Western Digital 7200rpm 2mb cache External Usb 2.0 drive
    Promise ATA133 Ide controller card
    ATI Radeon 9800 Pro
    Hercules Gamesurround Fortissimo II Soundcard
    Avermedia TV Studio capture card
    Modded Black Case i call "The *****" with 2 Neon fans, one in the rear and one on the side both used as exhaust fans.
    Borla exhaust tip affixed to rear of pc case with fan actually blowing out of the exhaust pipe, he he he.

    I used a Dlink Nic in my old pc but this one had the onboard nic so I opted to use that instead.

    I purchased this new board and new AMD processor for myself as a Xmas present, and had no foresight into the excruciating nightmare that was to come... :)

    When I first booted the computer up I had noticed that my processor was detected at like 1000 mhz or something, I thought that as kind of odd, but I let it continue into booting into Windows Xp Home which told me that I needed to reactivate windows due to a significant hardware change. I've seen this message before with a simple harddrive upgrade from 60gb to 120gb so I wasn't too worried about it. But what suxored was that I had to call a 1-800 number this time, and read numbers to this terminator monotone monster voice which then read me the activation code to input into the boxes, fun fun..

    Then when Windows Xp loaded up the dialog box that detected new hardware kept buggin' and wanted to install drivers which i gave the booty slap to and then put in the Mobo driver cd in.
    I installed all drivers and optional software such as the Live Update and Pc Alert.

    After that I rebooted and went straight into bios first to check the bus speed and changed it from 100 to 166 and checked all other options, I then disabled to onboard audio because I have my own soundcard. When I booted back into windows I then had to reinstall the drivers for all my other devices such as soundcard, videocard, capture card, ide controller etc., then I rebooted again, and It did count my processor correctly this time and said it had also counted 512mb of DDR400. But when windows booted up and I tried to execute certain programs I had everything was so slow and laggy. It was horrible, my PC was operating like a 286. I tried moving a large video mpeg file from the C drive to the D drive and it said it would take 45 min!! Normally moving files like this only took about 2 minutes on my old Pc so I knew something was definitely wrong. Anyway I was very frustrated at this point and went to watch tv and left the pc alone.
    A few hours later I came back to my pc and the arrow was frozen in the screen and Windows had locked up and Cntl+Alt+Del did nothing so I hard booted it.
    When windows came back up it took a full on 10 minutes for all my normal programs to load in the taskbar. I was freaking and thinking that maybe a jumper wasnt right on one of my harddrives since i have so many, or maybe one of the drivers were bad so I checked them in System properties and It said all the drivers had no conflicts. So I threw my hands up and went to bed...

    The next day I went back to the PC shop I had purchased the board and processor and memory at with my PC and asked them why my "*****" was being such a *****! They took a look at it and told me that my power supply was inadequate for all the stuff I had in there including all the harddrives and pci cards. They recommended the Enermax 450watt with dual fans, so I purchased it and went home and installed it. I noticed that the Enermax 450 watt had an extra power wire with P4 labeled on it and the K7N2 Delta board has the socket to plug it into so I did that also and still it did not correct my problem. I was so close to going mad at this point, the power supply was like 90 bucks!!! Grrr...

    I then went on boards similar to this one and found others with problems similar to mine. I then read reviews about this board and one of them stated a problem with this boards Nvidia Nforce chipset and certain brands of DDR400 memory. The site I went to, I'm sorry but I forgot where it was, also said that it recommended to install Corsair DDR400 memory in dual channel, one in the purple slot, and one in the green slot. Unfortunately Corsair memory is more expensive than normal DDR400 but I went and bought some anyway, 2x 256mb Corsair DDR400, and installed it just as the site had recommended. Instantly my PC had responded by being SUPER FAST and Responsive and actually acted like an AMD 3200xp. In my opinion this was the fix, everything I had tried previously had not worked out.

    Hopefully this helps some of you, I know what it feels like to spend and spend and spend with no hope in sight, but thank GOD!! it worked out for me. :)
  8. savethesquirrel

    savethesquirrel TS Rookie

    I have been having the same issues with the same board. I have tried quite a few different sticks of RAM, 5 different boards, power supply, video, CPU, reload etc. I also tried unplugging everything in the system except what I need. The system will install fine, load windows, and after a few will then start to blue screen and lock up. Nothing in event viewer sheds light on the situation. I have 2 120GB Seagate SATA HD's in RAID0 that I have not tried yet. I will take them out of the array and try it with each one and see what happens. I just want the system to run stable at this point. I don't think my HD's are bad because I had tested them previously due to another MSI mobo problem. I did a full scan of the media with Seatools and it found nothing, on both drives. Yes frustration has set in...

    MSI K7N2 (Nforce 2)
    AMD 2600XP
    1GB DDR400
    ATI Radeon 9600XT
    Sounds Blaster Live! 5.1 Digital
    2 120GB SATA in RAID0
    120GB + 60GB + 30GB ATA100 HD's
    Liteon Combo
    400Watt Pwr Sply

    I really have tried 5 different motherboards. I used to work for a small repair shop and the owner still likes me :)

    Aside from trying the HD's out of RAID 0, any other ideas? Also, it does not matter whether I put the RAM in single or dual channel. I have also checked the case stand offs to make sure I didn't screw that up. Thanks!
  9. goldfishimon

    goldfishimon TS Rookie

    Similar Problem

    Hi Guys,

    i also have the K7n2 Delta - L and a 2700+ athlon processor. i was having no probs till recently when all the on board USB ports stopped working... except one; my mouse, luckily!!!
    now i dont know why it did this but i havent found a solution. device manager calls them UNKNOWN DEVICES, so i un-installed and scanned for new changes, nothing hapend, i tested all ports - only one works, i have looked for new drivers but i cant find any, the only thing is, i dont have the motherboard CD so i am not sure if that would solve the problem.

    ive tried all the logical things. it seems these motherboards have issues!

    can anyone suggest anything?

    Sorry i cant help with the original problem!

  10. savethesquirrel

    savethesquirrel TS Rookie

    My issue ended up being the duel channel DDR, as soon as I took that out it works fine. I believe it is because I used less than tier 1 RAM. I now have 2 512MB sticks in each non duel channel slot and the PC works fine and is still very fast.
  11. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    I use 2 kingston and 1 crucial memoy sticks for 1.5 gigs.
  12. M@lfunct10n

    M@lfunct10n TS Rookie

    Similar Setup - Similar Problem

    I have a similar setup. A Msi K7n2 Delta2-L with an Athlon XP 2600+ and 512(legend) ddr400 ram. I recently brought 2 x 256mb(pqi or pmi im not sure) sticks of ddr400 ram and installed one in the other purple slot beside the 512 stick and the other in the green slot. This worked great for awhile.I brought another 512(RamBo) stick. I removed the 256 stick from the green slot and put the 512(Rambo) in its place. This proved Disastorus. First there was a burning smell. Then it booted okay for a few hoours. Then sudenly crashed and will not beep or post or nething since no matter what components I pu in there. I have tried many different setups. I have purchased a different board and now only have the orignal 512(legend) stick in it and it works fine. Is my K7n2 motherboard stuffed because of what I did If so what exactly did I do wrong? And how do I aviod doing it again?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...