1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Help, can't get Windows installed...

By MatangLawin ยท 4 replies
Dec 20, 2006
  1. Hello everybody. I am new here. I've been trying to find a solution to my problem and I hope someone can help me out here. Here is how it happened.

    I have a Dell XPS Gen 2 which is working for almost 2 years now. 6 months after buying it, I repartitioned my C drive (D:\) to have a separate partition for my data. As an MCP, I was offered to beta test the new MS OS, Vista. So I repartitioned my HD again for Vista. Computer is working for dual boot, XP Pro and Vista. After the beta testing, I decided to remove the Vista and tried to install Ubuntu 5.10 in the Vista partition. I am not new to Linux but Ubuntu partitioning program seems to be different from other Linux flavors like Fedora, Red Hat, Mandrake. During this process, it asked me to repartition the target drive or partition for swap and / mount point. So I did and select to format the partition created. During the format process, it came back with an error message saying that the partition is not a FAT filesystem. There is only one selection which is Go Back. Going back brings me to the partitioning program again. I aborted the installation and rebooted my computer. This is where my problem started. After each reboot, it always comes with a message, "No bootable device, --strike F1 to retry boot."

    I went to the Recovery Console on the XP CD and do fixmbr and fixboot. The recovery console didn't help at all. I tried to repair the installation using the repair from the XP CD but no luck. I tried all sorts of troubleshooting using different utilities but no luck. So I decided to reinstall XP Pro. The installation went through the first process of install which is the Test Mode Install process. It rebooted the first time, and when it should display the Windows XP logo, it didn't. It was just a blank screen. I went to the recovery console again and tried the fixboot and it seems to be pointing to C: this time. I again tried to reinstall XP Pro but again, the same problem, blank screen after the first reboot.

    This time I tried the DSRFix utility from www.goodells.net and it gave me a lot of alerts and some fatal messages and can't do any dsrfix on my MBR.

    I need to repair my MBR and I would like the help of those who has experience in editing MBR particularly the Dell XPS Gen 2 model. Or if you will be kind enough to send me a copy of your XPS Gen 2 MBR. There is a utility called MBRSaver in www.goodells.net/dellrestore. Or if you know where I can find a source to download a Dell MBR code.

    My system is a Dell XPS Gen 2
    100GB HDD, 1GB RAM


  2. N3051M

    N3051M TS Evangelist Posts: 2,115

    Simple. IF your HDD uses a RAID setup or SATA HDDs, you need to use the third party drivers (from the motherboard's CD or download from dell somewhere) and use them when the windows installer says "Press F6 to use Third Party Drivers"

    If its IDE, check cables are ok and jumper settings ok.
  3. MatangLawin

    MatangLawin TS Rookie Topic Starter

    Thanks for the reply. I forgot to mention that my computer is a Laptop not a desktop. I have only a single drive. HD checked to be ok. I used a utility from Fujitsu site cuz my HD is a Fujitsu.
  4. N3051M

    N3051M TS Evangelist Posts: 2,115

    Well see if it needs the dell motherboard/driver cd to boot with first.. SATA HDDS do exist for the laptop area..

    i'm not sure if dell has a specific MBR structure that it needs to be able to be used, but in theory, treating it as a normal HDD/install, if the cd doesn't work, try doing a low level format on the HDD, not using window's one but with the fujitsu's utility or similar.. that will at least bring it to near factory conditions
  5. MatangLawin

    MatangLawin TS Rookie Topic Starter

    Thnaks, it's working now....

    Thanks again N3051M. I got it working now. I used the Powerquest Boot Editor to edit the boot record. Dell had set the MBR so that the 1st partition have to be the Dell Utility Partition, 2nd to be the C:\ which has to be set to be the boot partition. Editing the MBR to boot on the 2nd partition fixed the problem. This case is closed.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...