Help Connecting to the Internet

By AndrewPeter ยท 21 replies
Oct 4, 2008
  1. I have my PC connected by cable to my router, it seems to be assigned an IP address etc from the DHCP but I cannot connect to the Internet i.e. it just comes up with the cannot display webpage.

    This puzzles me because it has always worked and turned it on today and wont! I have tried many things such as the winsoxfix etc but no success. Another strange thing is that if I click renew IP address, it fails and comes up with limited connectivity.

    Can anyone help me please as this is driving me mad!


  2. manacloud1

    manacloud1 TS Rookie Posts: 21

    hey andrew posting the type of router you have would greatly help. computer specs as well.
  3. AndrewPeter

    AndrewPeter TS Rookie Topic Starter


    I have a Sitecom wireless router, my laptop that I am using is connected via wireless and the internet works fine. My PC is connected to the router via cable and the specs are:

    Pentium 4 3ghz
    512 mb ram
    Windows XP

    I have tried also resetting the winsoc. I can log in to the router details page via the wired pc but the internet will not work!
  4. manacloud1

    manacloud1 TS Rookie Posts: 21


    have you tried updating the firmware for your router. As well as plugging the computers cat5 wire that doesnt work into the different slots of your router?

    your problem is still very brief so help me out here.

    is your wifi working?
    have you tried other computers connected directly to your router which works?
  5. AndrewPeter

    AndrewPeter TS Rookie Topic Starter

    Yes I have updated the router firmware - I dont think it is the router as other PC's work by cable or wireless and in the same socket.

    The pc not working seems to connect to the router when you start the pc but I do notice that it does not seem to receive any packets when looking at the local area connection status.

    If I click repair in that window, it then fails to acquire an IP address and gives limited connectivity..
  6. AndrewPeter

    AndrewPeter TS Rookie Topic Starter

    A bit more infor for you that may help:

    When I click on the IE 'Diagnose Connection Problems' the end results reads, 'Error attempting to validate the Winsock base provider: 2 Not all base service provider entries could be found in the winsock catalog. A reset is needed.

    However, I have already reset it!
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    It sounds like it's not getting an IP address from the start.
    • Does the router indicate link status? (There should a status light for the router port that lights up when they're just physically connected indicating good link level connection between devices)
    • Didn't go back to re-read thread details but i assume you've also tried different cables and trying different router ports?
    • Could you reboot into safemode with networking. When machine comes up Start->Run, enter cmd /c ipconfig /all >Desktop\out.txt. Attach the out.txt file to your next post
    • Check the ipconfig output to find the router address. Start->Run enter cmd, Then enter: ping where is the router address. Does it indicate ping response?

    /************ EDIT *************/
    And are you XP Pro or Home? What Service Pack level?
  8. manacloud1

    manacloud1 TS Rookie Posts: 21

    hey again


    have you tried going into the computers Bios and check the Lan settings? Could be the onboard lan is disabled unless you are using an ethernet card. I dont think it is so much the router ,but the computer you are using, however in most routers not all the ethernet ports work. Maybe the connector you are connecting to is a switch. Switches dont act like the other ethernet ports.

    Hope this helps, also ive notice most routers do not have one working ethernet slot, so try another router and get back to me, but from what i read from the microsoft webpage it is a key error on the computer. Somehow the computer has damaged files for the internet protocol.

    so try doing all this at the microsoft webpage for help using the different steps to repair. Then get back to me.;en-us;811259
  9. AndrewPeter

    AndrewPeter TS Rookie Topic Starter

    All the links are working on the router and I have tried cables in different ports etc and everything works apart from this PC.

    I tried pinging the router using the PC and the router responded to etc without any packets being lost.

    I have done the ipconfig/all, which is attached and as you can see it looks all fine but the internet just does not work!

    I am using XP Home with Service pack 3


    Windows IP Configuration

    Host Name . . . . . . . . . . . . : andrew-desktop
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Mixed
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : SiS 900-Based PCI Fast Ethernet Adap
    Physical Address. . . . . . . . . : 00-01-6C-A0-A7-DE
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . :
    Subnet Mask . . . . . . . . . . . :
    Default Gateway . . . . . . . . . :
    DHCP Server . . . . . . . . . . . :
    DNS Servers . . . . . . . . . . . :
    Lease Obtained. . . . . . . . . . : 05 October 2008 11:34:12
    Lease Expires . . . . . . . . . . : 08 October 2008 11:34:12
  10. AndrewPeter

    AndrewPeter TS Rookie Topic Starter

    Something that may help:

    I have just been looking at the event viewer and there are errors ar about the time when the internet stopped working - they read:

    Event ID 17: Time Provider NtpClient: An error occurred during DNS lookup of the manually configured ',0x1'. NtpClient will try the DNS lookup again in 5 minutes. The error was: A socket operation was attempted to an unreachable host (0x80072751)

    Dont tknow if that means anything to anyone but could be the problem???
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Interesting.. if you look at your ipconfig output note you have no DNS servers assigned. The entry points to your router.

    why don't you try (from a command prompt)


    then ping one of the addresses it returns (DNS translates those names to addresses so let;s see if you reach it by numeric address alone)
  12. Anne_Marie

    Anne_Marie TS Rookie

    It sounds unlikely, but unplugging your entire router and switching everything off for 15 minutes can make a strange difference. I remember having a similar problem in the past and just shutting down shop did the trick.

    You definitely need to take a look at that DNS setup. I'd recommend taking a look at LookinAround's latest post. Also do you have any anti-virus software at work?
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1. Powering everything off and back on never hurts (many times helps) as suggested by Anne_Marie
    2. You should be able to logon to your router (see your router manual) to verify its status to confirm it's connected to your ISP. Or you confirm that fact if another device connected to same router clearly working over the internet
    3. Will offer some add'l info about leaving it off for 15 minutes. This typically only applies if you're not seeing a connection between router and ISP (or cable modem and ISP). Some ISP do "hardware provisioning" and recognize if you change a hardware device connected to their modem. They often won't connect to it. Unless you call them to tell them of change OR in most cases you can get them to reset the hardware address they connect to by "leaving everything off" for 15 minutes
    4. Usually if you router is connected to your ISP it gets the DNS addresses and they should then be reflected by IP config. Was your router connected to ISP at this moment time? As the router clearly responded with an IP address but not DNS addresses.
  14. AndrewPeter

    AndrewPeter TS Rookie Topic Starter


    Apologies for the delayed response - your help with this is much appreciated.

    I have tried the nslookup suggestion and the attached file shows the outcome, basically it said the DMS request timed out.

    So I think it is something to do with the DMS - in regards to powering everything down, I have tried this but makes no difference and the fact that the other 2 pcs connected to the router work fine, suggests its an issue with the actual pc?
  15. AndrewPeter

    AndrewPeter TS Rookie Topic Starter

    I should also add that I pinged one of the addresses as suggested after the nslookup and again no packets were lost?
  16. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    from a command prompt enter: ipconfig /flushdns

    then try again

    /************ Edit *****************/
    OOOOp.s Also thru Network Connections, get Properties for the network adapter(s) yoiu are using eg. LAN, wireless
    On General tab, click on Internet Protocol (TCP/Ip) then Properties button
    See Obtaind DNS server automatic is checked
  17. AndrewPeter

    AndrewPeter TS Rookie Topic Starter

    It flushed the DNS successfully and I tried the nslookup again, but got the same message as before. Pinged an address with no packet loss again.
  18. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    sorry. look at my last post again. i had added something about checking the computer's adapters (whichever u use for lan, wireless, etc) are set for automatic DNS config
  19. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    to clarify a couple things:
    - Ping an address with no packet loss is a good thing
    - You also want to ping it by URL i.e. ping
    (DNS xlates that URL to the numeric address)
    - After making sure DNS automatic is setup per prior post, you can enter
    ipconfig /release followed by ipconfig /renew
  20. AndrewPeter

    AndrewPeter TS Rookie Topic Starter

    I have checked to see the DNS auto is checked and it is.

    I have carried out the suggestions from your last post, please see the outcome attached:
  21. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    OK. A few things.
    - I assume your Sitecom is the only router between your computers and your ISP (you don't have multiple routers configured)

    - just as an aside, do you know that your wireless computers are, in fact, connected to your router not an open wireless network?
    - Do you have cable modem on other end? you use DSL or cable or other?

    Best steps i think
    - Turn off router and computer
    - Restart router give a minute or two (and test from wireless while down and back up they talk to it ok)
    - Restart computer. Now run the Network wizard again to let it reconfigure settings
  22. AndrewPeter

    AndrewPeter TS Rookie Topic Starter

    Still no joy after restarts unfortuantly. The wireless is deff conected to my router and the router is connected by telephone cable.

    As I say I am convinced it is computer related.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...