Help with external HD Enclosure!!!!!

By Dajinx1979 ยท 10 replies
Dec 24, 2006
  1. Hello Everyone I have a bit of a problem. I recently purchased a mad dog mega vault hd enclosure for an old computer of mine. In it I have a 40gb seagated hd. When I hooked up the usb cable to the computer windows xp is supposed to recognize and install it according to the manual. Then i am supposed to go to control panel, administrative tools, disk management and then the new disk wizard is supposed to launch to let me formatt the drive. Well the problem I'm haveing is when i go to disk management the drive is not listed and the new disk wizard never appears. The drive is spinning and is powered. It worked in my other computer. I found the the device under hardware profiles and it is listed as working properly. The only other message I got was that the device was connected to a hi-speed usb cable. There are no hi-speed ports on the computer and that the device would not fuction at full speed. I understand that but it still should function!!!1 I need Help!!
  2. dopefisher

    dopefisher TS Rookie Posts: 444

    Hi and welcome to Techspot. Please post your system specs here so we can better assist you.
  3. tipstir

    tipstir TS Ambassador Posts: 2,475   +126

    I've seen that happen, could be the HDD itself is bad. If you try another one is should work. Or you have something else using that drive letter that is on the UsB channel.

    C: local disk
    D: cd/dvd
    E: external drive
    F: zip drive or network drive mappings
    G: this drive
  4. Dajinx1979

    Dajinx1979 TS Rookie Topic Starter

    Ok I have recently did some searching but still have the problem. One correction is that the hardrive is a maxtor. So I tried to formatt the harddrive with MaxBlast 4. Under the setup your disk utilities it recognized the drive as usb. It let me format and partition the drive. Then it said your hard disk is ready to be used. So once I exit MaxBlast I cant find the harddrive on my computer. Where is it located so i can use it? I went to device manger and it list the device as a usb mass storage device as working fine.
    It reads:
    Device Type: Universal Serial Bus Controllers
    Manufacturer: Compatible USB Storage Device
    Location: Location 0 (Cypress AT2LP)

    Is this location being 0 the problem? How do I change it?
    By the way I updated the usb ports to 2.0 and they work fine with my other usb devices so I dont that thats the problem anymore.
    How do you change the drive letter on the usb channel?
  5. Nolalefty

    Nolalefty TS Rookie

    I am having a problem with a usb drive simular to yours, my laptop runs xp pro and will only see the drive if it is formatted NTFS, I would like to make it a fat32 to read ms-dos. I can only format it if I put it in another computer as the C-drive and I do not have the option to format as FAT32. I don't have a solution to your problem but maybe this info will help. basically can a drive be formatted FAT32 if already an NTFS? Good Luck!
  6. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    get a command prompt and enter help format
    one option is

    /FS:filesystem Specifies the type of the file system (FAT, FAT32, or NTFS).​
    hopefully obvious, the HD must have a drive-letter assignment for this to work.
  7. tipstir

    tipstir TS Ambassador Posts: 2,475   +126

    Something wrong here. How many drives do you have open can you explain? So when you connect to the UsB 2.0 the computer should see the drive and give it the next letter.
  8. Dajinx1979

    Dajinx1979 TS Rookie Topic Starter

    I have a hard drive on C: a hard drive on F: A CD ROm Drive On D: a DVD Writer on E: and a virtual drive on G:
  9. Dajinx1979

    Dajinx1979 TS Rookie Topic Starter

    I have a hard drive on C: a hard drive on F: A CD ROm Drive On D: a DVD Writer on E: and a virtual drive on G: Is H supposed to be the next letter?
  10. nickc

    nickc TechSpot Paladin Posts: 923   +11

    your drive should be listed in my computer along with all other drives.
  11. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    xp pro can read FAT 32. However, since you are going from IDE to USB, you need a USB2 port. You will need to buy a USB2 PCI card.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...