Help with Oblivion please

By nessty
Feb 3, 2008
  1. Hi, I'm just writing to see if anybody can help. We just tried to start Oblivion and received the error message nixadapterdesc::getdevicecaps()failed. I have tried updating my video card (ati radeon 1300 pro), uninstalling and reinstalling the game, and even restoring the computer to a restore point I knew worked before. We have beat the game once and was partway through with the second class so I know my computer can run it. Please, please help!!!!!!
  2. alisbin

    alisbin TS Rookie Posts: 93

    hmm, a couple things to try and a couple questions.
    1, do you have any mods, official or unofficial, installed (especially ones that play with graphics)?
    2, when you reinstalled oblivion did you do a full uninstall then delete all the remaining files just to be sure? (particularly the ini files)
    3, do you have the latest patchs?
    4, can you think of anything driver related that you've installed between it working and it not working? btw, a restore point won't neccesarily help if you have a driver file corrupted. its not replacing all the files with old versions, just doing some registry tinkering.

    try the oblivion unofficial patch, it fixes ALOT of bugs, whether this is one of them i dunno, but its worth a try.
    try reinstalling directx (thats directx related error i think), also try several video card drivers, maybe the current version you have doesnt like oblivion.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...