Heur / Vundo

By davelaptop ยท 9 replies
Sep 21, 2009
  1. Hi there! Don't know if this is the right place, but i'll give it a go and hope you can help!

    AVG popped up with "Heur" virus and "Vundo" has been seen a few times as well. There were popups and all sorts of weird error messages. However, they seem to have stopped since going through the 8 steps (thanks!). However, when checking the old versions of Java have been removed, clicking on Control Panel brings up "Explorer.exe - Application not found" and I have to go through a different menu. Is this still because of the viruses or something else thats easily fixed?

    Also, I've included the logs, is there still a threat with my computer?

    Any help will be most appreciated!

    Cheers and keep up the good work,

  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    This coud be caused by virus damage... See if you can restore Windows to an earlier time. Also see if you can install Vista Service Pack 2 and any other missing Windows Updates after a sucessful restore
  3. davelaptop

    davelaptop TS Rookie Topic Starter

    Restoring windows to an earlier time - won't let me go back further than when the problem happened.

    Installing Service Pack 2 - won't let me update Windows through the normal way and for some reason won't let me on any Microsoft website to download it. Is there anywhere else I can get it from?
  4. Punkid

    Punkid TS Guru Posts: 422   +7

    try googling
  5. davelaptop

    davelaptop TS Rookie Topic Starter

    Unfortuantly, all the ones I have tried through google eventually link back to the Microsoft website. I see that SP1 is available on download.com but no SP2. Any guidance?


  6. Punkid

    Punkid TS Guru Posts: 422   +7

  7. davelaptop

    davelaptop TS Rookie Topic Starter

    Tried it and it said cannot find server download.microsoft.com

    Any ideas?


  8. Punkid

    Punkid TS Guru Posts: 422   +7

    i'd say dude just reinstall your OS and try something like Kaspersky Internet Security
  9. davelaptop

    davelaptop TS Rookie Topic Starter

    The virus indications are stopping now so most problems have gone away. But there is still an error when trying to run videos:

    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: explorer.exe
    Application Version: 6.0.6001.18164
    Application Timestamp: d05ebc67
    Fault Module Name: mcmpgdec.dll
    Fault Module Version: 2.0.4178.0
    Fault Module Timestamp: 4496feaf
    Exception Code: c0000005
    Exception Offset: 00013d40
    OS Version: 6.0.6001.
    Locale ID: 2057
    Additional Information 1: fd00
    Additional Information 2: ea6f5fe8924aaa756324d57f87834160
    Additional Information 3: fd00
    Additional Information 4: ea6f5fe8924aaa756324d57f87834160

    I don't know if this is easily fixed but i've tried searching all over google for it and haven't got anywhere. I believe the file causing the error is linked to Corel Video Design but can't be sure. I've uninstalled it and still a problem. Any ideas?


  10. davelaptop

    davelaptop TS Rookie Topic Starter

    I've tried one technique of going through the command window and typing "regsvr32 mcmpgdec.dll". This brings up the following response:

    The module "mcmpgdec.dll" failed to load.

    Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files.

    The specified module could not be found.

    Does this help with diagnosis?


Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...