1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

HP DV7-1245DX will not boot to any device

By sethbest
Oct 5, 2011
Post New Reply
  1. I got in a HP DV7-1245DX today with the error code: 03F0 which then says "No boot device present, Install operating system".

    This system was apperantly running normally, and then was going slow so the user reset it and started getting that error.

    I thought this was a dying drive or corrupt boot sector but this code continued when the hard drive had been removed, and the system would find no other boot devices. I tried bootable cd's, dvd's and a bootable USB stick that I know works, and the system does not see any.

    The odd thing is it CAN run a disk scan on the hard drive when its plugged in. It just does not see it in the boot manager. The boot manager is actually blank, showing no options for devices. I setup the boot order properly, and made sure "cd drive" was enabled as a boot device, but this changed nothing. I tried bios defaults also.

    I removed the memory, tested each individually, unplugged the power and cmos and put everything back in, plugged in another hard drive with a different windows install, nothing changes the error.

    I put the original hard drive in an enclosure and ran a MBR rebuild on it with EASEUS, and a disk scan which returned no errors, the system still could not boot to the device.

    The only thing I can think at this point is that the disk controller went bad. Any other thoughts?

    I have tried multiple motherboard repair services around the country for previous laptops with motherboard issues, but never found a reliable one (usually get them back to die a few days later) so if this is a disk controller issue this system gets sold for parts.
  2. sethbest

    sethbest TS Enthusiast Topic Starter Posts: 77

    Just an update, I fixed this in a way that makes absolutely no sense. I gave up and then just started messing around with it. I put two hard drives in instead of 1 and it booted right up. Removed them put back in the original now it works fine. All I can think of is that the drive controller was somehow corrrupted, and even with bios reset stayed messed up; then the 2 drives somehow got it working again (2 drives providing input somehow fired it up?). Anyways, I hope this obscure happenstance helps someone else.
  3. foundmysolution

    foundmysolution TS Rookie

    I would like to add to this post because I was experiencing almost identical problems as this poster and I was able to find a proper fix on my dv5-1100.

    Updating the BIOS on my computer solved all boot device detection problems. If you go to the HP website for BIOS update F.23 (hxxp://h10025.www1.hp.com/ewfrf/wc/softwareDownloadIndex?softwareitem=ob-68241-1&cc=us&dlc=en&lc=en&os=4063&product=3759541&sw_lang=) you will notice that it states the following in the changelog:

    Resolves an intermittent issue where the bootable device is lost when powering up or restarting the system.
    You can either use their Insyde flash utility, or you can use 7-zip to extract the .FD files from the sp#####.exe,

    After you extract the .FD files you must rename them by removing everything after the first four characters and renaming the filetype to .BIN.

    Once the file is renamed, you can put the .BIN file on a USB formatted to FAT32 and restart your computer holding the Windows and B key simultaneously until you hear a BEEP from your PC speaker.

    After you hear the beeps, the screen will stay black until you see a "flashing ##%" box and then the computer will shut down by itself after 2-5 minutes.

    Hope this post helps out anyone that got stuck where I was.
  4. sethbest

    sethbest TS Enthusiast Topic Starter Posts: 77

    Hey foundmysolution, thanks for posting.

    I checked the bios when I first got the problem fixed and there was no update, but there is now. Downloaded and flashed, hopefully this fixes my problem for good. I actually opened a new post about this system just a few days ago since the problem kept re-appearing, so your response is very timely.

    Thanks again.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...