I can’t get PCI Express to work on my new/old mobo

By alx149 · 7 replies
Jan 15, 2012
Post New Reply
  1. I can’t get the PCI-E X16 slot to work on my new/old 939 mobo. It’s an old socket 939, but new, right out of the package.

    Might be presumptive of me to dump all this info here, but the computer is for my homemade lab and I teach high school in a poor neighborhood, so any help you might give is for a good cause.

    Here are the build’s specs:

    CPU: Athlon 64 Fx55
    Mobo: AN8 VM with Nvidia 6150 onboard, with a pci-e x16 slot
    Mem: 2x 1gb sticks of DDR 400
    PSU: 600 Watt Corsair

    When I tried to install a new pci-e x16 card, Radeon HD 5450, the monitor gets no signal. The computer comes on, does not post (keyboard does not light up), cpu fan and PSU fan both turn on, but nothing else happens.

    When I then take the pci-e card out and plug the monitor cord into the onboard video card, everything works fine, but ONLY if I take the pci-e card out. When I leave the pci-e card in and plug the cord into the onboard card there’s still no signal

    Things I’ve tried already:

    I plugged the card into another computer. It works.

    I plugged another pci-e x16 video card, an 8800gt, into this build and the same things happen, no signal.

    Tried with both the onboard card’s manufacturer’s driver and the standard window’s driver and tried both of these with them enabled and disabled and uninstalled in device manager

    Did most of the trouble shooting here with each of the three latest versions of bios available for my machine.

    BIOS settings I tried:

    Under Northbridge configuration there are a few seemingly relevant categories of parameters that can be tweaked, “VGA Options” and “Primary Graphics Adapter” are the ones I adjusted, but to no avail.

    Under “VGA Options” the choices are ‘Enable’ and ‘Auto’, the descriptions in BIOS of what they do is somewhat muddled.

    For ‘Enable’ it says: “enable onboard VGA, this should be chosen only when nvidia external VGA was installed.”

    The Auto description states: “disable onboard VGA if external”.

    The other parameters of interest, “Primary Graphics Adapter” has two options:
    “PCI->PCI-E->IGP” and “IGP->PCI-E->IGP”

    Mostly I troubleshot with “Auto” on and “PCI->PCI-E->IPCIGP” as that seemed to make sense.

    Other BIOS parameters that I didn’t try to adjust, but might be relevant are:

    OnChip VGA Frame Buffer
    OnChip VGA Trap Enable
    Under Hypertransport Configuration
    LDT to Geforce frequency
    Repost video on S3 resume

    Then there’s the IRQ stuff, under which there’s an option to “Allocate IRQ to VGA.” I think the choice3 is to have Bios do so automatically.

    The mobo is right out of the package and everything else works like a charm. My two 1 gb mem sticks might nit match.

    Everything is clean and all connections have been checked and double checked, what’s more I’ve tested the cards and monitor and they work.

    It must be either the pci-e X16 slot is broken somehow but hopefully I’m missing something in BIOS which someone here can shed some light on. Thanks in advance.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

  3. alx149

    alx149 TS Rookie Topic Starter

    Obsolete? Don’t you mean legendary? The 939 that ran the EPIC FX 60, the extremely happening dual core processor from back when AMD spanked Intel on a daily basis. I rehab PCs from parts and such for my homemade classroom lab and have concocted a number of 939 builds, and recently made a 939 build with an 8800gt for my sons with said FX 60, runs skyrim on high settings without a hitch.
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    It may have run well, but manufacturers dropped the design almost unanimously after just a few years. Does the link I posted show your board?
  5. woodyshopper

    woodyshopper TS Rookie

    Change Primary Graphics Adapter

    Try to change first Primary Graphics Adapter on BIOS to... PCI ... and not PCIE x 16 that will desactivate the onboard graphic and will start the PCIE x 16.
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Hey woodyshopper,
    don't you have that backwards?
  7. Buckshot420

    Buckshot420 TS Enthusiast Posts: 301

    Might be your keyboard/USB causing the POST problem. Seems like more of a headache than it's worth. Why not just upgrade mobo?
  8. Darth Shiv

    Darth Shiv TS Evangelist Posts: 1,811   +472

    Definitely have onboard VGA disabled.

    PCI-E first is the ideal solution. If not pick the PCI->PCI-E-IGP. It won't detect anything PCI then will try PCI-E.

    Since you've fiddled with this stuff my guess is the slot is blown. Another thing to try is disable ActiveArmor (in bios). It might not sound related but I had instability with my NVIDIA chipset S939 board back in the day and that had to be disabled for it to work nicely.

    PCI-E slots don't have to worry about IRQ so you don't have to fiddle there.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...