Installing PCI card..drivers: data invalid error

By later2day ยท 24 replies
Apr 5, 2002
  1. I upgraded my mainboard from an ASUS A7M266 to a Soyo K7Dragon+ and found that XP would not let me load the mainboard drivers. So I wiped my drive and started over without any pci cards installed. After XP was installed I tried to install my Soundblaster Live Card. Windows told me that the data was invalid so it could not load the drivers. Son of a... I tried moving the card to a different slot, and also tried removing it and using the onboard audio. Both solutions ended up with the same answer, the data invalid error. I looked into the problem and found out that it is a problem in windows xp with pci cards and scsi device pci cards. Here is the solution for those of you that may experience that. The fix works, I know as I am living proof!

    Why do I get the message "data is invalid" when installing a device driver under WindowsXP?

    This error appears to be due to a protection problem in the Windows registry and can occur with a variety of drivers (sound cards and SCSI drivers have been reported). To fix this problem, go to Start, Run... and type "regedit" without the quotes to run the Registry Editor. Navigate to


    and you will see a number of keys of the form "VEN_xxxx", where xxxx are strings like "1102&DEV_0004&SUBSYS_00011103&REV_04". Under each of these folders will be another folder with a long numerical name. Open each folder and look for the "DeviceDesc" which matches the hardware you are trying to install. Right Click on the "VEN_xxxx" for that device and select 'Permissions' and then tick "Allow" for "Full Control". Close Regedit and then continue with the installation of your device.

    I hope this information helps someone out there!

  2. andrew_ysk

    andrew_ysk TS Rookie

    the data is invalid windows2000 smc fast ethernet network card - no permission button

    sir, regarding the very same problem as mentioned in the thread. Yes, i heard lot of website providing the same method of solution, but when i use regedit, there is not "permission" button in it. Hence the solution is not workable for me althought i am facing the same problem as mentioned.

    i am using windows 2000 pro
    amd xp athlon 2000

    pls advice.
    thank you,

  3. Triton

    Triton TS Enthusiast Posts: 82

    In Windows 2000 run regedt32.
  4. andrew_ysk

    andrew_ysk TS Rookie

    windows 2000 regedit don't have "permission" button.

    windows 2000 regedit don't have "permission" button, not as windows xp.

    when used regedt32 (this s/w got permission button), but there is only 1 pci device shown, unluckly, the device having problem not shown in it.

    while regedit shows 8 pci devices.. one of them is faulty driver.

    pls advice if you have more detailed help.

  5. Triton

    Triton TS Enthusiast Posts: 82

  6. andrew_ysk

    andrew_ysk TS Rookie

    i can't find the registry of my installed networkcard in regedt32.can c it in regedit

    dear sir,

    the problem is not administrator, this time. because there is only 1 user in the computer , and the user is holding administrator right.

    the problem lies at :
    i didn't even see the registry of the network card i installed when using regedt32, how can i click "allow permission" if i didn't able to see it ?
    in regedt32, i only saw 1 registry under "pci".

    how ever, i can see 8 pci registries in regedit.

    is there anyway to totally disable the hardware installation protection ? by policy editor or registry .


  7. Triton

    Triton TS Enthusiast Posts: 82

    The directions at the given link show how to give "Permissions" to "PCI" (bus);
    """Make sure that PCI is selected/highlighted. Now click on Security > Permissions. The following dialog will appear: """
    and "all child objects";
    """"Make sure that Reset permissions on all child objects and enable propagation of inheritable permissions has been enabled/checked. Allow inheritable permissions from parent to propagate to this object needs to be disabled/unchecked. """"
    PCI devices on the PCI bus will inherit the permissions.

    """in regedt32, i only saw 1 registry under "pci"."""
    Have you ever installed a Leadtek WinFast Graphic Adapters.;en-us;810509
    """The Leadtek driver installation program incorrectly changes the security attributes for the Enum branch of the Registry, which is critical for driver installation. As a result, attempts to install drivers later are not successful."""
  8. Zlen

    Zlen TS Rookie

    Thank God for this thread!!!!!!!

    Thank you both!
    Awhile ago I had a problem installing a soundblaster card, about
    a year ago and was never able to get it to install. My motherboard
    has 5.1 onboard so I just ended up using that.

    I just bought a wireless Zonet g card and was recieving these errors
    while trying to install, Code 1, invalid... I have been looking through
    threads on problems with the driver for this chipset but found nothing.

    Then I came across this last post with the problems that the leadtek
    card has. Uvcourse I have a leadtek A250. I downloaded the
    patch from the link you provided, microsoft website and then
    attempted to re-install the driver for the pci g card.

    It works!!!!!!!!! Yeeeeha!
    Thank you again for putting your knowledge into this thread.
    Greatly appreciated!!!! :giddy: :giddy:
  9. Priyanka

    Priyanka TS Rookie

    Many Thanks for the advice

    Many thanks to all subscribers to this thread. I too experienced this problem when installing a network card. The computer repairman claimed vehemently that my O/S must be corrupt and recommended a major overhaul of my computer.

    Luckily that wasn't necessary in the end thanks to you all (and Google for finding this thread!). I've printed out the Microsoft Knowledge Sheet to show computer repairman as well.


  10. ARAKIS

    ARAKIS TS Rookie

    Invalid Data (hid-scanner-on Board Sound Card

    I have the same problem but not with PCI cards. XP does not recognise my on board sound card (multimedia Device) - 2 HID devices (I dont know what exactly - and my EPSON scanner USB2

    Is the solution you suggest the same in my case?

    THANKS in advance
  11. kaybulsolo

    kaybulsolo TS Rookie

    Method works perfectly!

    I was having some dificulty installing the drivers for a Promise Technology Ultra100 TX2/133 TX2 PCI IDE card on my Windows XP Home w/ SP2 machine.

    I used the method and it worked perfectly!

    Thank you!
  12. RichieP

    RichieP TS Rookie

    I though I'd finally found a fix for this annoying problem but it doesn't work for me.

    I'm trying to install a PCI Network card but keep getting the "Data is invalid" message.

    Done the registry bit so any other suggestions gratefully accepted.
  13. rush2112

    rush2112 TS Rookie

    I would really like to say a big thank you to Buzz for posting a solution that worked like a charm on my seemingly impossible graphics card installation problem.

    First, my system:
    2.4 Ghz P4 (not overclocked)
    8iexp Gigabyte motherboard (845E chipset, 4x AGP)
    1 GB ECC DDR PC2100
    6600 GT AGP 8x 128MB by PNY
    80 GB Wester Digital HD

    I was trying to upgrade the graphics card on my admittedly not so new system and the drivers just would not install. I kept getting the "data is invalid" error when using the XP hardware wizard.

    If I used the Nvidia installer directly, it would go through the whole process without any error - the drivers would show up in the windows/system32 directory but the graphics card still showed up under the "Unknown Device" entry in the Device Manager after the restart. (As an aside - I have heard that the card should have shown up under "Display Adapters" with a question mark before sucessful driver installation but I never did figure that one out - if anyone has any ideas....)

    At first I thought perhaps my system was just too old for the 6600 GT and so I downloaded all the latest drivers for the BIOS, chipset etc. but no luck. Finally after spending way too many hours lurking around various forums I found the amazing post by Buzz. Went to the registry and amazingly enough the permission box for "Full Control" was NOT checked for this card! (And yes, I was logged in as Admin.) I checked that baby and the drivers loaded right up. After the restart, the card showed up under "Display Adapter" in the Device Manager and works great!

    Thanks again for the super solution!
  14. sigmatech

    sigmatech TS Rookie


    I received "the "data is invalid" error while trying to install the onboard audio after moving my hard drive to its 3rd computer. I have been running this installation of WinXP Pro for almost 2 years, and I really didn't want to have to reformat and start over as others have suggested.

    I tried the Registry premissions first, but that didn't work, so I began searching for other options. Finally I found a person who suggested that replacing the file on the hard drive with the one from the install CD.

    Worked great! I hope this helps someone else from going 2 weeks with a computer with no sound. ;)
  15. budman

    budman TS Rookie

    I received the "data is invalid" also, when trying to install a Compaq NC3121 Fast Ethernet card driver.

    I tried three hours on my own, and hit the google searches! Found this website.

    I tried the Permissions thing----didn't work. Also saw that on another website too.

    I tried looking for the Driver's file to recopy from the CD thinking maybe it was corrupted----couldn't find it.

    What I did find (AND THIS WORKED), was the Driver Cache folder.

    I deleted everything in it, and immediately hit the Device Manager, and added my NIC driver! VOILA!
  16. arne99

    arne99 TS Rookie

    For all Invalid Data Messages with AC 97 ChipSet

    That will work:

    Just sign in as administrator (maybe change user profile to manual input mode) and login as admin. (username: administrator - password: you'd typed in while isntalling winxp)

    Now isntall the driver. all will work!
    yust sign in as normal user (admin or not) and you will have sound :D

    for questions...ask me
  17. BruceB

    BruceB TS Rookie

    This problem has been driving me crazy with multiple USB drivers for several months now. The Permissions fix doesn't work for me.

    Which is the driver cache folder? Is it really safe to delete the entire contents of the folder?

    Any other tips?

    Thanks in advance...
  18. budman

    budman TS Rookie


    Back it up first, then delete everything in it.

    Open Device Manager and Click Update Driver.

    No more problem. :) :) :)
  19. kk_v_in

    kk_v_in TS Rookie

    Delete Driver cache works on WinXP

    Hello ,
    Deleting C:\WINDOWS\DRIVER CACHE\i386 works for sure. I had similar problems installing HID devices . Now everything works .
  20. Jorgealto

    Jorgealto TS Rookie


    Hard a lot of trouble installing my Audiophile 192 on my asus P4s333 mobo. Always got the "invalid data" dialog. Cautiously did the regedit permissions change. Now working a treat.Thanks for the advice because I was on the verge of smashing my computer.
  21. carostrelec

    carostrelec TS Rookie

    Finally solved!

    Thank you!!! I tried EVERYTHING - changing permissions in registry, reinstalling SP2, deleting drivers in other location... but this one finally worked! Take care!
  22. andy_wall101

    andy_wall101 TS Rookie

    Still not working

    I've tried all of the suggestions so far: Permissions, deleting the driver cache etc. but still not working for me! Does anyone have any other suggestions I could try?
  23. ben disraeli

    ben disraeli TS Rookie

    Budman, thanks a million!

    Finally solved the issue...thought I had a serious hardware issue there...
  24. visaliagraph

    visaliagraph TS Rookie

    Thank you, thank you, thank you.

    Although I know this is an old post, but this post is my latest find. After adding and re-adding my Epson USB scanner all of two days I tripped over this post. I was receiving the data invalid error after PNP finished its "install". The setup went wrong from the beginning and like drawing a line in the dirt for water to flow Windows kept adding the wrong device, following the wrong setup. i could see it in the install log.

    After simply deleting the C:\Windows\Driver Cache\ folder and its contents (i386 folder) it finally added correctly.

    Microsoft should give the operator the option to ignore this folder if desired.

    MAYBE A STUPID LITTLE CHECK BOX to try if all else fails. Hmmmmmm.

    THANK YOU all that Contributed. Native to Macs I probably would never have figured this one out.
  25. cartguy

    cartguy TS Rookie

    Data Invalid

    Hi, typical error (data invalid), have tried changing permissions, even reset the register tp default settings and still getting the error. I installed a Netgear WG311v2 wireless network adapter, I'm not sure where to go from here, can run cables but that defeats the purpose of a wireless router.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...