Intel 975Xbx stopped recognizing memory - 3 beeps

By Duncan Yahn ยท 6 replies
Oct 7, 2006
  1. life is a world of suck now. $1500 system I put together myself and no problems for a month. Working great last night...this morning it won't get past post and issues 3 beeps indicating NO MEMORY. Now keep in mind the system wasn't touched between shutdown last night and startup this morning. No storms last power dumps either (at least all the clocks were still displaying the proper time this morn)and the system is on a good quality surge protector/battery backup.

    I have consulted all docs Intel has to offer and have gone through all the troubleshooting steps (basically disconnect all periphs, verify memory is still good, verify pow supply is still good). So all that is done but still won't get past 3 beeps.

    Now here's a bit of light. While disconnecting periphs one at a time and leaving them disconnected (in case more than one was bad), it got thru post right after disconnecting the keyboard. So I leave that out and hook the HD back up so it could boot and then restarted the system. No go. 3 beeps again. So I think HD is fried too, right? Wrong. Unhooked HD and still the same prob. Soooo, for whatever reason, that one time without the keyboard it worked. So now I'm getting schizoid results and this lets me think, "maybe not hardware related but corrupted BIOS maybe?" If so, is it even possible to do a BIOS recovery if BIOS won't get thru post? Perhaps that's what removing that jumper does....let's it get thru bios and access the floppy that has the BIOS file so it can recover.

    Well...I don't know, but I'm not so sure the MB is fried just any help would be greatly appreciated.
  2. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    When you built your new PC, did you use a cheap power supply that came with the case? If so, I would look in that direction.
  3. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    you have to have a good POST to flash the BIOS.
    It is possible your memory is incompatible. If you have dynamic overclocking, turn it off in BIOS. Read my thread aobut NO POST in the guides forum.
  4. Duncan Yahn

    Duncan Yahn TS Rookie Topic Starter

    Pow supply good?

    Good point...but I saw that one coming (I had an issue a couple years ago with a diff system that had a cheap pow supply). No, I put in a Cooler Master 600w that ran me $140....and just in case it was fried anyway, I had the shop that sold it to me test it yesterday after the problem cropped up. It tested fine. :)
  5. Duncan Yahn

    Duncan Yahn TS Rookie Topic Starter

    Mem incompatible? overclocking set for RAM or the CPU.

    I was afraid that might be the case with flalhing the BIOS. Hmmm...I'm thinking I'm going to give it a try anyway since I'm at the "nothing to lose" point. What I'm hoping is that if the prob IS a corrupted BIOS, that by pulling the jumper, the BIOS will revert to the hardware ROM BIOS (ignoring the corrupted BIOS in memory) and recognize memory long enough to recover. Of course, this'll only work if there isn't a fried circuit somewhere causing all this. I'll let you know..

    As far as memory...the system's been working fine with it for a month now and I had it tested at the same place that tested my pow supply yesterday. I reads as good. However, it isn't "tested and approved" memory by Intel for this MB but it DOES meet all specs as laid down by them though. :)
  6. Duncan Yahn

    Duncan Yahn TS Rookie Topic Starter


    OK....removed the BIOS jumper from the MB and restarted to try a BIOS recovery...didn't work. Just like Tedster said, POST has to complete for any BIOS flash procedure to take hold whether the BIOS jumper is in or not. For all I know BIOS is fine anyway since I can't get past the 3 beeps to find out. What gets me is...why did it get thru post that one time after removing the keyboard but not again since then? If a circuit is should stay fried. As much as we all want them too...electronics don't heal themselves. Well...guess now I'm stuck with waiting for Intel to get back to me.
  7. Duncan Yahn

    Duncan Yahn TS Rookie Topic Starter

    Finally fixed!

    Well, I just spent 30 mins writing all the steps for this prob resolution here only to hit the wrong key on the keyboard and have it all disappear. (I hate when that happens) So here's the short version.

    The BIOS was corrupted from a peripheral failure. I had to remove the CMOS battery and wait 20 min for it's memory to fade completely out then ran a BIOS recovery per Intel's specs. Of course there was more to it, like disconnecting all periphs and reconnecting them one at a time after the recovery to find the bad peripherals. There were 2: the Printer and the Keyboard. The Printer was out and out fried...the keyboard was more insiduous in that it didn't immediately screw up the BIOS when I rebooted with it connected, but I figured it out eventually. So total casualties were those 2 and I have 1 bad USB port I can't use now.

    Oh, and here's a note that Intel and all other help but one didn't relate. When you unplug your power, hit the start button to discharge the capacitors on the MB or you could have a component fry when you remove it or plug it in. DDR and DDR2 memory especially.

    Thanx to all for the posts! Gratefully, Duncan Yahn
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...