IRQ dilema with a brand new Advent pc...!

By matrix358 · 4 replies
Jul 1, 2006
  1. Heya!

    This is my first post on what looks like a great forum..! I'm really happy and releived to have found it and I'm so desperate to get this frustrating problem sorted out! The Advent T9106 computer (if that helps at all..! ) in question is only 2 months old, and I made the grim mistake of shelling out far more on the thing than I probably should have lol..!

    The problem is related to the IRQ's. I switch on the pc and it hums into action pretty nicely, everything ticks and wirrs - no errors at all. Then when you start up a game, for instants, Microsoft Flight Simulator 2004, the glitches just come in fast and furious. You're able to swiftly switch views, barrel roll and vault above the clouds with relative smoothness during the first 20 mins, and then the computer seems to hit a brick wall. The picture jars, and the sound playing at the time of the lockup repeats itself on a really rapid loop - almost a constant hum. The computer then decides to either shut down and reboot completely, or i'll get the legendary 'blue screen of death' which is about as unhelpful as a paper anorak telling me that the IRQ is :


    The annoying thing is that MSFS2004 isn't the only program with issues - i'm a 3D graphics student embarking on a 3 yr BA course, so I'm worried about investing in expensive CAD applictions through the fear that it they not function and simply crash. X3 Reunion, MSTS, Halflife 2,Doom 3 - the list goes on, they all reach around about the 20 - 30 min point and lock up.

    Strangely, the only program that doesn't lock up is the most demanding 3D game of all, (and part of my reason for buying the new pc..)Battlefield 2! Hmm...!

    So all this aggravation from a new pc that cost me over £900. I can't tell you how annoying and frustrating it is - I’ve only made two alterations since the day of purchase, and those are a graphics card replacement (Now an X1300 Radeon) and the installation of a new wireless networking card (in the same slot as video DVB-T card was).
    I'd really appreciate any help, could I disable any of the USB ports? Are there any items listed that may be conflicting with eachother? I understand that one IRQ can house as many as 4 chipsets - but the setup is quite strange. Anyway, here are the specs and a screenshot! Again, i'd really welcome any advise to get this pc working as it should..!

    Cheers! (Sorry for the ludicrously long post!)


    (As you can see from above, single IRQ’s house many of the T9106’s devices. This is made even more complicated by the fact that the Graphics card cannot be shifted into another PCI slot. But maybe that’s normal..!)

    ADVENT 9106

    Intel Pentium 4 HT processor 630 ghz (2 cpu's)
    1024 mb of system ram
    X1300 Radeon Series (512mb ram)
    C-Media Audio
    250 Gb HD Space
  2. fastco

    fastco TS Booster Posts: 1,123

    try disabling the onboard network adapter in the bios, run a game and see what happens. if that doesn't work pull the new wireless pci card and start the computer and try the same game. If no good take out 1 memory module and try the game. Still no good try the other memory module (assuming that there are 2 x 512) Stll no good then swap out the video card for a different one and try the game. Something has to work..
  3. matrix358

    matrix358 TS Rookie Topic Starter

    Heya, thanks for the advice..! I've been really trying hard to think of things I could possibly disable to resolve the conflict, so last night (as a last resort)I decided to unplug the USB mouse and keyboard that came with the new pc and plug them into the ps1 / 2 slots leaving all the usb's completely free. I really didn't think anything remotley interesting would happen, but incredibly, everything seems to be running slicker! I also changed my desktop resolution from the higest setting to 1024 x 768 (i know its not exactly condusive but what the heck)

    So taking the fast running and improved performance on the desktop into account, I decided to boot up X3 Reunion and see if the differences had been carried through. And they have! The game runs extremely quickly now, and I've played about an hour and a half into it..! Its really strange! Half life 2 also seems much quicker and really shifts. And they all play for a lot longer, which is excellent. I'm not going to count my chickens just yet, but I'm pretty certain something has happened as a result of dissconnecting all my usb devices. I dont use the usb's much anyway (apart from the odd pen drive but thats it) so this isn't exactly problem for me.

    Anyways, if anything else happens i'll give your suggestions a try, but fingers crossed!
  4. matrix358

    matrix358 TS Rookie Topic Starter

    argh, still no joy - freeze frame sound loop crash after an hour of running X3 with the dreaded blue screen IRQ error :-(
    Will disable the network card and see if that changes anything, but I still can't see how its going to help - the card is asigned a seperate IRQ, so i would seriously doubt it stems from that. Its so annoying!
  5. nork

    nork TS Maniac Posts: 306

    Im not a gamer, but it seems to me that i have read on a forum that you can disable the com port to free up an irq. Provided, of course, that you arent using the com port. Still, i would wait for someone else to comment on the com port as i could very well be wrong.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...