1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Is My Drive Dead?

By EXCellR8 ยท 15 replies
Aug 22, 2008
  1. I'm having a serious problem with one of my new hard drives. It is a 500GB Western Digital SATA II internal hard drive. I recently had to do a hard reset due to a 3D application freezing up (which was installed on this drive) and now Windows XP does not detect the drive at all. I fear it might be dead. I can see it registered in the BIOS but the drive does not appear in "My Computer" or in the "Device Manager" as it did before. I have been using this drive for the past few weeks without any issues so I would appreciate any input on this. I'm not too familiar with the SATA interface so I could be overlooking something I suppose. Feel free to help me out. Thanks in advance.
  2. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    If its file system was being written to during the lock up, your file system is probably damaged.

    If you can't see a drive letter AT ALL, that means the partition table is damaged. There may not be much hope for using chkdsk to repair this, but check in Start > Run > diskmgmt.msc and let us know if you can see your 500GB drive.

    If you do see it, try to assign a letter to it (if possible) using Disk Management and run chkdsk on it by going to Start > Run > cmd /k chkdsk assigned_letter: /f to run a full scan. This will take some time, maybe an hour or so.

    If you're lucky, this will fix it. If this doesn't work for any reason, there are some other things you can do. We will take it one step at a time though. :) S
  3. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 1,835

    Thanks for the response. Fortunately, this drive is but a second storage drive and contains no operating system files. There are some files that will take some time to replace though so I'll be really bummed out if the drive is broken. I cannot see the drive letter in Disk Management :( The only place I can even see that the drive exists is in BIOS, which does little good. I have tried plugging the disk into another SATA port as well as swapping interface and power cables. Still nothing. The drive spins up but I can't hear much activity. I have also noticed that when the disk is being used in the system, Windows takes a long time to boot up, like 5+ mins. Once I remove the drive from the system, it starts up normally. I'm thinking the drive is just done for.
  4. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 1,835

    Still need help with this I'm afraid...

    I ran TestDisk 6.10, in DOS, which detected the drive and it appears that all of my data is in tact. I was able to browse through the directories and view my files using the program but it didn't detect any problems. The partition structure checked out ok, the boot sector was fine, and the backup boot sector was good. If there is any way I can copy the files over to another drive I would just reformat the disk but I don't think I have anything to allow me to do so. I'm not sure what to try now, but at least I know my data is still there.

    Here is a overview of what is going on:

    500GB SATA hard drive (E:\) is not recognized in Windows XP at all after hard reset
    -Not in My Computer
    -Not in Device Manager
    -Not in Disk Managment

    BIOS (system) detects the drive as "SATA1"
    -SATA controller is enabled

    DOS Program "TestDisk" v6 detects drive
    -Analyzed disk w/ no problems reported
    -Boot Sector is ok
    -Partition Structure is ok
    -Listed files/folders on the drive

    Thanks in advance for any further input.
  5. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 1,835

    Another Update...

    I ran Western Digital's diagnostics tool in DOS and testing the problem drive didn't come up with any errors whatsoever. So now, I'm thinking that possibly the SATA controller on my mobo could be fried or something because so far I haven't found anything wrong with the actual hard drive. I plan to run DLG tools in DOS just to see if the partitions are still visible.

    I'm waiting on another case to come in so I can rebuild my Linux box using my NF7 board. If I can get the drive to work on that system then I guess the problem lies on my new mobo somewhere. If I can just get my data off the disk I'll be set.
  6. seanc

    seanc TS Rookie Posts: 88

    You could try resetting the BIOS to optimized or failsafe defaults in case there's a small setting somewhere that's being overlooked.
  7. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 1,835

    One of the very first things I tired among a few other things. I even left the cmos battery out of its socket for 5 mins and then tried it... no luck. I've tried everything but I can't seem to get anything out of it. Hopefully my NF7 does the trick when I get it set up again but i dunno. I just don't understand why the disk scans clean with no errors and yet still doesn't work in Windows. Thanks for the input though.
  8. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Read up on installing SATA drives. You are missing something you need to know... that applies to some boards and some cable setups... and downloads that are available from the manufacturers web site.
  9. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 1,835

    I had the bloody thing working perfectly all up until that one restart so I kinda figured I had it set up correctly. I'll see what else I can find on their site, thanks. Anyways, I got some more diagnostics information that I've been doing some searching on. I ran Data Lifeguard Tools in DOS which displayed some strange information on the drive. It read the hard drive as a "BIOS drive (82 hex)" mounted on an "Unknown Controller." It also displayed no XBIOS logical or physical information, which is present for the other two IDE drives I have installed. Weird.
  10. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 1,835

    Gah, this sucks... I ran chkdisk just for kicks and I got "Volume appears to have one or more unrecoverable problems." That's great, just what I wanted to hear. I've never had ANY problems with hard drives before this; all of them were IDE. The first SATA drive I buy fries in less than a month of use... pos!! I'm just glad I didn't have any super-important data on there or I would be pretty mad/upset right now. Oh well, I guess I just need to make more backups next time :(
  11. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    I don't think anything 'fried'...

    It sounds like your problem is the partition is damaged. The other software didn't pick it up because it probably handles NTFS partitions differently than Windows does. I know I've had plenty of DOS and Linux apps that would read an NTFS partitions even though Windows itself wouldn't. But the hardware diagnostic you did is pretty definitive - the drive is good. And if you can pass a physical drive diagnostic, then your controller is probably fine too.

    Backups are important, but you may be able to fix this issue. There is software that makes it possible, such as Active@Partition Reovery. I've used it many times and it is well worth the $35 if you have important data. You can download a demo of the program that will show you your data to help make sure that it *will* fix your problem before you actually commit to buy it.

    But I'm sure your hard drive and controller are OK. It's a problem with the logical structure of your data. Unfortunately, I'm unaware of any free tools that make this easy to fix.

    If you do manage to restore your data, I'd recommend copy it over to another drive to back it up and repartition and format the drive you're having problems with at the moment. This will help ensure you don't have any other quirky problems later on with your file system.
  12. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 1,835

    One of the Western Digital tech support agents told me to run the extended test on the drive using their Data Lifeguard Diagnostics program (in DOS). I ran the program this morning and it performed a "Full Media Scan" on the drive returning the "000" code, which means the disk is error-free. So, you might be right. Nothing appears to be physically damaged, especially since the problem drive does mechanically function properly... well at least sounds like it does. I am definitely going to give Active@ a try though, looks like a nice piece of software to have handy. Since it comes with a bootable DOS CDROM ISO I would be crazy not to try it. Thanks again for your input and I will make sure to post up the results.
  13. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 1,835

    Alright I think I've narrowed down the problem to being a corrupted MBR but I don't really know what to do about it. Active Partition Recovery can only restore the MBR if there is a pre-created backup, which I don't have. I don't think it will fix or correct the existing one. I think I tried fixing the master boot record with "fixmbr" but I don't think it worked. Perhaps because the disk doesn't contain the operating system? I'm trying to figure out how to create a disk image with the data so that I can back it up to an external hdd.

    [EDIT]: I ran the recovery console again using my XP CD so that I could try fixmbr again. I completely removed my other two hard drives from the system so that I couldn't screw up and ran the command fixmbr \Device\HardDisk0 (SATA drive now primary). I got a message stating that the system appeared to have an incorrect master boot record etc... so I just said "yes" to recording a new one. The program displayed that the new mbr recording was successful so I exited the program and shut the system down. I put my two other disk drives in the system, turned it back on, configured BIOS and... TAH DAH... nothing changed. This is getting really frustrating.
  14. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 1,835

    Hate to bump this thread again but I've actually made some progress with this; it seems the drive itself is problem-free! :)

    Anyways, my el cheapo case finally came in so I dug my NF7 out of the closet and screwed together a new little Linux machine. After Ubuntu was installed I downloaded all of the available updates and made sure all of my hardware was working. Once that was all done, I powered down and attached my new SATA drive to one of the ports on the mobo; attached the appropriate power connector. When I turned the system back on, I went to Places --> Computer and a Volume C appeared in the window. Upon selecting the device/volume, a list of folders on the SATA drive appeared! I took a quick browse and it appeared everything was ok. Without hesitation I copied all my stuff to another drive and made sure everything transferred over alright.

    So now, it looks like the drive is 100% working on the Linux system on an Abit NF7-S 2.0 SATA-150 port. My Windows XP machine still cannot see the disk connected to a 300 port so now I'm wondering if I should try another mobo or reinstall SATA drivers. I'm also going to try my new SATA DVD burner on the Windows machine just to see if the ports do actually work fine. If the drive does work, I guess it's a driver issue. Any thoughts?

    [UPDATE]: LiteOn SATA DVD Burner works fine...
  15. CCT

    CCT TS Evangelist Posts: 2,653   +6

    It could be that your original comp has Sata controller issues that are driver related.

    Do an sfc /scannow, then re-install SP3 (if you had it) and then re-install the chipset drivers.
  16. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 1,835


    I was finally able to get the drive working again with Windows XP. I had swapped motherboards and had the same problem occur so I reinstalled the chipset drivers and now the drive is working! Hopefully I don't ever have to go through this again but at least I know it was a driver issue; how to fix it. I'm still trying to figure out what exactly went wrong but I'll probably never know. Anyways, thanks to everyone who helped out; I'm officially DONE bumping this damn thread :)

    -Now I can finally get back to gaming...
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...