Is my PSU the reason my floppy drive and F/P NEVER work?

By patrickc284
Sep 27, 2006
  1. Hi,

    My problem is this: The two small power cables from my PSU that connect to the floppy drive and my Audigy 2ZS Platinum front panel seem to be causing me problems.

    Neither my floppy drive, nor mu Audigy 2ZS Platinum, will work correctly. I have exhausted all options that I can think of in terms of checking my BIOS settings, drivers, and connections for power, PCI, and data. When I go to click on my A drive in Windows Explorer, it says, "please insert disk" even though a disk is inserted. When I try to open my Creative EAX Console it says, "Hardware not detected, the program will now exit."

    My problems with my floppy drive, and nowadays, my Audigy card and panel, all occurred after one day, while I was having problems with my floppy drive, I unwittingly connected the power to my floppy drive while my computer was on. Good one, right? No...

    After that, the floppy drive, and perhaps my audigy card/panel, have never worked correctly again. I have tried a new floppy drive, but not a new Audigy card (which would be horrible if I had to). I have audio, I use it all the time, but not the quality that I would if I could use my EAX console and other Creative programs.

    The rest of my computer and hardware all work fine. Did I fry just those connections to my PSU or is it something else? I CANNOT figure this out!

    My system specs are:

    XP Pro SP2
    AMD 64 3700+
    DFI Lan Party NF-4 Ultra-D
    2x 512 Corsair Value PC3200
    Thermaltake Venus
    2x Western Digital SATA 3.0 GB/s 80GB
    Samsung CD-RW/DVD
    Audigy 2 ZS Platinum
    Abit GeForce 6200
    Trendnet full duplex gigabit
    Aspire X-Plorer
  2. patrickc284

    patrickc284 TS Rookie Topic Starter Posts: 18

    I did some searching on the web with an error message I got after changing the floppy cable. "Floppy fail (40)" On one message board I found out this could mean that my cable was simply attached...upside down...

    So I guess my stupid mistakes live on! However, I still have to figure out my F/P problem. I guess I better check those cables too...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...