Issues with a Radeon 7000.

By feioncastor ยท 14 replies
Mar 8, 2006
  1. Okay, here's the story.

    I know a bit about computers, and obviously, not enough. You know, since I ended up here. A friend of mine wanted to play some Unreal Tournament, so he asked me to help him shop for a decent graphics card. I popped open his computer to see if he had an AGP slot, and he did not (w00t for Dell, amiright?).

    So I ordered him a ATI Radeon 7000. It came with a drivers disc, and the disc had a junkload of drivers on it, for a lot of different cards, like Nvidia and a few others. I clicked the file for WinXp drivers in the Radeon directory, and did the typical installation, involving clicking next a bunch of times. When prompted to restart, I said okay, and the comp shut down.

    By the way, all this time, the monitor was still plugged into the onboard video card.

    Well, the ATI Radeon 7000 has two monitor ports, for dual monitoring good stuff. But my friend had just one monitor, and has no desire to get a second.

    So I plugged the monitor into the graphics card upon restarting and the monitor did not respond until windows was done loading, and at the User screen.

    I went into Device Manager, and disabled the onboard video card, and things seemed to being going well.

    Then he tried to play a video. You'd get audio, but the video would simply stay at whatever was on the first frame of the video. I checked the Hardware acceleration, and dragged the slider down to the option that disabled Direct3D and Directdraw, and then videos would play, pretty normally, with a bit of lag, which is to be expected. No big deal.

    But to play games like UT2004, he had to adjust the slider thing for Hardware acceleration up to full.

    Interestingly enough, the monitor is still not responding until windows is fully loaded up and at the select-a-user screen.

    And this is the weirdest part. Now, when you adjust the Hardware acceleration slider thing, the computer stops responding when you click apply.

    One thing I noticed is that when windows starts up, a message appears saying the ATI control panel can't start because the drivers aren't installed, or they aren't current, or something to that effect.

    I've installed the drivers that came with the card about 20 times, and I don't know what else to do!!

    Please help if you can.
  2. feioncastor

    feioncastor TS Rookie Topic Starter


    I really could use some help here, if anyone has any ideas...
  3. paulla

    paulla TS Rookie Posts: 38

    I believe the latest ATI drivers (for XP) require that you have Microsoft .NET installed? However the Radeon 7000 is an old card and this probably doesn't apply so I'd try extracting the drivers to a folder then uninstalling the card in Device Manager then rebooting and using the manual "Point it at the drivers" routine rather than letting it automatically detect them. Make sure the MOBO chipset drivers are the latest versions before you try this as I've seen this cause problems before.
  4. feioncastor

    feioncastor TS Rookie Topic Starter

    I'm not sure which files are the drivers and which are just other stuff.... What extensions does a driver file usually have?
  5. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    The Catalyst Control Center bundle (which includes drivers) requires Microsoft .NET Framework. However, you can still just download the driver only. Click here. This is ATI's page. Look half way down the page to "Low Speed (Dial-up).

    On the other hand why not just install .NET Framework?
  6. feioncastor

    feioncastor TS Rookie Topic Starter

    Well, I did this:

    uninstalled the drivers I was using
    disabled the onboard video card (in setup)
    let windows start up
    installed .Net framework
    installed the newest Radeon drivers

    And videos still freeze on the first frame when DDraw and Direct3D are enabled. Anyone have any ideas?
  7. feioncastor

    feioncastor TS Rookie Topic Starter

    Oh, and I tried something.

    Videos seem to run fine when using Real Player, but not when using WMP. To me, this would be no problem since I don't really like WMP at all. I usually use VLC or Zoomplayer or one of those.

    But my friend really likes WMP... Any ideas?
  8. jhartwick

    jhartwick TS Rookie

    one thing to check with the Catalyst Control centre is to make sure that your monitor is set to be the primary display ... i had a few problems when i first started to use my Radeon 7000, even without a TV on it, it still sets a TV to be the primary display sometimes, and WMP seems to be the most compatable with ATI as far as only allowing videos to show on one display, and not cloning the second one properly ... i still have to switch primary display back and forth when trying to watch a movie from my TV
  9. feioncastor

    feioncastor TS Rookie Topic Starter

    Seriously, if anyone can help me, I'd ultra-super-mega appreciate it.
  10. feioncastor

    feioncastor TS Rookie Topic Starter


    Only because I really would like some advice as to a resolution to my problem.... I don't like to bump dead threads, but this thread isn't dead as the problem still persists, after having taken all the advice already offered as best I can.
  11. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    When uninstalling the old graphics driver, did you use Add/Remove Programs? You don't use Device Manager for this. Go to the ATI website for the latest graphics card driver.
  12. paulla

    paulla TS Rookie Posts: 38

    I'd try a repair install of your OS (XP I'm guessing) saving critical data first obviously just in case, as this should correct any conflicts you seem to be suffering from.
  13. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,443   +38

    Try getting ur friend to use the K-Lite Mega Codec Pack and the Media Player that comes with it. Its pretty easy to use(looks just like vintage WMP) and plays almost any video fine. Other than that, I have no idea.
  14. feioncastor

    feioncastor TS Rookie Topic Starter

    It's an onboard video card (the old one), so I can't uninstall it. I just disabled it in windows and in BIOS
  15. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    I was talking about the driver not the hardware itself.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...