1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Keyboard and touchpad freeze during Win OS installation

By godra986 ยท 4 replies
Oct 23, 2008
  1. Hi everyone!

    I have a problem with my laptop, obviously.
    I have an Acer Aspire 5672WLMi. Been working fine so far, sort of.
    I bought it in summer, 2006. It came with 120GB hdd, of wich 4GB is win xp bootable recovery partition, which I never removed because I used it every time and it worked excelent.
    In summer 2007 came the first problem, my web cam stoped working, but I was fine with it and decided to wait a bit more with the warranty because I have a 3yr warranty.
    This summer (2008), my cd burner stoped doing it's job as it used to. It burns DVD's and sometimes better quality CD-s. I realize it's getting older, so ok, I get over that as well.
    Five days ago I get into a little bigger problem. Whatever OS that I install it is not working as it should.
    If I try to install win xp from cd next thing happens:
    it goes trought the proces as always but comes to the "instaling devices" point and then my touch-pad and keyboard freezes but the proces goes on. Final result is that I cant enter the win xp serial number. Even my power button stops working so I must force shutdown it by unplugging the cabel and removing the batery.

    When I try to install from bootable partition:
    It goes trought the first phase of moving files to C and copying or whatever but when it restarts it does not recognize the win xp instalation so it does not contuinue whit it. Interesting thing is that once I even managed to go all the way to the "enter user name" point but, you guessed it, my keyboard is frozen and I cant enter "at least one user name".

    When I install ubuntu 6.06 from cd:
    instalation goes excelent, keyboard works as well as touch-pad. The problem is that ubuntu is not working as before. Sometimes freezes completly, or it does not recognize usb stick. BUT, I repeat, keyboard and touchpad work just fine.

    When I try to install Vista from DVD:
    Instalation goes fine, sort of. On some point my keyboard and t.pad stop working, but one good thing about Vista, at least in my case :), is that it doesnt require you to enter serial key, or if you want you can do it with on-screen keyboard. So, I go al the way trought installation and log on to vista. First 2 seconds my touch pad works and then it's off. Interesting thing is, that touch pad, as well as keyboard work, BUT: If I want to write a letter I have to press verry hard and wait few seconds, t.pad - I move it by finger but you can see the reaction after a minute. The thing is that I continued to receive this messages about one of my USB hub not working, which I received formerly in working installation of win xp.

    Things that happened beffore this:
    I had a dual boot:
    Win xp home - installed from my recovery partition, working fine with all drivers except web cam. Few months back I started receiving messages that one of my USB hubs is not working correctly and that it cannot recognize device. So it keeps poping up all the time. (I keep it up and move it to the side so it stops buggin me). I didnt think that could be a bigger proble and still dont because everything functioned. Then I installed NOD32, 3.something ver, probably infected, because I downloaded it from some torrent and from that point on my laptop is not as it was before. I rebooted once and it worked ok. But few hours later when I rebooted again it didnt want to log on to win xp, so I decided to reinstall windows... but since then I didnt manage to do that.
    ubuntu 6.06 LTS - worked excelent before this, USB recognition... everything, LAN, internet... never froze.

    BTW, in all installations my external usb mouse works fine.

    This is the first time this has happened to me. I tried all combinations, deleting and formating all partitions except the recovery partition, instaling xp then Vista, instaling Vista then XP, then unix, all the combinations, several times. NOT working. I dont know what to suspect because keyboard and t.pad is working in linux but not in any of Windows. Dust, south bridge, connections somewhere somehow...

    please do post if u have any "smart" ideas or helpfull info. I apologize for the huge post, I tought it's better to write everything that may matter.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 13,810

    Well it's still under warranty (I think)

    Anyway Ubuntu works perfectly
    Windows does not

    Is that the general drift ?

    Have you confirmed all your driers are up to date?

    Hae you tried the Acer Disk Formatter ?
  3. godra986

    godra986 TS Rookie Topic Starter

    Im thinking...
    why would drivers be the problem, because they worked so far, and suddenly they dont. So my conclusion is that problem is probably not connected to drivers. And even if it is, I could install only those for Vista because I cant get into the XP.
    Ubuntu worked perfectly, now it's unpredictable. Keyboard and t.pad work perfectly but Ubuntu OS tends to freeze completly, often. Sometimes it doesnt recognize usb stick when I plug it in... some aplications freeze.
    If Ubuntu worked fine I would still be forced to dual boot with Win OS because a lot of my work is connected with Windows.
    Today I tried installing Vista again. Installation went to the end. KB ant TP dont function, wireless also (wireless worked in my previous installation of Vista). mind boggling.

    I'll try Acer Disk Formater when I... when I calm down :).
    It is under warranty but I might have lost it. :) Still looking for it.

  4. godra986

    godra986 TS Rookie Topic Starter

    solved the problem. thx for all the help ;)
    it was the battery all the time. It was too weak and I had to remove it so windows instalation could recognize my keyboard and touchpad. dont know the bottom of the problem but this solved it.
  5. almcneil

    almcneil TS Guru Posts: 1,236

    No, the problem was the BIOS settings were messed up and the drivers for the CD/DVD drive could not be located. I used to be a high tech engineer and I developed device drivers.

    It was the BIOS settings in CMOS getting messed up from a weak battery. BIOS couldn't find the driver.

    -- Andy
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...