LAN Network Question

Hi there Tech Forum, thanks in advance for your help.-
I have a question about a LAN and stuff. There is a modem and a wireless router with 4 LAN ports. In one of them there is conected also a switch with 8 LAN ports.-
Some weird things have been going on. I always get a wireless connection, so, no problem there. Issues appear with the wired network. On one hand, I had many times an 'unidentified network', a 169.x.x.x ip and no network. Nothing changed in configuration on my box or the router, and got to connect at 1MB/s, while if connected through wi fi I got more than 4MB/s. From a moment on, again unidentified network and no signal, in the adapter a yellow light would blink quick. So, now, after touching the cable and a little bit of despair, not driven to the computer by the way, I have a full conection by lan and by wi fi, both at a good speed. AND, weird for me, a green light on and the same yellow blinking.-
So, main questions are:
1.- What does the green light ON, not blinking means?
2.- Could there be a difference due to the cable manipulation?
3.- Is there a gost inside my router? =D

Thanks a bunch to all of you, I try my best to understand computers, so now I am happy with the connection, but curious on the rest.-

Regards!
 

St1ckM4n

Posts: 2,887   +628
How new are these devices? Are you using new 'patch' cables? Is DHCP running on only one of the devices? Seems weird that "touching the cable" caused a change.

1. The LEDs differ, but usually one signifies a connection [on/off] and the second signifies activity [blinking]
 
Hi there, thanks for your reply!
They are not too old, but am not sure though. The cable is a long one, about 20mts. The DHCP is running on the router, I have set an static IP for the desktop machine, to try out what happend. Same thing in both configurations(ip via DHCP or static).-
Yes it is weird, endeed. 'Touching the cable' is unplugging it from lan card, moving the rj45 connector, plugging it again. That's what's more confussing =S Guess there might have been a disconected wire or something, for it is working really smooth so far =P
1. Great, seems legit for this device. I tried the realtek site but could not find a manual for the integrated lan which, by the way, is a 10/100/1000 PCI e card.-

Thanks again for your concern. Do you have a reading recomendation on this subject?

(y)
 
Great St1ckM4n, thanks endeed.-
A sure thing is that it is working better now, with green on an yellow blinking than just yellos blinking.-
Useful links also, regards!
 
I guess it was, for it's working at its best now. But since I have never seen the green light before, you know how panic is, the first thing many people think is 'I screwed it'. I kinda gently twisted the cable. It must have said 'OK, I'll work!' :D
Thanks for your aswer Clifford!
 

Darth Shiv

Posts: 2,242   +810
On one hand, I had many times an 'unidentified network', a 169.x.x.x ip and no network.
Sounds like the issue is sorted but I just wanted to throw some ramblings/experience I've had with diagnosing 169.x.x.x IP addresses.

If that happens (you get some random 169.x.x.x IP), you are trying to connect to the DHCP server and for some reason the negotiation fails. The network adapter thinks/knows it is connected to a network but couldn't get an IP so your computer just gives up and picks a random 169.x.x.x address.

When I see that, the things I think of are:
  1. Bad connection (e.g. bad cable or not plugged in somewhere properly)
  2. DHCP server down/flakey/not present
With the "Bad connection" scenario, it could be any hop to the DHCP server. That means the 8 port switch could be flakey too. The other thing to look out for is multiple DHCP servers.
 
Hi there Darth Shiv, thanks for your concern.-
Kinda, not really 'solved' It was working great, but had to disconect all devices, and now again is the thing. Seems you're right on that cable stuff, for it worked great as long as it wanted, then turned off the box and today it's ruined. Tried another cable and works fine, also the same lights config(green_on; yellos_blinks).-
By the way, it has always taken its time to give an IP and a connections, Could it be the router DHCP? There is just one router, one switch which is not configurable.-
Be good!
 

Darth Shiv

Posts: 2,242   +810
By the way, it has always taken its time to give an IP and a connections, Could it be the router DHCP?
Yes I've found plenty of routers are flakey on DHCP. If it is old, it could be just worn (heat tends to be an enemy of those things over time). Particularly if you use P2P traffic.

If it is a cheaper router that would also raise an eyebrow but even expensive home routers aren't bulletproof. Had lots of trouble with both wrt reliability tbh.