Lan problems

By rhodias ยท 18 replies
Sep 14, 2008
  1. I have a Vista SP1 laptop hooked up to an XP SP3 desktop. Two computers are connected via lan. Workgroup is the same. I've allowed file sharing for Vista, but when I go into my network places and attempt to access the folders that are visible, it states that I do not have permission to use this resource network. Unsure how to correct this.

    Thanks is advance.
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    A few things

    First, it sounds like you've addressed the networking side of file sharing OK as you don't mention any problem with the computers seeing each other right?

    So, access issues are either due to
    • An authentication problem. User making the request doesn't have server logon rights and/or they aren't providing valid logon credentials
    • Resource permissions problem. The request gets authenticated but its permissions aren't sufficient for access to the resource

    So, sounds like the problem is XP accessing resources on Vista? Question is: What TYPE of file sharing did you enable on Vista? Is it Password protected file sharing? Or did you disable Vista Password Protected Sharing in the Network Center? (because the authentication methods aren't the same for each type)

    If it's password protected sharing, make sure identical user accounts (same userid and EXACT same password) exist on both machine. (i.e. for whatever userid you logged in on XP when you tried accessing Vista)

    If NOT password protected, make certain the Guest account is enabled and matches on both XP and Vista computers.
  3. rhodias

    rhodias TS Rookie Topic Starter

    You're correct, using the XP to access files on Vista. Password protected sharing is turned off. I don't have guest accounts on either PC, just 1 primary account. you're saying I should enable them?

    I'm strangely able to access the "public" vista folder, so I've started to copy files into that folder and it's worked to transfer over... however the speed of transfer is extremely slow (nearly an hour to transfer 600MB worth of data). Any thoughts?
  4. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    Yes; set a trivial password for the Guest Account and then Disable it (it only stops keyboard logins
    but is used for simple filesharing).
    make sure the target Shares ar NOT encrypted
  5. rhodias

    rhodias TS Rookie Topic Starter

    Guest accounts are created. The shares are not encrypted.

    I've discovered that while I am able to view the shared folders on the other computer (but not access them) there still appears to be a connection problem. #1, XP reads limited or no connect, Vista reads Unidentified Network. Both computers recieve ping response, however when pinging Vista from XP I recieve very slow responses.

  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    What firewall product are you using on Vista computer? and what on XP?
    Unplug your ISP cable so disconnected from Internet, then turn off both firewalls. Reboot both and test again to see if a firewall issue

    Make sure Guest accounts a) are enabled b) do NOT have a password (assign one later if you want after it all works) and c) has network logon rights on server
    => On both XP and Vista, from a command prompt on XP and Vista enter:
    net user guest /active:yes
    control userpasswords2
    then select Guest account, hit Reset Password and hit Enter for no password.

    => On server (Vista) only, setup logon rights. You can use policy editor if your version Vista supports it. Or use ntrights tool to grant or revoke logon rights. ntrights works on all XP and Vista versions.Download Win2003 Resource Kit.. You can copy/paste each of the 4 commands to a Vista command prompt (note commands are case sensitive)
    ntrights +r SeNetworkLogonRight -u Guest
    ntrights +r SeNetworkLogonRight -u Everyone
    ntrights -r SeDenyNetworkLogonRight -u Guest
    ntrights -r SeDenyNetworkLogonRight -u Everyone

    Use Windows Event Logs to check the remote logon id from XP
    If using Vista home, logon audits are already set by default. For other Vista versions, see this link and set policy to audit logon events. At the end, you;ll find info on how to view the posted events. Check to see what userid XP is sending each time and see if Audit Succeeds or fails (i.e.logon attempt work or not)

    /************ EDIT ****************/
    OOOPS! You needn't do the last step with Windows Event Logs (but is handy to know the ability is there!). Since you have Password Protected Sharing off it doesn't matter what id XP is sending. Vista authenticates all requests as Guest. BUT do double check that there isn't any Guest password on either computer/.
  7. rhodias

    rhodias TS Rookie Topic Starter

    When attempting the ntrights function I recieve error message " ***Error*** OpenPolicy -1073741790 "

    This occured with all 4 functions
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1. Which version of Vista do you have? (Control Panel->System to check and see)
    2. Did you run ntrights from an elevated command prompt as administrator? Or you can change its file properties so it always runs as administrator. Find it in C:\Program Files\Windows Resource Kits\Tools, Rt click Properties->Compatibility and check Run this program as administrator. Hit OK
    3. Something else comes to mind. Still do the ntrights thing and then try again. Think it will still fail and there may also be an issue with Vista by default not including Guest as a user or in any Group with folder access permissions
    4. Go to the folder you are sharing. Rt click on it. Properties->Security->Advanced. On Permissions tab hit Edit->Add->Advanced->Find Now. Scroll to and select Guest (not Guests!). Hit OK->OK. Check boxes to allow the permissions you want. Then OK till you get back to Permissions display and see that Guest is listed and has permission.

    What a pain, huh?!

    Actually, how many userid need to actually file share resources on the Vista computer? You might just want run with Vista's Password Protection turned ON and for each user who wants to access Vista shared folders, create a per user IDENTICAL login account on Vista to match their account on the remote computer they log into. Then their Vista user account permissions are applied for each share and you don't need add Guest permissions to all current (or future) shared folders. Up to you.

    Going to bed shortly. Hope you have good news at next report!
  9. rhodias

    rhodias TS Rookie Topic Starter

    I'm running Vista Home Premium SP1, 32 bit OS. I went into the command prompt as an administrator from my primary account, by executing cmd.exe.

    It fails whether I attempt for "guest" or "everyone". When attempting part 4, after giving access, I go to click the final ok button to close the Advanced Security Settings for the folder and I'm given "An error occurred while applying security settings... access is denied". I had attempted a similar thing early on before coming on here with the same result (although the first time I was attempting to apply that to everyone, not just the guest).

    Additionally for part 2, I am unable to set the command prompt to Run this program as administrator for reason of "it is part of this version of windows"

    All I'm looking to do is allow access to a number of documents and necessary files (some of which are fairly large) that I want to back-up on my xp desktop computer so that I can format my vista laptop. My burner died on it (for what reason I'm still attempting to discern as it still reads perfectly fine, simply goes through the burn process and nothing actually gets written. I believe it may be viral related, but multiple virus scan programs have turned up empty, part of the reason why I wish to format). So basically I'm looking to transfer the files over to the desktop, but it's currently taking about an hour per gig at the quickest for it to transfer (generally closer to 500mb per hour)... and I'm lost as to how to correct it. Getting close to just buying an external hard drive to get this done and over with :p.

    If you have any more ideas... please share, otherwise I think I may just go out and buy the external hard drive later this week.

    Thanks soooo much for all your help thus far. It's greatly appreciated!!!

    And yes... definate pain in the rear...
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I want to be sure we're covering the basics...
    => Does your Vista user account have Administrator rights? (Control Panel->User Accounts. Does it list Administrator or Standard User under your ID?)
    => Isn't clear but are you opening an elevated command prompt? See this link.

    Did you try changing Properties of file cmd.exe? or ntrights.exe? (The message described would occur for cmd.exe) Try going to the ntrights folder (in my post), and rt click on ntrights.exe
  11. rhodias

    rhodias TS Rookie Topic Starter

    Yes, the account I was using was the admin account. However I'm still not able to check any boxes in properties. Good news is on the page from simply right clicking on command prompt there is a line to run as admin, so I did that and was able to successfully run the commands. Bad news however is that my computer is apparently no longer recognizing that I have a network cable plugged in and have lost all access to that comp. Going to reboot both comps and see where it goes from there...
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Yes! That is good news.

    And while setting logon rights is a good thing am guessing access will still fail due to resource permissions. Though now I wonder why you had "Access denied" when you tried changing permissions on the folder. What is the folder you are trying to change permissions on?
  13. rhodias

    rhodias TS Rookie Topic Starter

    Still having the same problem after the reboot. I'll have connection for maybe 2-3 minutes, then it's lost and won't return. This has happened with every subsequent reboot (whether I repeat the ntrights commands or not).

    The folder I was attempting to change permissions on is the "public" folder where I had copied a number of files that I was looking to transfer. The public folder is the only one which I had been able to access up until this point, so I was moving anything I wanted transfered into that folder so I could start the process. Now the connection is down completely.
  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    OK. Could you do the following
    1. Use Everest Home Edition to post the specs of each computer
      Download from here to XP and Vista computers. Run it on each computer
      - Click Reports->Report Wizard
      - Get a Custom report. Check: Computer, Motherboard, Network. Output in simple text format
      - Attach the output of each report to your post using the paper clip icon (in TechSpot Advanced Reply)
    2. I assume the connection problem you report is on the Vista computer?
    3. When you say "losing the connection" does the computer report it as cable unplugged or Disabled? Or are you saying you just no longer get communications - even tho computer still says its connected?
    4. What firewall and anti-virus product are you using on each computer?
  15. rhodias

    rhodias TS Rookie Topic Starter

    Vista - second message with XP report soon attached. Will answer other questions in second posting.


    Connection problems is with Vista. I'll go into network places, attempt to transfer a file and then it cuts out. Vista reports that the network cable is unplugged. XP still states limited or no connectivity. And at that point I am no longer able to enter any files on the Vista comp from XP... problem occurs as early with access not allowed etc.

    I have AVG free running on each computer currently. The Vista comp also has MalwareBytes as I was trying to discover a virus that might have disable the burner somehow, but both scans have come up clean, as well as trendmicro online scan.

    Firewall on Vista is zonealarm, but it is turned off, and the windows vista firewall is also disabled. No current firewall on XP, windows XP firewall has been disabled.
  16. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    OK. Tho may not have time to look at it for awhile. But quick comment as i see both a LAN and wireless adapter on Vista. Could you set the Wireless adapters (for both computers if XP also has wireless) to Disabled so we know we're just dealing with a cable issue on each (and not wireless connectivity)

    You can also give this link a shot on Vista.

    If nothing else, have you tried the suggestion (prior post) of disconnecting from Internet and turning off both firewalls? btw.. if you are NOT using Windows firewall on Vista is a reasonable chance 3rd party firewall needs some adjusting for Vista.

    Check in on you later.
  17. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    This symptom is COMMON when you allow BOTH the wired and wireless adaptors to
    be active at the same time.
    DISABLE the adaptor you are not using and the problem goes away :)

    Apparently you you would prefer the wired connection
    (else you wouldn't have used the wireless and complained about the issue with the wired).

    On my laptop, at home I use the wired ethernet, but when traveling I use the wireless.
    The Toshiba ConfigFree software makes it trivial to disable the adaptor not in use,
    but if necessary, you can use the Device Manager to control the devices.

    Once the WiFi is disabled, you only need to set the wired adaptor to use DHCP for
    both the IP and DNS settings, save and the system will connect in about 20 seconds.
    Using ipconfig /all should show an IP address OTHER THAN 169.254.x.x
    (likely to be the used previously by the wireless).

    If ping returns timing info, you're good to go.
  18. rhodias

    rhodias TS Rookie Topic Starter

    Lookin around - Have tried with wireless disabled. Does not correct the problem. Attempted options in that link... again, no correction. All firewalls are disabled. Still coming up empty.

    Jo - as stated, even with wireless disable, does not correct the problem. I had tried setting up a wireless connection between the two comps, then switched to wired because I wasn't getting anywhere and assumed wired would be more simple. I generally connect to the internet via wireless connection from each computer that I'm using at that point in time. Even with DHCP enabled, still having all the problems. Additionally I'm not recieving an IP address from my wired ethernet when running ipconfig.

    Just figured I would let you know I gave up. Went out and bought an external USB HD. Found a deal for a terrabyte drive for 170$... Just going to back up my files on there and get this process done and over with.

    Thanks all for your help!!
  19. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    this is your primary problem; must be a bad driver (Vista requires SIGNED drivers),
    bad cable, or bad port on the router.

    Failure to connect can be several issues, but failure to get an IP address is not
    dependent upon ver much at all :(
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...