Tech Stocking Stuffers: 18 awesome gifts under $50

Laptop Boot Problem: Evesham Explorer 2007

By Indifferent ยท 6 replies
Dec 16, 2007
  1. Hi there.

    I purchased my first ever laptop, it is a Evesham Explorer 2007 a few days ago. It came on Friday. Now it Sunday, and its not working. As you may expect I'm am slightly annoyed.

    Here is the problem I am having:

    I pressed Ctrl-Alt-Delete, to end a program task. I ended it, but it started making a weird noise, I was like wtf is going on... :dead: Kept making a noise and a red light (i think it was something to do with the battery) kept flashing, and still making an annoying beep sound. So I shut it down.

    Now... I cant start it up. :roll: The red light still flickers, and it loaded up just past the boot screen. Then shuts down automatically. By this point I'm freaking out. :evil: Sooo, I try boot it again, same thing, this time no sound. Weird.

    So I boot it without having it plugged in to a socket, just from the battery, same thing. I try clean near the fan and stuff, same thing. I try take the battery out, put it back in, same thing. I take the battery out and run it from the mains ... same thing. I put the battery back in, same thing. Just a while ago, I tried again, now it wont even boot up.

    Can anyone help me? I don't know what to do now.

    I have read a few bad things about the company and there products which I just found today after doing a Google search, I would never have brought it if I knew this before hand.

  2. Rik

    Rik Banned Posts: 3,814

    The only thing you can really do is take it back and demand it be fixed.
  3. Indifferent

    Indifferent TS Rookie Topic Starter

    The thing is when I got it I was really excited, so after I checked everything was okay and it worked, I threw the packaging stuff away. [/blonde-moment] lol

    Another thing was that I got it from and it was the cheapest laptop that had the features that I wanted and I could not spend much, this one was already expensive for me because I'm working part-time, but was still the cheapest with all the features at 220 pounds so thats why I got it. And I doubt that they will take it back now.

    I think I may just have to deal with it and mark it down as experience.

    Ah well, these things happen I guess. Don't think I will be getting one for a very long time now.

    It's just annoying me that it happened so fast, I didn't even have it for that long. [sigh]

  4. Rik

    Rik Banned Posts: 3,814

    As long as you have proof of purchase then you shouldn't have a problem.
  5. Indifferent

    Indifferent TS Rookie Topic Starter

    I'll try, and see what happens. :)
  6. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    bios beeps are indicative of hardware failure. REturn to the store or get an RMA from the manufactuer. You should have warranty coverage for at least 90 days. If you bought with a credit card, perhaps longer.

    Also post in the correct forum next time - mobile computing.
  7. cmdavies2003

    cmdavies2003 TS Rookie

    Try to re install the os if you still have the disk.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...