Lenovo G510: Harddrive caddy not recognised

By SlothNation
Oct 9, 2016
Post New Reply
  1. Holla Amigos!

    Long time reader, first time poster... You know how it is!
    I'm totally desperate...

    I tried everything I can think of, yet my Caddy is still going crazy.


    Lenovo G510

    Windows 7

    i7 4700MQ

    8GB Ram

    AMD Radeon Graphics HD8750 M

    1 TB SSHD

    250 GB Samsung EVO SSD (currently in the caddy)

    (the original build: https://www.amazon.de/gp/product/B00FQLVHK0/ref=oh_aui_...)

    Basically, the Laptop will no longer detect the SSD (or HDD, doesn't make a difference) placed
    in the caddy anymore. It never worked 100%, but for a long period of time it worked atleast most
    of the time. Every 5th boot or so, it wouldn't get recognised - which is why I never put the OS
    on the SSD, since it was to unreliable. Instead, I put my audio software, plugins and video caches
    onto the SSD (I know, that's not really the point... But I feel like it made some difference).
    For a few weeks now, no harddrive in the caddy whatsoever is recognised at all. Not in the Bios,
    not in the device manager and not in Windows' harddrive manager. This was more of a gradual
    thing, I got a bunch of blue screens durring the boot process (usually at the Windows 7 loading bar).

    Occasionally, it will show up in the boot menu - but as soon as I actually boot, it will once again be undetectable.

    The CD drive works just fine when I put it back in, so it can't be the SATA port.

    I tried three different Caddys, so that can't be the problem either- unless the G510 needs a VERY SPECIAL caddy!

    I tried two of these: https://www.amazon.de/gp/product/B0088WOALW/ref=oh_aui_...

    And one of these: https://www.amazon.de/dp/B012A9HOES/ref=twister_B01EAAX...

    The only one I found that's specifically made for the G510 is this one, would that be worth a try?

    I can't find a difference, except for it's higher price...


    As I've mentioned, it also doesn't make a difference what harddrive is in the caddy; same problem.

    So it's not the SATA connection, it's not the drive, it's (probably) not the caddy... The BIOS is up to date, the CD drive is still recognised. I tried attaching thin layers of paper to the caddy, to slightly push the connections together; no success.

    Is the CD drive's SATA connection on the G510 unable to handle other drives than the CD drive?

    If I can find a permanent solution for this, I will put the OS on the SSD. Been wanting to do this for almost two years.

    I really hope someone here can help me, I'm going insane.

    Cheers, Jonas
  2. Mama mia

    Mama mia TS Rookie

    Same problem here. No solution though.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...