Spread the love! TechSpot Tech Gift Shortlist 2017

LiteOn SOHW 1633S DVD won't read DVD

By Natotiger ยท 9 replies
Aug 1, 2005
  1. Hello. first time post. looks like cool site.
    Help. My LiteOn SOHW 1633S DVD drive will not read DVD's. It does not seem to work with the MSI software that came with it. I can get it to show the files that are on the Seinfeld DVD I'm trying to view if I click on my DVD drive icon (after a minute or two), but it will not run the DVD, or I do not know how to get it to run. I tried to flash the drive with the firmware/driver from this site, but got the message "Cannot flash the firmware. Please contact vendor". I am assuming that the flash runs in Windows, not DOS. I have had the drive for a while & just never dealt with it.....I guess it's time to try.....help.
  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    what operating system and service pack are you using?
  3. Natotiger

    Natotiger TS Rookie Topic Starter

    WinXP, Service pack 2
  4. Natotiger

    Natotiger TS Rookie Topic Starter

    I think I'm just going to throw away this drive and buy another, brand-name one. Like Pioneer, or IBM, or TDK....or something like that. It's not worth the agony of not getting this one to work.
  5. zephead

    zephead TechSpot Paladin Posts: 1,569

    sounds like a likely fix
  6. etones

    etones TS Rookie Posts: 146

    i had a similar problem with a dvd drive, my problem was down to the dvd region set to the wrong one, apperantly
  7. johkneeb

    johkneeb TS Rookie

    Try This

    Hi, I had the same problem.

    I have a Liteon SHW 1635s. It wouldn't read DVDs it had just burned, never mind others! The firmware upgrade would fail on 5% saying contact vendor etc.

    I also have a mitsumi Cd writer which worked fine, but seems to be the cause of the Liteon problem. As soon as I disconnected the mitsumi, the Liteon started reading DVDs, and flashed to the latest firmware in 1 go. I haven't tried putting the mitsumi back on to see if the liteon upgrade gets round this, perhaps making it master (it was a slave before) , or changing the cable position - but at least the drive seems to be ok now, so maybe I won't bother!
  8. zephead

    zephead TechSpot Paladin Posts: 1,569

    as long as it works.... ;)
  9. Ropa

    Ropa TS Rookie

    Here's A possible Solution That worked for me!!!

    I was having the exact same problem that you were having. I visited this site and several others and tried everything that was recommended. I eventually had the Lite-on SHW 1635s returned and the dealer replaced it for me. But it still wouldn't work. Therefore I suspected that the problem was with the instalation.
    I had HDD as master on primary and a Hitachi DVD-rom as Slave on secondary with the Lite-on as Master on secondary. I temporarily disconnected the Hitachi DVD-rom and to my surprise the Lite-on worked Fine. When I replace the Hitachi same problem started all over again. I figured that the mobo was confusing the two drives on the same IDE cable because region settings for the Hitachi showed up when I clicked on Liteon properties. So I changed the configuration: HDD as Master on Primary, Hitachi as Slave on Primary and Lite-on as master on Secondary. Now everything works Just fine. I Don't know if this exact same sollution will work for you but try experimenting with various IDE configurations. You never know one may work...Cheers
  10. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,377

    I was using that drive for my computer builds and every one has failed, including the one in my personal system. All with the same problem, will read CDs but not DVDs. I havent found a fix.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...