Loss of USB drivers

Mar 14, 2008
  1. I connected a iPod shuffle via USB port, and now none of my USB ports function. My mother board is a Gigabyte GA-N650SLI-DS4, Rev 1.0, Award BIOS v6.00PG. I do not have mobo software, and am not able to locate drivers on Gigabyte site. I have attempted un-install, but to no avail. Any idea's out there?
  2. Whiffen

    Whiffen TS Rookie Posts: 235


    Their isn't a USB 2.0 driver their but if you still wanted to find the drivers for your motherboard thats where they are. So were the USB ports were working before you tried the iPod, and have you tried any other USB device to see if it works? Also be sure the check "My computer" and make sure its not showing up when its plugged in.
    If it just stopped working it might also just be the motherboard ;(
  3. PCTechII

    PCTechII TS Rookie Topic Starter

    Thank you, and attempted given link to no success. Gigabyte said the USB chip is bad and they are going to RMA me another one. Appreciate your input.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...