Mixed Ethernet and WiFi

By Captainsguard ยท 5 replies
Nov 26, 2006
  1. I have just set up a Wifi network to use my laptop when at Home,my Main PC is Ethernet connected to the Router/modem/WiFi.
    How easy is it to make them share and be on the same network?
  2. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    The type of connection (wifi or wired) doesn't make any difference. So as long as you can get them both on the network (or online usually, since that's what most people aim for) then its just the same as setting up two wired computers.

    Here's a random guide on XP file sharing:

    It should be very simple, but complications can arise. If they do, let us know. :)
  3. Captainsguard

    Captainsguard TS Rookie Topic Starter


    Thanks Rick
    I retired from networking some 10 years ago and am trying to upgrade my knowledge and set up a home network with NAS and Mulimedia but am a bit rusty.
    Can I use the networking wizard and set up my network addressing all the PC similarly?
  4. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    The networking wizard basically sets up your workgroup (The 'group' your computers will be accessible in), host name (alpha-numeric network name to access your computer regardless of IP address) and turns your file/printer sharing off/on. It doesn't really help you setup IP addresses though.

    I'm going to ramble a bit and some of it may not make much sense to you since you aren't familiar with NAS or wireless, so don't be afraid to ask questions, if you have any. Here's a good resource for a wide variety of networking tips & solutions: www.practicallynetworked.com

    The good news is, your average home router has a built-in DHCP server, so addresses are assigned automatically. Just plug in your computers and NAS and you're good to go without even ever using the network wizard. The only reason you'll want to use the network wizard is to set up your computer's network name and to put your computers in the same workgroup.

    Because DHCP can give somewhat random IP addresses, you may find it difficult to locate your NAS box via IP directly. However, NAS shares files using different file sharing protocols such as Windows' SMB, which means you don't really have to know the IP address... It should show up in My Network Places without ever really know its IP.

    You NAS box should have come with a manual and possibly a utility to set it up. If so, this might be the easiest way for you. If it didn't come with a setup disc, you can usually set it up via the web config interface that many of them come with. To use the web config, just type the IP address of your NAS into any Internet browser like Internet Explorer and a configuration page should appear. The difficult thing may be that you don't know what the IP is of your NAS, but the manual that comes with it should have that information. Once you get into the config, change the IP address so it is on the same subnet and is within the scope of your router's IP range

    A possible problem is your router assigns IP addresses through a certain range like -, but your NAS might be setup with a static IP of You may need to manually change your IP address (ie. and subnet (ie. to access your NAS if this is the case, as you need to be on the 'same network' to access the configuration page... and blah blah blah blah.

    Just throwing out some extra info to better prepare you. Feel free to ask anything as there are plenty of helpful people here. :)
  5. Captainsguard

    Captainsguard TS Rookie Topic Starter

    Thanks Rick
    Most of your rambling makes sense but my adsl modem in my router has just gone on the blink so I'll change it to a Belkin
  6. Captainsguard

    Captainsguard TS Rookie Topic Starter

    Back up and running wifi wise adsl modem must have got blasted.back to setting up network.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...