Spread the love! TechSpot Tech Gift Shortlist 2017

Mixing HDD, RH 7.2 / WinXP

By Justin ยท 8 replies
May 5, 2002
  1. OK.

    Here's the situation.

    HDD 1 is a WinXP HDD

    HDD2 is a redhat 7.2 HDD

    Currently, you have HDD2 as the only HDD on the system, as primary master, linux is the only OS. Now, I want to make HDD1 as the primary master and dual-boot that way. I can already boot into XP, but what do I have to change to be able to boot into linux as well? I read through the dual boot guide but that was kinda not what I was looking for, since it is assuming you already have an OS installed and are doing a fresh install; in this case both OS's were installed seperately at seperate times.

    Again, originally HDD2 was primary master, now it is primary slave, and HDD1 is primary master with WinXP.

    I was told it was quite easy, how would I go about doing this? Thanks a lot.
  2. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Set your computer to boot from primary slave disk, then:

    Boot to Linux. Type df. It should tell which partition is "/", ie. boot partition. It should be /dev/hdb1 or something like that. You also should have XP partition mounted, in this example it's /mnt/winxp.

    Just set your computer to boot from primary master again, and it should work.
  3. Justin

    Justin TS Rookie Topic Starter Posts: 942

    I can't boot to linux if the HDD is primary slave. On boot, it gives me a kernel panic saying it cannot find init, and several bad access errors to /hda1.

    The WinXP HDD does not have LILO as the bootloader, which is why I can't just mount it. Linux will not boot unless it is the primary master, how can I fix this?

    Thanks again
  4. Justin

    Justin TS Rookie Topic Starter Posts: 942

    Ok scratch that. I found what I needed to fix and changed it myself, everything worked fine and I can now boot *from a floppy* into Linux.

    LILO is on the second HDD and is not on MBR, so is it still possible to modify XP's bootloader to boot from that HDD? I tried to mount the XP partition, however it refused to mount it because it was NTFS.
  5. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    dd command doesn't require partitions to be mounted, you could use /dev/hda1 or whatever your XP partition is instead of /mnt/winxp.
    Then again, if ntfs support is compiled to kernel, you could mount it by mount -t ntfs *xp partition here* *mount point*.
  6. Justin

    Justin TS Rookie Topic Starter Posts: 942

    Hmm... didn't work.

    I wasn't able to mount the XP partition so I just transferred bootsect.lin via FTP to the XP partition instead, and I added the entry. When I select redhat however, it just gives me a blank screen with a blinking cursor, nothing more.
  7. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    hmm, Linux was installed when that hdd was master, not slave, and now Linux doesn't find the boot files as it's slave..
    Grub could handle this, I'm not sure how LILO behaves. And I've never used NT bootloader to boot to Linux. I'll see what I can find out about this.
  8. Justin

    Justin TS Rookie Topic Starter Posts: 942

    Thanks a lot. I now reinstalled Linux with the HDD as seconday master, I can boot just fine from a bootdisk, but regardless of what I put in boot.ini (whether its path or the actual disk/location) and regardless of whether or not I point to bootsect.lin it either just gives a blank screen or restarts.
  9. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Could you post the contents of /etc/lilo.conf?
    Lilo doesn't seem to be installed correctly for some reason, or bootsect.lin isn't created correctly.
    Lilo should be installed to the first sector of your Linux disk, not to MBR. Then, the first sector from that disk should be copied to c:\bootsect.lin and boot.ini should point to this file. Once again, I repeat that I haven't used NT bootloader for this purpose & I don't use lilo, so I can't guarantee that this will work.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...