Mouse/Keyboard don't work after POST

By Arakasi ยท 10 replies
Aug 22, 2007
  1. I recently had some problems with a bad PSU, and I stripped down the system to just run with mobo, RAM, CPU & GPU to find the problem (didn't know which part was faulty). I got a new PSU, installed everything, and booted.

    While POSTing the lights on the keyboard go on and out (which is normal), but when it says "press DEL to enter BIOS setup" it has already stopped working. It goes on booting into Windows where I found out the mouse doesn't work either.

    When I plug the keyboard out (whilst in Windows) and then back in, the PC gives one short beep. (it does not do this for the mouse, however). After the beep it still does not respond, though. There was a "found new hardware" dialog open, but I don't know what it was for, and since I can't use any of the peripherals (mouse & keyboard) I can't install it either.

    So then I tried clearing the CMOS (I have an MSI K8N Diamond Plus with a handy red button :p ). When I boot, it gives me a screen that says "CMOS Checksum Bad". Accompanied with my obvious swearing and cursing, it gave me two options: either go into setup or load the system defaults. But the keyboard doesn't work so I'm stuck! :(

    So yeah after five weeks without PC I finally get it to boot and then this happens. Please help me out. :(
  2. Rik

    Rik Banned Posts: 3,814

    Do your mouse and keyboard have ps2 or usb plugs?
  3. Arakasi

    Arakasi TS Rookie Topic Starter

    They are both USB but have PS/2 adapters.
  4. Rik

    Rik Banned Posts: 3,814

    Have you tried them both ways with the same results?
  5. Arakasi

    Arakasi TS Rookie Topic Starter

    Yep, I tried using them in USB ports as well, then plugged the adapters back on and tried the normal ports, but still no result.
  6. Rik

    Rik Banned Posts: 3,814

    Can you perhaps borrow a ps2 only keybord? Im thinking it may be down to usb legacy support needing to be enabled in your bios. Its a possibility!!
  7. Arakasi

    Arakasi TS Rookie Topic Starter

    Yes I can get one from the PC downstairs. I'll try that tomorrow. It's getting pretty late now (one hour ahead of you ;) ) so I'm off to bed for now.

    Thanks for your help thus far.
  8. Rik

    Rik Banned Posts: 3,814

    Let me know how you get on or if you have any problems with sorting your bios out and i will help further if needs be.
  9. Arakasi

    Arakasi TS Rookie Topic Starter


    Alright I took a normal keyboard and mouse and it worked!

    I got the "CMOS checksum bad" screen again and chose F2, then chose "Last known good configuration". It booted into Windows and a Found New Hardware dialog opened up. It says "Built-in Infrared Device", and that device driver may be corrupted or missing.

    I have never known of any infrared stuff inside my PC though :p I doubt the new PSU has something infrared on it.. oh well.

    I'm going to fiddle with it until I get my other mouse and keyboard to work. Then I have to solve the CMOS problem (probably the cmos time that is wrong or something? (I hope) )

    And I have to put a ball in this mouse cause I noticed it's
  10. Rik

    Rik Banned Posts: 3,814

    Lmao, ball mouse, vaguely remember one o' them! :)

    Any luck with sorting your usb keyboard and mouse out?

    Have a look for an online mobo manual then post the link and i will see if i can help out further, i think the infra red thing is a minor bios setting error and i should be able to help you with it with the manual.
  11. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    have you tried replacing the CMOS battery?
    Have you updated your BIOS?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...