Multimedia Controllers

By Twigkat ยท 15 replies
Jan 2, 2007
  1. I see this issue has been partly addressed previously, but it seems the problem I have is *slightly* different.

    In Device manager I have yellow question marks next to Multimedia Controller and Multimedia Video Controller.

    I have a Packard Bell Platinum as follows (using Belarc Adviser) s/n: M334800035

    Windows XP Professional Service Pack 2 (build 2600) Asset Tag: 0123ABC
    Enclosure Type: Desktop
    Processor a Main Circuit Board b
    800 megahertz Intel Pentium III
    32 kilobyte primary memory cache
    256 kilobyte secondary memory cache Board: Micro-Star Inc. MS-6309 1.0
    Bus Clock: 133 megahertz
    BIOS: American Megatrends Inc. 62710 07/15/97
    Drives Memory Modules c,d
    30.00 Gigabytes Usable Hard Drive Capacity
    12.96 Gigabytes Hard Drive Free Space

    _NEC DVD-ROM DV-5700A [CD-ROM drive]
    GoldStar CD-RW CED-8080B [CD-ROM drive]
    3.5" format removeable media [Floppy drive]

    QUANTUM FIREBALLP LM30 [Hard drive]
    (30.02 GB) -- drive 0, s/n 186014231284, rev A35.0700, SMART Status: Healthy 256 Megabytes Installed Memory

    Slot '0' has 128 MB
    Slot '1' has 128 MB
    Slot '2' is Empty
    Local Drive Volumes

    PCI288-Q3DII PCI Audio (WDM)
    Unimodem Half-Duplex Audio Device

    So using the above, I went to the manufacturers site and downloaded what I thought were the drivers for the PC (I had done a complete reinstall of XP, wiped the original etc which was W98).

    But still I have yellow question marks which I would like to resolve. Additionally I would like to get another memory chip but am not sure which type to get. On top of that the DVD rom does not work despite using a firmware update (so am probably going to purchase a new internal drive).

    Any advice to solve these issues would be much appreciated!

    Many thanks
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Your PC is of a slightly 'aged' persuasion.
    256MB memory is just about enough to run XP on its own, hardly enough to run more than 1 app at a time.
    Try updating the sound/audio drivers or install the closest generic sound drivers from XP itself. Make sure you have SP2, as well as all the latest XP-updates.
    Try for your specific 'oldie'.
    Don't waste too much time though, a new PC seems to be in order...
  3. N3051M

    N3051M TS Evangelist Posts: 2,115

  4. Twigkat

    Twigkat TS Rookie Topic Starter Posts: 17

    Hello and thanks for your responses. I have SP 2 installed, and I have all the necessary updates.

    Clicking the yellow question mark and selecting update driver does not work as it doesn't find the driver - for both - despite checking what they are and going to (who have been very good to me in the past!) and downloading what I thought was the correct driver. Am still stumped.
  5. N3051M

    N3051M TS Evangelist Posts: 2,115

    Do you by any chance have a TV/digital tv tuner card or capture card installed?
  6. Twigkat

    Twigkat TS Rookie Topic Starter Posts: 17

    Not to my knowledge - although did check with manufacturer on their site who suggest there is a hauppage winTV piece of hardware connected (have checked and downloaded this out of interest to see if question mark got removed, but no!)
  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  8. Twigkat

    Twigkat TS Rookie Topic Starter Posts: 17

    Did just that - it re-found the multimedia audio controller and reinstalled that, which wasn't the problem. There is still a conflict with the multimedia controller and multimedia video controller. It finds them every time I start up but I can't seem to install the supporting drivers as it says it can't find them. I really don't know what else to try.
  9. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Go into Control Panel/System/Device Manager, click on View/Show Hidden Devices.
    Uninstall/remove anything that has to do with those 'marked' multimedia thingies. Uninstall any double or multiple hidden devices that you can find. Always remove the second and/or higher occurrence of those doubles/multiples.
    If your driver files are 'packed' into one .exe file, try Winzip or Winrar to unzip them into a subdirectory. Check that all unzipped files have their full names, not with names such as 'assemb~1.dll'
    Then try 'Add new Hardware' and direct it to these unzipped sub-dirs.
  10. Twigkat

    Twigkat TS Rookie Topic Starter Posts: 17

    This is something I've already done - reinstalled the video card etc. etc. Short of doing another search under the correct driver - in case I got it wrong initially, all I can think of is that there is still a conflict in the BIOS that needs resetting (similar to what I did earlier but for the other cards).

    Incidentally as an addendum to this - having changed the IRQ in the BIOS setup as specified under the earlier link, and then subsequently checked system information, it shows both Multimedia Controller and Multimedia Video Controller sharing the same IRQ number - in this case it is now 10. Previously they were both under 5. I wonder if this is an issue?
  11. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    If you are on broadband, remove/uninstall the modem, that wastes interrupts.
  12. Twigkat

    Twigkat TS Rookie Topic Starter Posts: 17

    Not sure I'm with you - this computer is on a wireless network. Uninstalling the modem will merely find it again on a reboot. If the problem I have is with the multimedia devices then is there not another way to get the correct drivers? I've searched everywhere and the ones I downloaded didn't work.
  13. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Physically remove that modem, you don't need it.
    It takes up an interrupt unnecessarily, thus maybe causing the multimedia problem.
    From your first post: 'Unimodem Half-Duplex Audio Device' also takes up resources unnecessarily.
  14. Twigkat

    Twigkat TS Rookie Topic Starter Posts: 17

    Hi again - I did all you suggested but still no avail. (See here and here for system information for what is happening.

    Sound, display / monitor all seem to work fine, nevertheless - so perhaps I'll just have to live with the question marks.

    Thanks for your help in the meantime, however if you do have any other ideas, I'd be really pleased to hear them!

    At least I managed to successfully install a new DVD drive and some extra RAM so some things are going OK!

  15. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Packard Bell is the only computer that has more serious problems than an eMachine. I would not be surprised to learn your machine was never fixable.
    However, try several earlier versions of drivers, as that often helps. Also, publish the model numbers of those devices into a Google search. You will then get as many as 80 or 100 sites of driver providers... with notes that "such and such driver will resolve the Packard Bell problem" or the WDM... etc."
    Also, try upgrading or updating the motherboard chipset, as that, too, is sometimes a successful fix.
  16. Twigkat

    Twigkat TS Rookie Topic Starter Posts: 17

    Trouble is, I'm completely lost now as to what the drivers should actually be - having tried a few now! I did run Belarc Adviser but it doesn't specify the driver names (apart from the PCI288 sound one which is working fine!)

    I guess I'll just have to put this one down to experience.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...